Homey Community Forum

MCOHome App (v1.2.3)

z-wave
app
#21

A minor update has been uploaded to the app store:

#22

@TedTolboom
Thank you for this app!
Unfortunately I can’t get the app to work with mine CO2 Monitor.

Model: MH9-CO2-WD
(Date: 2018-11-23) EU Z-Wave plus

The message in homey after adding the device:
'“Er is geen geschikte Homey App gevonden voor dit apparaat.
Het apparaat is toegevoegd als Basic- Z-Wave apparaat.”

Translates to:
“Could not find a suitable Homey App for this device.
The device is added as a basic Z-wave device”

Maybe there is a difference in the newest iteration of the device?
Please tell me if I van provide some information so the device is properly recognized in the App.

#23

Thanks for reporting. I guess MCOHOME used new product- and or productType-ID’s for the latest generation.

Can you post the ID’s of the device when added as generic Z-wave device?

#24

Thank you for your dedicated support!
This is the information that Homey shows
(I couldn’t select the text for copy/paste so I hope I didn’t make an error…)

Node ID: 8
Fabrikant ID: 351
Product type ID: 2306
Product ID: 20738
Firmware version: 21250
Device class (basic): BASIC_TYPE_ROUTING_SLAVE
Device class (generic): GENERIC_TYPE_SENSOR_MULTILEVEL
Device class (specific): SPECIFIC_TYPE_ROUTING_SENSOR-MULTISENSOR

#25

I am having missing devices in the App.
But however I see the missing device as Unknown Node in developer>zwave.

While some device is in the app, it is in unknown node in developer>Zwave

I cannot remove this unknown device or find ways to make the device visible in App.

Lastly, I did a uninstall of the app and lose all my devices and repair every single switch successfully but still encounter this issue of unknown nodes in developer view but see the device or missing device in app.

Running Homey 1.5.2 and after upgrade same issue to 2.0.

#26

Hi Ted, can you add the device id in the next release?

Node ID: 8
Fabrikant ID: 351
Product type ID: 2306
Product ID: 20738
Firmware version: 21250
Device class (basic): BASIC_TYPE_ROUTING_SLAVE
Device class (generic): GENERIC_TYPE_SENSOR_MULTILEVEL
Device class (specific): SPECIFIC_TYPE_ROUTING_SENSOR-MULTISENSOR

#27

For which device?

#28

Thank you for the quick response, its this one:

Model: MH9-CO2-WD
(Date: 2018-11-23) EU Z-Wave plus

#29

I use the MH9-CO2-WA, the 230V version.
Homey version 2.0.4

Works, but only temperature is updated.
CO2, Humidity and CO2 alert don’t work.
Shows up as Simpel Z-Wave apparaat.

Properties

Property Value
ID 09e27ca7-8d1a-4596-8fea-520b0366952d
Class sensor
Driver homey:app:com.mcohome — MH9-CO2
Ready Yes
Available Yes
Custom icon No

Settings

Key Value
zw_node_id “71”
zw_manufacturer_id “351”
zw_product_type_id “2305”
zw_product_id “20738”
zw_secure “0”
zw_battery “0”
zw_device_class_basic “BASIC_TYPE_ROUTING_SLAVE”
zw_device_class_generic “GENERIC_TYPE_SENSOR_MULTILEVEL”
zw_device_class_specific “SPECIFIC_TYPE_ROUTING_SENSOR_MULTILEVEL”
zw_firmware_id “20738”
zw_wakeup_interval 0
zw_wakeup_enabled false
CO2_notification 600
zw_group_1 “”
zw_configuration_value “”

Capabilities

Capability Type Value Edit value Last Updated
measure_co2 number null 4 hours ago
alarm_co2 boolean null 4 hours ago
measure_temperature number 22.6 3 hours ago
measure_humidity number null 4 hours ago
#30

@Lennart_van_der_Poel @josbmw appologies for the long wait / delay in implementing this change.
I’ve just uploaded v1.2.2 to the app store, which adds the ID’s for your MH9 devices.

Once Athom approves this update, you can update the app from the app store, need to remove the MH9 device first and re-install it based on v1.2.2 of the app

#31

No problem, thanks!

#32

Hi,
Can I use MH6-HP thermostat with the app, did anyone try it please

#33

Edit: I finally added the MH9 to homey, thank you!

#34

The app is updated to 1.2.2 , when I try to add the MH9 Co meter and press the K2 button I see the zwave channel in the screen of the MH9 and then I confirm adding the device to Homey with the K2 button.

The Homey add device wizard continues and shows the message:
“Een ogenblik geduld, je apparaat wordt toegevoegd” with the turning circle wait animation.
After a few moments this message should disappear and the device should be added but this message will stay there indefinitely.
I already tried turning of the power for the MCO MH9, Homey and telephone and tried to add the device multiple times.

Can anyone try to test adding a device with the latest Homey and MCOHome App 1.2.2 update to confirm that it isn’t a general bug?

#35

Minor app update waiting for App store approval:

#36

@Lennart_van_der_Poel did you resolve your issue already?

Did you try to first remove the MH9 and then re-add it in close proximity to Homey (move Homey to the intended usage area of the MH9)?

#37

It worked, thank you!

1 Like