Homey Community Forum

MQTT Hub/Gateway


#286

hmm…I don’t have a IKEA bulb to test with. Do you have more/other devices with equal problems?


#287

A kaku, NEST.
Nothing works. I only get value changes in paperUI when i change something in the app.


#288

@Marcel_Wolf I Can reproduce the problem, looking into it now.


#289

@Marcel_Wolf Could you try installing the latest version from the homie2 branch?
Next disable all devices (settings > devices) except ‘staande-lamp’ and try setting the value from within OpenHab.

Let me know.


#290

@HarriedeGroot
Reinstalled latest homie2 branch
Disabled all the devices accept ‘Staande lamp’.
Reinstalled Homie MQTT device.
Gives same problem


#291

Anything useful in the log (settings > log)?


#292


#293

I have sort of the same problem. In short:

  • I can control my Homey devices from OpenHAB, and thus also Google Home =)
  • However. OpenHAB never detects device state changes from Homey. Not even if I do a full broadcast.

In MQTT-explorer (on / off device for example):

  • Device state change triggered from openHAB publishes “true” to the “…/set” topic. Homey acts on the change and turns on the device. “True” gets published to “…/onoff” topic.
  • Device state change triggered from Homey publishes “true” to “…/onoff” topic. Nothing on the “…/set” topic. The “…/set” topic for any given device doesn´t even exist until something is published from openHAB.

Will proceed with troubleshooting after work. I suspect it´s an issue with my openHAB config, but not really sure how to investigate further. OpenHAB re-start is first thing on my task list.

Oh, and thanks for an awesome app HarriedeGroot!


#294

We did some debugging already. But the issue of commands not being handled, is not resolved yet…

Probably there’s a small bug in the app2app interface with the MQTT Client. The client reports a successful topic subscription, but does not actually subscribe (no messages are received & send to the hub). When we added a simple flow with a card listening to a general topic (#), the hub received messages again.

Needs further investigation.


#295

Any ideas why I can’t add Hue lights? Same for fibaro dimmers.


#296

Think I found a bug?
If I enable a virtual device under devices tab, the update of all devices stops.


#297

If I understand correct the reason for my problem is a known bug in openHAB mqtt-binding. Atleast the problem seems to be identical to what is being duscussed on eclipse github: https://github.com/eclipse/smarthome/issues/6828

The problem is aknowledged by developers, but the fix seem to be several weeks ahead.

"when freshly added all devices work until OpenHab is restarted at which point all my temperature reports go to NaN and stay that way despite normal MQTT traffic. I have noticed however, that the “control” channels still work, so toggling switches in OpenHab sends out the required MQTT command, and the Homie devices respond - but my temperatures and configuration “readback” that the Homie devices transmit periodically are ignored.

Again, removing and re-adding the devices cause them to start working again until OpenHab is restarted."


#298

Have you tried the Milestone version of OpenHab? This fixed the same errors when i tried


#299

Good catch! Deserves some investigation.
Which virtual device (build in/VD app) did you use? And what kind of virtual device (button/switch, etc.) caused this behavior?


#300

Thanks Bananfluen! OpenHAB 2.5.0.M1 did the trick. Have tried a couple of OH-restarts and the connection comes back (after restart of client and hub app on Homey).


#301

Can it also be that non english letters cause problems? Here in Norway we use Æ,Ø,Å letters. Think that this thing dont like it :slight_smile:


#302

Any ideas why these devices cant be added?
They report just fine…



#303

This app: https://apps.athom.com/app/com.arjankranenburg.virtual
Used a switch.


#304

@HarriedeGroot thanks for the great work, I have some questions/request

  1. for testing it is usefull disable all devices in MQTT Hub and enable only one or two devices. Is it possible to add in the devices TAB a switch “disable all devices” and “enable all devices”

  2. On the settings TAB the Broadcast button is a bit strange, not really clear when pressed on it if the button is activated.

  3. Is it possble to transfer the status of variabels from Homey logica? so they can be used in OpenHAB?


#305
  1. Good suggestion, I’ve put it on the list
  2. It broadcasts all available devices & their current state, so external applications can discover them. Can be useful to get the OpenHAB MQTT device online or update the channel datatypes if ‘dummy’ is displayed.
  3. Probably, needs investigation. As a workaround you can create a virtual device operating on the variable.

I’ll add some additional info about the different settings in the settings instructions tab.