Homey Community Forum

MQTT Hub/Gateway


in addition:

  1. I know. but wat I mean is that the button feels like a text field that I have to press. doesn’t look and feel that I press a button.


FYI: I Changed the button styling & added instructions to the app settings


FYI: the homie2 branch has been merged to beta. A new beta version is submitted for approval to Athom.


Does that mean that we can install it via Homey App store when approved?



Single Flow/Logics App for Homey/Domoticz and others

Try using virtual device from homey itself. app v2.06 settings => Experimental and turn on virtual devices


New beta version is approved & available in the store.


With this new version the dashboard HABpanel isn’t working anymore. see object,object items. after rollback to version 2.02 it’s directly working again without modifications on both sides.



Message seems to-be empty.


version 2.02


@Sat2All I tried both the store version (2.0.4) & installed the beta branch via cli.
Both are working correctly here…I don’t see the empty messages (topic is correctly provided).
Tested onoff & dim level of a Fibaro dimmer, both can be controlled from OpenHAB.

How did you configure the MQTT Hub (app settings)?
Can you try a fresh install of the HUB & provide as much info as possible?


Harrie, first off, thanks for this amazing app.

I also seem to have the same issue. Empty messages on incoming messages, sending seems to work fine. So whenever I have HA turn a light off, it recognizes a message has come in but it doesn’t actually turn the light off. Just using the default settings of the HUB (broadcasting to homie/homey). Already tried a fresh install from the app store. Old version (2.02) seems to work fine. I am on Homey FW 2.04 RC1.


This logging is with hub version 2.04 beta.

Control the light (Fibaro) with wall switch directly and sonos device volume up/down. Also here message is empty. So this test without OpenHAB. Seems something wrong in creating the message in the HuB.

Did a fresh install of hub 2.04. This is during startup of the Hub. ( broadcast) as you can see also empty messages.


There was a small problem with the ‘system state dispatcher’ (topic conflict).
It should be fixed with version 2.0.5. The fix is already available in the beta branch.

Will do some additional tests and push the new version to the store asap.


This is now released in the store… and I wanted to see if the new version worked with the couple of devices I was still having ‘set’ issues with… however…

I also have a couple of reports that it is now not working with my Home Assistant flow and it seems that the state of Homey devices is no longer being sent to the homie MQTT topic, so just for the moment I would be cautious with the 2.0.5 update.



@xAPPO Problem is probably caused by the ‘broadcast system state’ setting.
When I turn of the system state broadcaster, the device states are correctly updated again (can you confirm?).

I can reproduce the issue & I’m looking into it now.


I can’t get the state updates even if I turn ‘broadcast system state’ off. Tried restarting too.

Its awkward to see sometimes with persisted values but I did find this that helps


Pushed a new version to the beta branch (v2.0.6). Hopefully this will fix the above.


seems to-be solving the issues reported. :smiley:


First and foremost, thanks for taking your time to develop this awesome app. Very much appreciated!

I´m running 2.0.6 but don´t get state updates for any device when broadcasting (example below).
I´ve read every line of the log in hub app and can´t find state updates there either.

Have tried:

  • Homey, hub, client and broker restarts (broker runs in Docker on my NAS).
  • Reinstalling hub and client apps several times (even with Homey powerless for 20+ minutes in between).
  • Unistalling / reinstalling mosquitto broker (wiping all stored data).
  • Disable “Broadcast system state” did nothing.

openHAB can find Homey as a thing but is indicated as Offline “Did not receive all required topics”. None of the channels can be linked to items.

Any advice is greatly appreciated and / or let me know if I can help by providing further info, logs etc.

Software versions:
Homey: 2.0.2, Hub app: 2.0.6, Client app: 2.2.1, Mosquitto broker: 1.5.5, openHAB: 2.5.0.M1


Have you tried removing the Nordic letters? Don’t think it likes æ,ø,å