Homey Community Forum

MQTT Hub/Gateway

#426

Beta branch

0 Likes

#427

It did not start to work when I installed it.
I’m trying to investigate myself as well and might have something but I need to check it myself first.

0 Likes

#428

One possible problem I seem to have is that I cannot change the topic in MQTT hub to upper case. In this scenario we need it to say “gBridge/u123” but it always defaults to “gbridge/u123” for me whatever I do. I can change the topic to say something different though (i.e. gbridge/u1234) but it will always become lowercase and the broker topic is case sensitive.

0 Likes

#429

@Camelen And if you turn off topic normalization (under custom settings?)

0 Likes

#430

Same as @Wout_F in the other thread. It started to work.
Also have the problem that I have created all devices in the gBridge connection with normalized names which means that everything needs to be adjusted.

It’s not that big of a deal and totally possible but I’d prefer if I somehow can choose to keep my devices normalized while also having the flexibility of connecting to brokers that don’t use normalized names. If one can come with suggestions =)

As in one thing I can control while the other I can not (since we’re not using our own broker).

0 Likes

#431

Going to make the topic lowercase only when Homie Convention is selected and I won’t touch the topic case if Custom protocol is selected.

0 Likes

#432

I came to the same conclusion in the other thread :slight_smile: (Guide to Connecting gBridge to Homey for Google Assistant). Thanks @HarriedeGroot, that sounds like the perfect solution.

0 Likes

#433

What’s the fun of discussing this problem in 2 topics? And then refer to the other topic? This is becoming very messy!

0 Likes

#434

It is indeed a bit messy and not very obvious what fits in which topic.
When suggesting changes for an app it seems obvious to do that in the topic that is dedicated to the app in question. But in this case we found this “shortcoming” so to speak of the app while trying to connect to a 3rd party service.

At some point we needed (IMO) to migrate the discussion from the topic of the connection to the service to the topic of the app, right?

0 Likes

#435

Going to make the topic lowercase only when Homie Convention is selected and I won’t touch the topic case if Custom protocol is selected.

Isn’t this the exact way it is handled now?

0 Likes

#436

No, the full topic is being normalized when normalization is turned on, because it’s part of the Homie Convention.
This is changed with the introduction of the normalization option in the app settings.
Going to disable this for Custom topic only (won’t touch the formatting of a custom topic).

1 Like

#437

So?

Its just the way it worked out and now the threads are supporting each other…

You, on the other hand are interrupting the conversation with this

0 Likes

#438

Version on the debug branch does not touch the Custom topic anymore.

0 Likes

#439

So the Custom topic stays the same when Normalize is enabled, but the devices do get normalized?
Because that’s a problem (for me at least :slight_smile: ) right now (see other topic :wink: )

0 Likes

#440

@Fire69 Yes. That’s exactly what has been resolved.

0 Likes

#441

Perfect :+1:

0 Likes

#442

Could you try it? And report back if this resolves your issue?

0 Likes

#443

Well… I was going to go to bed, but what the hell, sure! :smile:

Beta branch then?

1 Like

#444

yes

0 Likes

#445

Harrie, a full changelog would have helped pick this up. (Ab)using the homie3 spec to support gBridge worked and there is nothing that mandates the root topic has to be normalised in the spec is there?

I feel we’re creating unnecessary frustrations here in using MQTT-Hub - it should be straightforward, yet this and the other thread are just full of issues for users.

0 Likes