Homey Community Forum

MQTT Hub/Gateway

#446

It’s working again :slight_smile:

0 Likes

#447

That is great news… sorry you had a hiccup.
This is one of the best apps to liberate Homey. Let’s hope lots of people find that too.

1 Like

#448

But who’s at fault?
Is gBridge following the specs correctly? Since they also have the Action and Topic reversed…

0 Likes

#449

It’s OK. Issue is resolved. Let’s move on.

1 Like

#450

You have to look at from ‘which’ device the status is being reported and from which device the ‘command’ is being sent and which device actually ‘controls’ the device. It’s not a straightforward relationship, in this usage where Homey controls the device then the gBridge syntax needs changing.

0 Likes

#451

Do you know if the stable app on the forum is with the normalize that leaves custom topic yet? I get some questions about getting this to work in a Facebook group and it would be good to know.

0 Likes

#452

Available in the store.

Version 2.1.1

  • Improved app startup & shutdown procedures
  • Resolved issues with Client & Hub app install order
  • Resolved some issues in MQTT Client app (un)install handling
  • Skip normalization of custom topics
  • Introduced log levels for 20% speed improvement
  • Home Assistant status topic fix
  • Home Assistant binary sensors fix
  • Fixed the detection of config changes
  • General bug fixes & stability
3 Likes

#453

Thanks to the MTTQ hub and the MTTQ Client app in combination with OpenHab i have a beautiful dashboard.

6 Likes

#454

@HarriedeGroot Are remotes (pulse switches/ tradfri dimmers) working? or should I play around it with Virtual Devices?

0 Likes

#455

@Leon_van_Efferen Do you have specific issues?

0 Likes

#456

@HarriedeGroot I just came back from holiday to find my tablet with HABPanel is not working anymore. I now get the message ‘UNINITIALIZED - HANDLER_INITIALIZING_ERROR’ at Things > Homey, the other broker MQTT Broker is still green and online. Could this be caused by the update of your app since that was the only thing that updated when I was away? I tried restarting/powercycling everything but the issue remains.

0 Likes

#457

I have paired some Kika remotes (APA3-1500R and a kika pulse switch), I enabled them for MQTT but they are not discovered by HA nor is there any activity on MQTT when I press buttons on the remotes. My suggested workaround (Virtual Device) works as expected.

0 Likes

#458

@Julian What happens if you set the percentage scaling to 0…1 under Custom protocol?

0 Likes

#459

FYI: Just resolved a small error in datatype presentation of integer values for the Homie Convention.

1 Like

#460

@HarriedeGroot I tried, but no luck. I also tried to ‘soft’ reset the Hub app yesterday, and now I have another Homie MQTT device, only there the last part of the extension is :device instead of :homey. But that went offline and is not working anymore.

Ah well, I think for me the best solution is to start over again. Lack the knowledge to troubleshoot the whole Openhab stuff so that will probably take me longer :-).

0 Likes

#461

@HarriedeGroot When restarting home assistant all discovered devices are not re-discovered anymore until you restart MQTT app on homey. Is this normal (expected) behaviour? MQTT Hub 2.1.1

0 Likes

#462

@Leon_van_Efferen Did you configure the status messages on HA (birth & last will). The MQTT Hub should automatically broadcast when the HA sends the online status. And restarting the app isn’t necessary, pressing ‘broadcast’ should do the trick.

0 Likes

#463

That’s a neat way of handling the HA non persistent topic tree although I’m not sure it’s working Harrie.

If I manually alter hass/status between online > offline > online I don’t see a broadcast of any topics from MQTT-Hub. In particular there is no homeassistant root topic. Pressing broadcast does create it OK.

Should HA’s birth message cause MQTT-Hub to send everything or just the homeassistant tree , which I think might be all that would be needed as that’s the non persistent one ?

Curiously I have also yet to see an ‘offline’ status from HA’s last will config, it seems a restart of HA is not causing this to toggle and it stays ‘online’. Is it the MQTT broker that implements the last will - i.e. it notices the client disconnect and publishes ? Maybe there’s a timeout needed or something. Might be a bug in HA.

K

0 Likes

#464

@HarriedeGroot Hmm, wanted to start over and deleted the connection(s) to Homey in HABPanel, and added it when it popped up again after restarting everything. Wanted to configure it but apparently it retains its links in OpenHAB somehow because it all worked immediately. Still no idear what caused the UNINITIALIZED error.

0 Likes

#465

Sorry - you may have mentioned this earlier Julian but out of interest what version of openHAB are you running… and do you have auto update turned on for the MQTT-Hub app in Homey?

0 Likes