Homey Community Forum

MQTT Hub/Gateway

The conversion of the temperature value (455 in your sample above) is probably not correctly translated to a valid temperature capability value for Homey (0…1). Same goes for the other way around. The hub detects the existence of the temperature capability correctly and is therefore available in HA.

The source code can be found here (r720):
There’s probably a bug in this calculation: temperature = (value - 153) / (500 - 153);
NOTE: The color temperature command slider (HA) has a range of 153 to 500 mireds (micro reciprocal degrees).

So it’s most likely a shortcoming of the hub.

Thanks for all your comments. Once again - amazing app! Thank you.
Awaiting the full functionality, I made a flow-workaround for my two dimable ikea trådfri bulbs. At least now the color adjustments from HA gets to the lamps, but the feedback of the setting is not done (i.e. slider in HA not updated with latest value)

just bumped into this one, a bit late I know. what you do is amazing Harrie! it all looks like magic to me, it is great and very welcome having such a great and active developer working on this stuff. thanks a million for doing all this and at this rate Homey really becomes something truely awesome!

Is there a tutorial how to do this ?

openhab doesn’t discover my homey devices !

in mqtt explorer is see my devices

People have had mixed results discovering devices using OH2.4. I understand it’s much better in OH2.5M1 and should improve yet again in OH2.5M2. I believe it’s an OH issue with homie support but I’m not using OH currently … it’s just comments I’ve seen.

OH2.5M2 will be an interesting test but I wouldn’t recommend any of the intermediate 2.5 builds unless you’re very technical, and patient. 2.5M2 is due fairly soon.

K

I have it working that I can control and readout my lights using mqtt. I use an android app called mqtt dashboard for this.

The problem I am facing is, that if the app is not running, and I start the application, the current state of the lights is never shown. It only shows the correct state when a light switches state.

I thought the option flag “retain” would fix this, but still when starting the app, I simply do not see the latest state (the app starts with all lights are disabled).

I already selected QoS to number 1, as I have read that this is a requirement for retain to work. In the log messages on the homey, I do see that the android app is subscribing to the lights topic, but it keeps not showing the current state.

Anyone that can help me telling if it is possible what I want? And if so, how do i do that?

Thanks a million time.

When will the beta version become stable? Are the open issues (almost) solved? Thx!

For now the 2 versions will stay alongside.

The MQTT client app needs the ability to unsubscribe from topics using the app2app interface, before the beta will be promoted to stable. This is needed to free recourses after device discovery or removal of MQTT devices.

@roel_hendr Do you have specific issues with one of the two versions?

Excuse my stupidity, I have tried several itterations of this app but I have yet to succeed to update the value of a vitual sensor, either by using Virtual Devices or MQTT Hub-virutal sensors. All I want to do is to update the measure_temperature capability of a virtual sensor by MQTT (from EPS822). Is this even possible with this app?

how do i keep the devices in home assistant? Every time i restart either homey or home assistent all my devices disapear in home assitent and i need to to a new broadcast for them to appear again

Configure the birth & last will messages. The MQTT Hub does automatically broadcast when it receives a birth message from Hass.


They are configured?

Or should i do it somwhere else or in a different way?

@jolerius see: https://www.home-assistant.io/docs/mqtt/birth_will/

great, will it broadcast all devices even after homey reboot?

i have more problems. One of my lights, connected to a qubino dimmer, doesnt show up as light in HASS. So i cant control it from there. Any clue?

I have a problem. I used the hub to sync all my devices to HASS. But one lamp, connected to a qubino dimmer, doesn’t show up as neither dimmer or switch. So i cant control it from hass. The only thing i gett is contact alarm, power, power meter and temperature.

Any fix about this or is it the way it just is? Or can i sync the dimmer in somw way?

al ready tried to broadcast all the devices? or restart the the mqtt hub app? otherwise you can make a virtual dimmer device and use some flows with tags for syncing the virtual with the quoin dimmer;)

Yes tried that. But a vd May be a good idea. I don’t need the dimmer function. So a couple of flows with a vd could really work

I have synced homey to hass without problem. But often i find the devices are out of sync (ex a Light is turned on i hass, but not in homey)

Is there a way to scedule broadcasta or some other way to stay sure that devices are in sync?

@jolerius yes, by using the birth message.

I am a total newbie in this. But why and how will that keep my devices in sync? @HarriedeGroot