Homey Community Forum

MQTT Hub/Gateway


#102

I’m going to investigate further. But right now all my channels seems to be “Dummy” and I don’t seem to be able to communicate with the channels shown. For examples light switches that shows as dummies in openhab. But so far I have only used the gui in openhab so there might be me doing things wrong in openhab.

However what I find more troublesome is this screenshot:

I’m not comfortable with all the data transmitted. Seems to be a lot!


#103

Device property datatypes should be recognized:


#104

The number of packets depends on the number of device state changes. Also at startup, when registering devices, all states of all device properties are published.

Maybe you could try removing the Homie MQTT Device and all configured things (reset all), then try starting fresh by adding a new ‘Homie MQTT Device’.


#105

Yes, I will try to investigate further and restart from scratch. I will also reinstall my rpi to a clean openhab install.

I haven’t had the time to do it today.


#106
  • Open the Docker app in DSM
  • Go to “Registry”
  • Search for “openhab”
  • Select the openhab/openhab image
  • Click “Download”
  • Once it’s downloaded, it should appear under “Image”
  • Select the openhab/openhab image and click “Launch”

It may take a while until the container has started, but once it has, you can go to http://your-syno-ip-address:8080 to access the OpenHAB server.

I’m not sure if the default image will persist any changes made to filesystem within the container. In that respect, Docker is not like a virtual machine that has a “virtual drive”; by default, any changes made to a filesystem from within a Docker container are gone when the container is stopped.


#107

I reinstalled all the homey-apps and i flashed a blank openhab-image on my RPi.
Maybe it would have worked to just restart the gateway once more. I’m not sure.

Anyway now everything seems to be found and the property datatypes is correct. I did link a swich (light) channel to an item but haven’t managed to control things with it yet. Nothing happens if i flip the switch.

And the problem seems to be the OFFLINE-message I get from the status of Homey.
It says “OFFLINE - GONE” Device did not send heartbeat in time.
However when I restart the gateway app it goes to Online for a while (only a minute or two) and then back to offline.

Not sure what the deal is.


#108

ah nice tool, Thanks! that allowed me to debug… i think something went wrong while installing the beta app from the store. Once i installed the homie2 branch from homey-cli it worked.


#109

Correct, the app in the store does not yet contain the implementation for the Homie Convention (auto discovery).


#110

See a few posts back. This is a bug in OpenHAB and will probably be solved in a next release.

I’m able to control my devices, regardless of the offline
status of the Homie mqtt device.


#111

Ah it’s also connected to the 1,5sec thing. Anyway, good to know that you can control your devices anyway. I will continue to do some tests.

I’m considering trying to tie Google Home to OpenHAB for native support for swedish language. And also using HABPanel to make a tablet interface.


#112

Also one mistake I made once was adding a button instead of a switch control for a light switch. Buttons didn’t work, a switch control does the trick.


#113

Do you also receive temperature readings for example?


#114

Yes I receive temp readings, see image below.


#115

Did you get this to work?

I seem to be stuck at OpenHAB finding Homey, Connecting to it and receiving all channels. But when I link a channel to an item, wether it’s a switch or temperature reading it seems to not get any information and doesn’t seem to be able to communicate with the channel.

I’ve been trying to add, remove, refresh and reboot but nothing seems to help.


#116

Yes I think i’m facing the same issue. Pressing a button doesnt show anything in the gateway debug log and my nest temperature is also shown as NaN.

I also tried to manually change dim level and on-off state via MQTT Explorer, this is being printed in the debug log but still nothing happens.


#117

Wow, this is cool.
I already use OpenHAB to expose my lights/switches to a Hue-enabled-device (like Toon thermostat):

And for exposing the lights/switches for my Google Home Hub:


…to make it look like this:


#118

Hi, I’m the developer of homeeToMqtt for homee and just started to investigate or pretty sure switching to homey. And I’m glad to find you did most of the work already. I get the feeling that you’re gateway is under heavy development right now. Implementing homie convention reorganize topic structure. Please keep me informed if when the structure is settled and I’m happy to be a alpha tester.

Great work
Ciao odig


#119

Hi Odig! Welcome onboard.

Yes the gateway app is currently in development state. The first experimental versions can be found on GitHub. Experience & tips for integrations with other systems is very welcome!

Since I updated my Homey to 2.0 lately, most needed are testers for Homey 1.5.13. It’s hard to maintain backwards compatibility.

Yesterday I made some progress with the app settings (WIP; not fully functional yet…).


#120

These settings look good, like what you did with the tabs!


#121

I have installed Mosquitto on my openHABian installation and switched broker from the one on Homey to this one. Now I get all the readings, temperature, watt, on off/status and dim-level but I can’t control anything from openHAB, only read. I might research further when I get some new ideas.

EDIT: And if I check MQTT-explorer, a light switch for example gets an onoff parameter named “set” to change between true and false by openHAB but Homey doesn’t act on this.

Might start working on HABpanel instead also. But that’ll probably take a while to get things to look the right way hehe.