Homey Community Forum

MQTT Hub/Gateway


#162

You seem to have a similar problem to what I had yesterday. Honestly I’m not entirely sure what solved the problem for me, but I did change the broker from Homey app to openHabian Mosquitto. I’d recommend doing that anyway to leave as much load as possible off of homey.

But sometimes it’s just best to restart from the beginning. Uninstall all apps and just go from there once more. I did that and it works great now :slight_smile:


#163

Ow…you guys are using the settings already! :grimacing:
Know these are not fully functional yet. Especially the on/off button has still some issues (read: don’t flip the switch, or else :skull_and_crossbones:).


#164

Just to be clear, do we still need HA for this or can we directly tie Homey and GH together using MQTT?


#165

@Jeroen_Bos Sorry, I don’t understand your question, can you elaborate?
What do you want to achieve?


#166

Well, my question would be: will it eventually evolve into something that would be usable “off the shelf” as a dashboard application for my wall mounted tablet?


#167

@HarriedeGroot Looking for a way to use homeys devices from within GH. So without the ask homey… is that possible using this MQTT stuff above? Can / want to elaborate, im just not that much into MQTT yet.


#168

@Jan_Peeters
Sorry, nope. …

The purpose of this app is to connect Homey to the outside world.
It’s like a ‘hub’ using mqtt as the communication protocol.

It’s not meant as a standalone dashboard app.
There are many others working on those (edit: sorry, wrong link).


#169

I think @Phuturist got this working already? Combined with the great efforts of @xAPPO:


#170

Hi, I am very intrested in this? Can you tell me how to do this and to use it? Thanks.


#171

I have no idea how to PM on this forum, I can not find this…


#172

Click on his name and choose “message”


#173

thanks, but I can not find “message” I get a lot of other “badges” but no message


#174

Hi all, installed the mqtt Gateway for homey 1.5, but is not showing in the settings page. In the Apps window is inside. Any idea what is happening here?


#175

App settings is Homey 2.0 only


#176

Hi, and thanks. Are in 1.5 all devices enabled?


#177

Yes, all devices are enabled by default


#178

@ xAPPO I can not send you a message it seems, can you please send me the code on PM.


#179

I’m on homey 2.0 (software, not hw, right?)… Not seeing the settings either…

  • mqtt gateway v2.0.1
  • mqtt client v2.2.0
  • homey v2.0.2-rc.2

ideas? In mqtt-explorer, I am seeing a 5 homey_abcd.... entries, 1 with the name of my homey, and one called homey… All with status = offline.

Tried to restart gateway and client without luck


#180

Patience guys :slight_smile: , the settings is WIP and can be found on the homie2 branch (install via athom-cli).


#181

Yes I have this working indeed. Most has been described by xAPPO already here: MQTT Gateway

The only thing extra is that you need to connect Google Assistant to Home Assistant as described here: https://www.home-assistant.io/components/google_assistant/ (follow manual setup)

You will then have your Homey devices imported into HA and you can use Google Home to control them in your native language.