Homey Community Forum

NEEO App

app
#115

looks like this will be the future:
Neeo works well you can still use it after those 24 months, but no more adding possibilities.

#116

Well I assume that after 24 months if you need to change a device or need to add a new one you are done and you have a nice paperweight because you cannot acces the online db for the devices, and probably from this day forward no new device drivers will be added. So even if you want to add a new device in the coming two years this will not be possible.

Ah well, never got to install my NEEO properly because it has never got as usable as my Logitech so no big problems for me, only a waste of money and too bad the guy from NEEO got his payday selling the company, normally I do not begrudge someone a good deal but in this case I would rather have seen him getting nothing. I was amazed every time when they published something bad as ‘the best news ever’.

1 Like
#117

Hi @Niels,

Very sad news today, but do you update your app or is this also dead?

#118

I still think the NEEO remote and Homey are a perfect couple. I’m not letting it go that easily.

1 Like
#119

Big Thanks!

#121

We are rooting for you! :grin:

#122

As in trying to root the device?
I have a serial connection to the brain. Any 3.3v UART would do. I’ve tried to bypass eMMC during boot but that’s protected… https://mobile.twitter.com/nklerk/status/1089222397121712128

If you find a way in then I’m all ears.

#123

Haha, no sorry, that was a no pun intended remark! I do not nearly posses the skills to be of help… Hoping that some enthousiast NEEO users like yourself can help the community if the NEEO/4control team decides to drop us simpletons…

#124

Hi @Niels

I have problem, when i press download backup in your app, homey app crashed and closed. Its android tablet, can you please look into this. Thanks

#125

Sorry that’s know, I could remove the button but fixing it I cannot.

If you use developers.athom.com you can go to the app settings and download it on your computer.

#126

Ok, Thanks @Niels.

#127

@Niels
If I add a button capability in the Neeo app and delete it a bit later, will it be removed from the Neeo?
When I add the capability I find it in the Neeo straight away, but when I remove it from the Neeo app it doesn’t get deleted. There is also no “check for update” possibility in the Neeo.

I’m still on Homey v1.5.13

I just also found out that when I add a new device in Neeo and create a recipe it does not put “power on” in the launch. When I add "power on manually in the launch I get Send “hex code” instead of Send “Power on”

#128

@Niels,

Are you still supporting the Neeo app on Homey?

#129

@HansK, here is the answer!

#130

@Tolga

Thanks, but normally Niels responds very quickly. I have 2 problems which you can read in my previous post (Post 112).

#131

@HansK, why you are not updated to V2? I think your problem is then solved.

#132

Wel, he does spent his free time on the the app, and got i guess a normal daily job, a famely, friends, ect ect ect.

So you could have some patience when he give no answer in just 1 day.

#133

@RoyWissenburg

I realize that, but yesterday I read a post of him on planet neeo which made be a bit scared (see his post in topic Shape the NEEO future). He stated that he will support the Neeo app on Homey until he stop using his Neeos. We will never know when that will be. To be clear, I’m not pushing Niels. I really like his Neeo app and his support.

@Tolga

I did not update yet to V2, because there was no desktop flow editor. I know it is there now and I will update my Homey today. Hope that fixes the problems.

#134

Sorry m8 just didn’t notice your post.

I’m not aware of power button issues. But these could be because of the more dynamic approach I took. Have to look deeper into that and might take some time I’m afraid. I’m certain it’s not v1.5 related although v2 is what I’m developing for. What you’re seeing in the log there is a dynamic name. NEEO doesn’t send a POWER ON when it thinks it’s already ON. Also use the when a button is pressed card. Could you validate this? Try adding a shortcut to your NEEO for both power On and off to test.

Removing buttons in the App won’t remove the buttons from the NEEO. This is due the handling of NEEO and not something I have control over.

I keep supporting this App just not the native NEEO drivers like thekodi driver and such.

#135

@Niels,

Thanks a lot for your response. I will try to explain what I want to achieve. Instead of using the Neeo brain for sending IR commands I want to use a Harmony hub. The hub works a lot better and I don’t need IR extender eyes everywhere. Also the Harmony hub can connect to my shield tv via bluetooth. I thought I needed to add the “power on” command at the launch, but that is not needed. I used manual mode instead of assumption mode. Now I don’t get the “Your might need a little help” slide anymore.

The test adding power on and off in the shortcuts worked (via your app and Harmony hub)

But now I have 2 other problems.

  1. How do I create a flow in Homey to trigger a recipe OFF event, so I can stop the Harmony hub activity.
  2. When I add a television I can edit the favorites, but there is no slide available. I can only enable/disable the shortcut slide.