Homey Community Forum

Nest + Homey = Dead API by 31th August

They are making some serious progress at the HA platform

1 Like

That looks like a suitable solution.

Now we need the homey app to support this.
Any developer wants to do a fund raiser?

Looks great this posts

I took a look at the code of Alan Porter, mentioned at the link above,
Its a few python scripts, fetching the data en enabling authorisation.

Maybe @Emile can review a port the code? So Homey can have an official NEST integration again.
So the promise to integrate becomes true again and we don’t have to ditch our beautiful nest thermostats.

5 Likes

Any news ?

3 Likes

very quiet at the moment.

Its official… Nest API is dead for me too :frowning: Athom even removed their app from the store

The removed it already a long time ago

But still working for me😜

Fingers crossed, but still working here as well…

1 Like

A bit selfish… but I wish Google killed it completely so there where more people in this community that would be asking for a new integration :upside_down_face: :smile:

Its a Joke…

I would definitely be in for a new “official” integration from the community. Just in case the support would stop for me as well one day…

No skills to make it here nevertheless

Keep hoping here :slight_smile:

Still working for me, even during the upgrade from Homey to Homey pro.
As backup, I have forked the nest app in github and can install it via homey commandline app installer on a raspberry pi in my network.

And ofcourse I hope that a new app will be developed, but for now thats even no solution for me, because I have nest protects and these are not yet supported via the new google api.

Hoping for support on nest thermostat and protects

Hello @Elmar there is a soution available for the thermostats.

Hi guys, since this morning, I cannot control my nest thermostat anymore. I did no migration so I have no idea what is going on.

I have tried to restart the nest app, but now there is a red triangle on the icon.

And I see this text: This device is no longer availible in the nest account.

Any idea if this can be fixed? Or should I migrate now and try the new method…

I think now is a good time to migrate. The nest SDM is stable.

With me it still works with the old app…

Did you restart Homey already?

Yup, also tried a restart. After that, the red triangle is gone and I can read the temperature in homey. So when I change it on the test, I can see it in homey. But when I try to change the temperature in Homey I’m getting this error: