Homey Community Forum

Netgear Router App - Presence detection and network access

I could not see it in the Netgear app log becuse it doesn’t go back that many days. I looked in Homey Timeline and I can’t see any persons coming home or going away within the dates of the Netgear log.
I have however modify the flows so it only triggers once. I put another And card that the persons has to be away if coming home and has to be home if going away.

Thank for you responding.

Hello NetGear users,

Will the Netgear Router App work correctly with OpenWRT firmware installed on NetGear hardware?

Regards,

Wilco

Nope… it only works with the netgear firmware…

Maybe a little OT.
Does the Netgear Router App support Netgear access points?

We will get an fiber connection soon. I’m looking for a new internal WiFi configuration, preferably with 3 access points. I’m looking for options/combinations where Homey presence will work without issues.

anybody some advise?

If you mean orbi, yes it works with that :sunglasses:

But it will also work with other ap’s, as long as your main router is a netgear and is also doing dhcp for your entire network. I have a r7800 as main router/dhcp, and a r7000 as ap, and a chinese ap too. Presence detection works regardless which ap your device is connected to.

OT @Gruijter
How have you configured the ssid’s of the ap’s? Do you have 1 ssid for all, or do the ap’s have unique ssid’s?

I started giving them the same ssid, but I ran into problems with some devices not coping well with the handover when roaming between cells. So now I have 3 ssid’s. As long as you do not roam while using streaming content (VoIP or video) it works great.

Edit: almost forgot. On the netgears I enabled smart connect, so actually they each have the same ssid on two bands (2.4 and 5G). The Netgear will try to attach a device first on 5G, if the device supports that.

1 Like

Thanks for the answer @Gruijter

I have one Netgear and two TP-Link routers. I have my Netgear set to Smart Connect, so the 2.4 and 5 bands have the same SSID. The AP’s also have the same SSID. I have a feeling that mobile phones have difficulties moving between the 3 routers. So I was curious how you ste it up.

And you did setup one running in router mode, and the other two in ap mode? (Normally you do not want 3 routers in a home network)

Yes!

I checked again (one is actually an ASUS, the other a TP-Link). The Asus (model RT-AC68U) has a dedicated AP-mode. That was simple.
The TP-Link (model TL-WR1043ND) does not have an AP-mode, but I configured it with a static IP, switched DHCP and NAT off and set the SSID to the same as the ‘real router’, my Netgear R7000.

Untill now I have been trying to keep the Netgear app compatible with Homey V1. But I’m working on some functional extensions, and it is hard to maintain compatibility with legacy Homey firmware.

Are any of you still using Homey V1? If so I would like to know why you haven’t upgraded yet to V2.

And let me know if it is going to be a problem for you if the netgear app only supports V2 and higher Homey firmware.

Nice use case for the netgear app: see if your tv is on.

Im working on a major new release with AMAZING new functionality. Hint: it is related to Homey V3 :kissing_heart:

5 Likes

Hi Robin,

I’ve been using your Netgear app in combination with a R7000 for some time now and since one of the latest updates which was around the same time as a firmware update (which resulted in a stable wifi :partying_face:) of the R7000 the presence detection does not work properly anymore. and now i decided to take a better look into the problem.
It only communicates one device with homey and not the rest. the other functions such as traffic and connected devices do seem to show the correct data.

a part of the log which does not seem correct to me :slight_smile:
2019-10-07 08:01:52 [log] [ManagerDrivers] [netgear] [0] login succsesfull @ driver
2019-10-07 08:00:12 [err] [ManagerDrivers] [netgear] [0] updateRouterDeviceState error: Not logged in
2019-10-07 08:00:12 [log] [ManagerDrivers] [netgear] [0] “\r\n\r\n\r\n 401\r\n\r\n\r\n”
2019-10-07 08:00:12 [log] [ManagerDrivers] [netgear] [0] last repsonse from router:
2019-10-07 07:48:33 [log] [ManagerDrivers] [netgear] [0] Offline: 30:4A:26:1C:A8:92 DEV-1C:A8:92
2019-10-07 07:00:09 [log] [ManagerDrivers] [netgear] [0] login succsesfull @ driver
2019-10-07 06:58:28 [err] [ManagerDrivers] [netgear] [0] updateRouterDeviceState error: Not logged in
2019-10-07 06:58:28 [log] [ManagerDrivers] [netgear] [0] “\r\n\r\n\r\n 401\r\n\r\n\r\n”
2019-10-07 06:58:28 [log] [ManagerDrivers] [netgear] [0] last repsonse from router:
2019-10-07 06:41:49 [log] [ManagerDrivers] [netgear] [0] Online: 30:4A:26:1C:A8:92 DEV-1C:A8:92 192.168.1.101
2019-10-07 06:21:52 [log] [ManagerDrivers] [netgear] [0] error getting traffic meter info
2019-10-07 05:58:25 [log] [ManagerDrivers] [netgear] [0] login succsesfull @ driver
2019-10-07 05:56:45 [err] [ManagerDrivers] [netgear] [0] updateRouterDeviceState error: Not logged in
2019-10-07 05:56:45 [log] [ManagerDrivers] [netgear] [0] “\r\n\r\n\r\n 401\r\n\r\n\r\n”
2019-10-07 05:56:45 [log] [ManagerDrivers] [netgear] [0] last repsonse from router:
2019-10-07 05:48:26 [log] [ManagerDrivers] [netgear] [0] Offline: 30:4A:26:1C:A8:92 DEV-1C:A8:92

last week it looked like the log was showing other devices going on and off line but the connected flows do not trigger (setting home away etc). I tried removing the r7000 and adding it again but that did not fix it…

I also tried setting the port from 5000 to 443 but that resulted i no data at all.

the time out is of devices is on 250 seconds and the polling interval is 100secs
firmware version according to the app V1.0.9.88 smart agent 3.0 .

can you help me with this?

hi Fabien, the netgears routers sometimes go into a weird state that can only be resolved with a ptp (power cycle) of the router itself. Did you already try that?

On another note: Behind the scenes I have been completely rewriting the Homey Netgear app. It brings an important new feature: a separate Homey device per device attached to your network. So phones can be added individually, and the presence detection can be much better optimised per device. It will also bring a very nice new function related to Homey V3 (I can tell more once Homey V3 is released)

1 Like

I thought i tried it, but i’ll try that when i get home. i’ll let you know!

And the behind the scenes note makes me and probably others curious :slight_smile: , can you (are you allowed to) give an estimate on the homey V3 release?

:soon::joy:

1 Like

I tried rebooting and it seemed to work for a bit With reporting device online offline but now the logs show the same 401 and other errors and the online offline feature does not work .

It does look like a bug in the router firmware, since after ptp it works for a short while. But if you create an issue on github, and include the test result from the compatibility test there, I can investigate some more.

Breaking news: A major app update is coming really :soon:

(no really, it’s breaking news :grimacing: )

1 Like