Homey Community Forum

Netgear Router App - Presence detection and network access


The new version can now be downloaded from the appstore.


Anyone that can test the WakeOnLan with password?


Would it be possible to make a list of detected devices to pick from in the condition cards?
To add my MAC addresses I have to keep switching between apps on the phone and the router app doesn’t have a copy function for the field so I either have to write it then type it or keep switching back and forth.


I will put it on my todo list for the next release :+1:

1 Like

@Adrian_Rockall I just checked, but the condition cards already has an autocomplete dropdown. You only need to start typing part of the device name or part of the mac address. Are you on the latest version (2.2.0) ?

Or maybe I don’t understand what you mean?

Or are you on Homey V2? If so start an issue with Athom, because in the desktop flow it works :slight_smile:


I am using homey V2. I have used the Logic card in the And section to check for an exact match on the MAC tag from the Device went online / offline.
All I get is an edit field to type the text into.


Ah, must be a Homey V2 bug then. :open_mouth: just revert back to HomeyV1, add all your apps, pair all your devices, redo all your flows, and you’re good to go :rofl:


I was getting bored and wanted something to do for the next couple of days lol.
I will report it to Athom and await a fix.


new version 2.3.0 is pending approval by Athom.

Fixes timeout / socket hangup for certain router types. Adds Homey V2 icons and Insights.

1 Like

I have been using the Netgear App for over 2 week, as presence detector.This worked great!

Since a day or two (updated App??) I get away/present triggers multiple times a day… Even my wired Mac is seen as ‘new device’ occasionally. Seems that something was changed in the App and now MAC’s go offline after a while, although they are still present (but sleeping / hibernating).

This behaviour is new; the first two weeks of testing, this did not happen!

App version = v2.3.1
Homey f/w = v1.5.13


Hi there! I have an issue with the latest update; 2.3.1. Somehow the app cannot login to the router anymore. The message I get is ‘Failed to login’. I also tried Soap 5000. I use Homey 1.15.13. Thanks for your help!


mmh, actually in the last update only a pairing issue wit certain router types was changed. Could you create an issue on github, and post the relevant logs there?


Could you create an issue on github, and post the relevant logs there? Please also include the compatibility test there (can be found under app settings)


Hi Gruijter, thanks for your quick reply. I restarted both Homey and the Router and now it all works again. Very happy with thes great app!

1 Like

V2.3.2 was just released in the appstore. I made some small changes (login method). I hope this solves the login issues that @Eternity was experiencing :slight_smile:


I changed the flow to include the Homey logic + tag (MAC) and it’s working again.

I bet it was my own fault… :disappointed:


:joy: thx 4 letting me know

1 Like

I have an R6220. Compatibility check seems oke, but I do not get any status. I’m running the latest version of Homey.

Anyone else this problem?


I remember I had to switch on stuff before this information was available. I did it via an Android / Netgear App, but i bet it is in your web router interface too!

Found it in the opening post:

For up/download speed, enable the traffic statistics: routerlogin.net > advanced setup > traffic meter.


Hi Eternity,

You are right. But I enabled that but without any success. Thnx


New version 2.3.4 is ready for release in the appstore, just waiting for approval.

It has small fixes, and a major overhaul of the settings User Interface. It is now optimized for mobiles on Homey V2.