Netgear Router App

router
netgear
app

#1

https://apps.athom.com/app/com.gruijter.netgear

Netgear

App to make Homey interact with Netgear routers.

See and log:

  • internet connection status
  • the internet upload and download speed
  • the number of attached devices

Act on:

  • detection of a new attached devices
  • device coming online or going offline (presence)
  • change of up/download speed
  • change of internet connection status
  • results of internet speed test
  • new router firmware available

Do:

  • block and allow an attached device by MAC address
  • enable and disable Guest Wifi
  • perform internet speed test
  • perform firmware upgrade
  • reboot the router

image

Device setup in Homey

Only netgear devices that work in router mode have been tested. Your Homey should be connected inside the LAN part of the router, not from outside (WAN). To setup go to “Devices” and add the Netgear router by filling in the admin password. The other fields can be left on default, unless you know what you are doing :). After the router device is added successfully you can change the polling interval (set to 1 minute as default). The app will start collecting and remember MAC addresses of all devices that ever connected to the router. If you need to clear this list you can do so by checking the box “delete devicelist” in the device settings.

One time setup of the router

For Homey to get all the functionality you need to do some one time settings in the router. Depending on the router type and firmware you might not have some of this functionality. Make sure you are on the latest router firmware.

  • For up/download speed, enable the traffic statistics: routerlogin.net > advanced setup > traffic meter.
  • To be able to block or allow a device, enable access control: routerlogin.net > advanced > security > access control.

Supported routers

In general: If you can use the genie app to manage the router then my app will likely do something. The app has been confirmed to work with WNR2000v5, WNDR4500v2, R6250, R7000, R7800, R8000 and Orbi.
You can check your router version by browsing to http://routerlogin.net/currentsetting.htm . According to the NETGEAR Genie app description, the following routers might work:

Wi-Fi Routers: Orbi AC1450 Centria (WNDR4700, WND4720) JNR1010 JNR3210 JR6150 JWNR2010 R6050 R6100 R6200 R6220 R6250 R6300 R6400 R6700 R6900 R7000 R7500 R7500 R7800 R7900 R8000 R8300 R8500 R9000 WNDR3400v2 WNDR3700v3 WNDR3800 WNDR4000 WNDR4300 WNDR4500 WNDRMAC WNR1000v2 WNR1500 WNR2020 WNR2020v2 WNR2000v3 WNR2200 WNR2500 WNR3500Lv2 WNR612v2 WNR614

DSL Modem Gateways: DGN2200B DGND3700B D3600 D6000 D6100 D6200 D6000 D6200B D6300 D6300B D6400 D7000 D7800 DGN1000 DGN2200v3 DGN2200v4 DGND3700v2 DGND3800B DGND4000

Cable Gateway: C7000 C6300 C6250 C3700 C3000 N450

Compatibility test

If your router isn’t working properly with this app, you can perform a compatibility test from the app settings tab. After performing the test you will be directed to the developer page on Github. Here you can create an issue, and paste the test result. Note: you need an account on Github to be able to create an issue.

image

Donate:

If you like the app you can show your appreciation by posting it in the forum.
If you really like the app you can buy me a beer.

Paypal donate

===============================================================================

Version changelog

v2.0.9	2018.10.27 Netgear module updated to 3.0.8. Added auto discover. Improved pairing.
v2.0.8	2018.10.23 Netgear module updated to 3.0.6. More router types supported. New xml parser. Condition cards added. Router compatibility test added.
v2.0.7	2018.10.09 Netgear module updated to 2.2.0. Speedtest added. Fw update added. Guestwifi fix. Pairing fix.
v2.0.6	2018.09.29 GuestWifi2 support added.
v2.0.5	2018.08.19 Fix autoport detection. Netgear module update to 1.4.0
v2.0.4	2018.08.12 Reduce memory usage. Netgear module optimizations.
v2.0.3	2018.06.11 Fix autocomplete for corrupted devicelist. Small fixes.
v2.0.2	2018.03.24 Action card added for disable/enable guest wifi.
v2.0.1	2018.01.19 Hotfix. XML parser reverted.
v2.0.0	2018.01.15 Replaced the XML parser to a lightweight version
v1.3.1	2018.01.10 Minor fixes. Debug logger updated.
v1.3.0	2017.12.09 Fix option to empty the known devices list. Added automatic soap port detection during pairing.
v1.2.0	2017.11.29 Compatible routerlist greatly expanded. Bugfix up/down speed.
v1.0.0	2017.11.13 First stable release


#2

reserved for future use


#3

Hello Gruijter! I`ve connected the app with my router, but I am getting an error:
“2018-09-30 21:13:47 [err] [MyApp] unhandledRejection! TypeError: Cannot read property ‘0’ of undefined at parseString (/node_modules/netgear/netgear.js:462:97) at Parser. (/node_modules/xml2js/lib/parser.js:303:18) at emitOne (events.js:116:13) at Parser.emit (events.js:211:7) at SAXParser.onclosetag (/node_modules/xml2js/lib/parser.js:261:26) at emit (/node_modules/sax/lib/sax.js:624:35) at emitNode (/node_modules/sax/lib/sax.js:629:5) at closeTag (/node_modules/sax/lib/sax.js:889:7) at SAXParser.write (/node_modules/sax/lib/sax.js:1436:13) at Parser.exports.Parser.Parser.parseString (/node_modules/xml2js/lib/parser.js:322:31)” - am i doing something wrong?


#4

Hi Thomas. Thx for trying the app and reporting back. Could you please start an issue here:

and post there the outcome of this link: http://routerlogin.net/currentsetting.htm

Thx!


#5

After the last update I can not connect my router anymore.
I removed the Device Icon (It was showing a broken chain symbol) and tried to reinstall but I’m not able to (re)connect.
Receiving the error, by pushing the test button: connect ECONNREFUSED xxxxxxxx:5000 Where xxxxx is my Ip adress.
I do have the Nigthhawk X6 R8000.
It worked fine before the update
I changed the SOAP port to 5000 (It was that number the version before)
Also not changing the SOAP port is not working (I don’t know what the SOAP port is about)


#7

I have the same problem…


#8

New update is pending approval that should fix the pairing of r8000. In the meantime you can pair manually by entering your password, and use 5000 as soap port.


#9

Concerning the xml parse error: please check the issue that has been created on github:


#10

Hello Gruijter !

Thank you for your work ! Unfortunately it doesn’t work for me :cry:

I’ve tried the netgear homey app via the Homey App Store and get a “ECONNREFUSED” when a I want to connect.

Then I installed the last version via your github and the result is the same.

My Homey have the access control.

My routeur remote access is activate with port 8080.

My Router is a R7000 and here ici the log from Homey:

"2018-10-09 00:26:22 [err] [ManagerDrivers] [netgear] Pair error connect ECONNREFUSED 192.168.1.1:8080

2018-10-09 00:26:22 [log] [ManagerDrivers] [netgear] using as soap host/port: 192.168.1.1:8080

2018-10-09 00:26:22 [log] [ManagerDrivers] [netgear] {“Firmware”:“V1.0.9.42_10.2.44”,“RegionTag”:“R7000_WW”,“Region”:“ww”,“Model”:“R7000”,“InternetConnectionStatus”:“Up”,“ParentalControlSupported”:“1”,“CircleEnabled”:“0”,“OpenDNSEnabled”:“0”,“SOAPVersion”:“3.21”,“LoginMethod”:“2.0”,“ReadyShareSupportedLevel”:“29”,“XCloudSupported”:“1”,“DeviceMode”:“0”}

2018-10-09 00:26:22 [log] [ManagerDrivers] [netgear] save button pressed in frontend"

Here is info of “routerlogin.net/currentsetting”:

Firmware=V1.0.9.42_10.2.44 RegionTag=R7000_WW Region=ww Model=R7000 InternetConnectionStatus=Up ParentalControlSupported=1 CircleEnabled=0 OpenDNSEnabled=0 SOAPVersion=3.21 LoginMethod=2.0 ReadyShareSupportedLevel=29 XCloudSupported=1 DeviceMode=0

I don’t know what to do now ?

Have a nice day :slight_smile:

Julien


#11

Hi Julian

For r7000 the soap Port is 5000, not 8080 :grinning:


#12

Hello Gruijter,

It was 5000 but it did work with it so I changed it in Netgear config but error message is still the same…

I can printscreen my “Remote access” page from netgear when I’m home if it’s use full for you ??

Any other solution for me ??

Thank you for your quick answer :grinning:,

Julien


#13

Remote access is not what you need for this app. You really need port 5000 for the R7000 (I tested a r7000 myself just yesterday, and it works great!)

Try these steps:

  • your homey must be connected to the wifi of the r7000
  • uninstall the netgear app from homey
  • restart the r7000 (power off and on)
  • restart homey
  • install the app
  • add router in devices
  • make sure to only type in the password, and port 5000

It should then work…

If not, please report an issue via github


#14

heyyyy !!

I’ve just try soap 5000 again and it works :heart_eyes:

Thank you Gruijter !

Have a nice day,

Julien


#15

:muscle::muscle:


#16

New version is in the making :stuck_out_tongue:

Cool new features:

  • enable/disable second guest wifi
  • perform internet speed test
  • check for new router firmware
  • update the router firmware

2018-10-09%20(1)


#17

Dear community,

Should I also add a condition card (and column) for the ‘new firmware available’? Or would that be waisting precious time on something nobody needs?


#18

New Version had been releases. Because of the overwelming requests for a conditions Card for checking New firmware, this Will be included in a next release.:joy:

The next release Will First be Published as beta because it has significant rewrites in the software. It will further reduce Memory usage, and Will support even more routers!

Stay tuned on this Channel😘


#19

Thanks a lot for your work Gruijter !


#20

And here i Go, can´t access, i have a wnr3500l, any tips, port 80, 8080, 5000, 7000 does not work.


#21

Hi @Skee,

Soap Port is Always 5000 or 80. But if you leave the field on 0 during pairing it should find the port itself. Let me know if it works for you.