Netgear Router App

router
netgear
app

#22

I bought a new netgear wnr2000v5 €20 router and it now works.

could have been my old 3500 that was just to old.


#23

Wow, 20 euro’s is really a good deal on a new router. Glad it works for you. I will add the WNR2000v5 to the list of routers that have been confirmed to work. Thx!


#24

The new version of the app is now available in the appstore as beta release.

v2.0.8 2018.10.23 Netgear module updated to 3.0.6.
More router types supported.
New xml parser. Condition cards added.
Router compatibility test added.

It supports more router types, has improved handling of corrupt xml messages coming from the router, and has improved address and port discovery during pairing.

Furthermore, if you are having problems to pair or use your router, you can now run an extensive test and upload the result to github. With this information I can try to solve the problem for you in a next app release🤗


#25

new flow cards available ^


#26

After beta update again I’m not able to pair my r8000
I tried everything
only password
password and ip
password, ip and port
Nothing worked

I did a test giving:

starting test on Netgear package version 3.0.6
trying to auto discover the router...
{message:No valid SOAP port found on the host address}
{host:192.168.2.1,username:admin,password:*****,timeout:10000,sessionId:A7D88AE69687E58D9A00,cookie:[XSRF_TOKEN=1222440606; Path=/],loggedIn:false,configStarted:false,soapVersion:3,loginMethod:1,guestWifiMethod:{},lastResponse:Firmware=V1.0.4.18_10.1.49\r\nRegionTag=R8000_WW\r\nRegion=ww\r\nModel=R8000\r\nInternetConnectionStatus=Up\r\nParentalControlSupported=1\r\nCircleEnabled=0\r\nOpenDNSEnabled=0\r\nSOAPVersion=3.21\r\nLoginMethod=2.0\r\nReadyShareSupportedLevel=29\r\nXCloudSupported=1\r\nSmartNetworkSupported=0\r\nDeviceMode=0\r\n}
getting currentSetting...
{Firmware:V1.0.4.18_10.1.49,RegionTag:R8000_WW,Region:ww,Model:R8000,InternetConnectionStatus:Up,ParentalControlSupported:1,CircleEnabled:0,OpenDNSEnabled:0,SOAPVersion:3.21,LoginMethod:2.0,ReadyShareSupportedLevel:29,XCloudSupported:1,SmartNetworkSupported:0,DeviceMode:0}
trying to login...
{message:Cannot login: host IP and/or SOAP port not set}
{host:192.168.2.1,username:admin,password:*****,timeout:10000,sessionId:A7D88AE69687E58D9A00,cookie:[XSRF_TOKEN=1222440606; Path=/],loggedIn:false,configStarted:false,soapVersion:3,loginMethod:1,guestWifiMethod:{},lastResponse:Firmware=V1.0.4.18_10.1.49\r\nRegionTag=R8000_WW\r\nRegion=ww\r\nModel=R8000\r\nInternetConnectionStatus=Up\r\nParentalControlSupported=1\r\nCircleEnabled=0\r\nOpenDNSEnabled=0\r\nSOAPVersion=3.21\r\nLoginMethod=2.0\r\nReadyShareSupportedLevel=29\r\nXCloudSupported=1\r\nSmartNetworkSupported=0\r\nDeviceMode=0\r\n}

Discover router gives a red triangle


#27

Hi @Canedje,

Is your r8000 set to router mode, or to bridge mode? The app only supports router mode! (Although a new stable version is waiting aproval that should work better with netgears in bridge mode)

Is 192.168.2.1 indeed the right ip address of your r8000? If so, can you try running the test by manually entering this ip and using 5000 as soap port?


#28

I did restart my router.
After restart I could connect again


#29

The new version 2.0.9 has been released as stable version. This version supports even more router types, and has an auto discovery function during pairing.

Also check out the new flowcards to check if an ip address is in use, or if a new router firmware is available.


#30

I have setup my new Orbi RBK 23 as access point and i guess this is not working?
After adding the router it works for a very short time.
orbi-2
The internet connection is always shown as No
And after about 30 seconds it all goes to 0
orbi-1

If i do the test i do get this result

===========================================
starting test on Netgear package version 3.0.8
trying to auto discover the router...
{Firmware:V2.2.1.210WW,RegionTag:RBR20_WW,Region:ww,Model:RBR20,InternetConnectionStatus:Down,ParentalControlSupported:1,OpenDNSEnabled:0,CircleEnabled:0,DeviceMode:1,SOAPVersion:3.46,ReadyShareSupportedLevel:0,XCloudSupported:1,isBlankState:0,LoginMethod:2.0,host:192.168.178.105,port:80}
trying to login...
login method: 2
trying to getInfo...
{ModelName:RBR20,Description:Netgear Smart Wizard 3.0, specification 1.6 version,SerialNumber:**********,SignalStrength:-4,Firmwareversion:V2.2.1.210,SmartAgentversion:3.0,FirewallVersion:net-wall 2.0,OthersoftwareVersion:N/A,Hardwareversion:N/A,Otherhardwareversion:N/A,FirstUseDate:Sunday, 30 Sep 2007 01:10:03,DeviceName:NetgearWifi,DeviceNameUserSet:false,FirmwareDLmethod:HTTPS,FirmwareLastUpdate:2018_11.5_20:23:16,FirmwareLastChecked:2018_11.9_16:51:49,DeviceMode:1,DeviceModeCapability:0;1}
trying to get supportFeatures...
{OpenDNSParentalControl:1.0,CircleParentalControl:1.0,OrbiTribandSupport:1.0,AccessControl:3.0,SpeedTest:2.0,GuestNetworkSchedule:1.0,TCAcceptance:1.0,SmartConnect:1.0,LightingLED:1.0,TimeZone:2.0,SatelliteInfo:2.0,NameNTGRDevice:1.0,AttachedDevice:2.0,MaxMonthlyTrafficLimitation:4293918720,SystemWps:1.0,SystemDfs:1.0,AvsSupport:1.0}
trying to get attachedDevices...
Number of attached devices: 38, method: 2
trying to get Guest Wifi Status...
2.4G-1 Guest wifi enabled: false
5.0G-1 Guest wifi enabled: false, method: 1
5.0G-2 Guest wifi is not available
trying to get trafficMeter...
{newTodayUpload:2156,newTodayDownload:463.8,newMonthUpload:2156,newMonthDownload:463.8}
trying to check newFirmware...
{currentVersion:V2.2.1.210,newVersion:,releaseNote:}
trying to logout...
test finished o.k. :)

If i look in the setup page of the router is says internet connect: Good

Is this because i am in AP mode on the router?

Thanks


#31

Hi @Gijsje

Actually, the test shows all is working good. The app is intended for router mode indeed. So the internet status and speed might be not working in AP mode. Did you enable traffic statistics in the netgear?

I do think that most flow cards should work. If you test it, let us know which work and wich don’t.

:+1:


#32

Thinking about the internet status. I think I can add an option to let Homey get the internet connection status, in stead of the netgear device. This would then give you the connection state, even if you use the netgear in AP mode.

I could add that to a next app release. Would anybody be interested in that?