Homey Community Forum

[NEW APP] Kia UVO and Hyundai Bluelink

Yes! It’s working!

1 Like

Hello Robin,
I’ve installed the Kai and Hyundai app just today and it’s working propperly until now, thanks for your effort so far.
Is is possible to start loading my Ioniq with the Homey app?
This seems the most important feature to me, so i can combine my Ioniq with my smart meter and make a flow that the Ioniq automatically starts loading when I delivering back to the grid.

Greets, John

Start / stop charging is definitely on my list to implement. But Im depending on the developers that create the library.

I am already testing it with Kia EU, but it needs more reverse engineering also from my side. At this stage it does not work the way I expect / would like it to work. Once I have it working o.k. for Kia, it should be possible to make it work for Hyundai as well.

By the way: I use a 16A plugwise plug at the moment to start/stop charging based on my smart meter readings.

1 Like

Thanks for your early reply Robin.
I’m using BeNext smarthome already to read my smart meter and switch the socket for loading the Ioniq, but it would be nice to do everything in the Homey

How cool to have the EV connected to Homey! Bummer that is only Homey V5 sdk3 compatible.
I’m in the “I don’t want to upgrade to 5, since 3/4 of my home will stop working if I do” phase. I assume many others among us have the same issue. Many community developers are programming there ass of to keep everything working.

It is not your fault that Homey do their stupid upgrade or die move (again).

well, v5 will be stable :soon:. So everything is solved by then :wink:

If i install the Kia and Hyundai App en connect my Ioniq to my Homey, the Hyundai Bluelink app connection with the Ioniq doesn’t work anymore.
So I removed the Hyundai bluelink app from my Homey.
Hopefully this problem can be solved

Well, it might not solve itself :stuck_out_tongue_winking_eye:

So if you think there is something wrong in the Homey app, please create an issue on github with details on what is not working and how that happened.

Please check the frequency of your data query. I got a love letter today:

"Dear customer,
We have noticed an unusually high data usage related to your UVO account.
According to our internal research, this is because of the use of a third-party app, not developed by Kia Motors, which is consuming data assigned to the UVO Connect Services.
However, this violates our Terms of Use (see Section 4.1) and we have the right to terminate the contract in the event of a material breach (see Section 9.6).
We therefore ask you to stop this activity immediately. If we do not notice any change in data usage two days after receiving this email, your vehicle’s SIM card will be blocked and you will no longer be able to use the UVO Connect services.
With best wishes,

Kia UVO Connected"

Yes, on forums I see Kia and Hyundai are doing this at least in Germany and NL. You can set the poll interval yourself by the way, in advanced device settings. Default is once per minute.

But I will probably have to re-invent the app where you can use it to start charging, to defrost, and know where it is parked. But not realtime info when you are driving :pensive:

I got the same message here in Sweden (but translated into Swedish). To bad and to sad

I’m trying to use this app with my Kia Soul EV, but I’m not seeing any data when opening the device.

Checking the logs I see the following error:
2020-10-16 17:49:47 [err] [uvo] [0] TypeError: Cannot read property 'batSoc' of undefined at UvoDevice.handleInfo (/drivers/generic_device.js:409:46) at UvoDevice.doPoll (/drivers/generic_device.js:317:10) at processTicksAndRejections (internal/process/task_queues.js:97:5) at async

So you are able to add your car to Homey? Try removing the device from Homey, then change your password from the UVO app, and add the car again to Homey with the new password. If it still does not work please create an issue on github and post the entire log, including the pairing process.