Homey Community Forum

Node Red: A widget based dashboard working with Homey trough MQTT

Thanks man! Or women :grin: will definitely try it out after i get a little more familiar with node red

Is anybody encountering problems with their Node-Red dashboard since the Homey v5 update?

All my dashboard controls are no longer working. I can click on the different switch nodes and the dashboard will change state but it seems that no MQTT signal is being send since the devices are not responding.

Sending MQTT signals from Homey is working, since i can control the Sonoff tasmota via homey. However when i do so, the dashboard is not showing the correct state.

Maybe somebody can put me in the right direction?

Have you tried restarting MQTT Hub and MQTT Client on Homey? Sorted out the same problem for me. (Homey not responding on Node-Red)

I rebooted the Client and the Broker. But not the HUB. That did the trick!
Thank you

Past week the MQTT Hub went through some updates.

Most users are upgraded by now, so I would like to know if anyone encountered issues?
Or maybe you have suggestions for improvements to make your live a little easier?

Thought I should ask here to, most of the heavy users are probably around here somewhere :slight_smile:

1 Like


Wow Harrie, you’ve been buzzy.

To be honest, I don’t notice any difference. But that’s probably a good thing :smile:
Now I think of it, in the past couple of weeks I did had an unresponsive dashboard. I restarted the client and hub and then it worked fine. Don’t know if it’s related to these updates. I didn’t put much thought in it.

Just scrolled trough the Changelog. I don’t think there’s something I had a problem with. To be honest, most thing are above my MQTT knowledge :sweat_smile: Are there things that changed the interaction with Node-red?

Anyhow, big thanks for keeping this project updated/supported! Just bought you a couple of Corona Beers! :beers:

1 Like

The biggest change is probably the upgrade to SDK 3. The app API has been improved by Athom. Combined with v2.4.2 of the MQTT Client (test version) it should be an improvement in connectivity between Hub & Client. The rest is mostly some bug fixes & extended functionality of the MQTT Device.

The MQTT Device is a powerful device operating on mqtt messages. It links Homey capabilities to MQTT topics. E.g. add a button to send an on/off message to some mqtt topic or display an external sensor value within Homey on a virtual device. All fully configurable.

2 Likes

@HarriedeGroot My dashboard is a bit unresponsive since the update. The lights controls on my dashboard do not show the on/off status when i control them via the homey app. However the light controls on my dashboard are working. It looks like the dash can send the MQTT signals but cannot receive them.

This node was working fine before:

   [{"id":"a08b2174.7fb8a","type":"mqtt in","z":"48518d4f.6375e4","name":"Back Door","topic":"homie/homey-topic/backdoor/onoff","qos":"2","datatype":"auto","broker":"d094d3b7.a558a8","x":420,"y":1238,"wires":[["6c50e10d.feaf7"]]},{"id":"6c50e10d.feaf7","type":"function","z":"48518d4f.6375e4","name":"Convert String to Boolean","func":"if(msg.payload === \"true\"){\n   msg.payload = true;  \n}else{\n   msg.payload = false;\n}\nreturn msg;","outputs":1,"noerr":0,"initialize":"","finalize":"","x":690,"y":1238,"wires":[["4a6e3509.b3aaac"]]},{"id":"4a6e3509.b3aaac","type":"ui_switch","z":"48518d4f.6375e4","name":"Back door light","label":"","tooltip":"","group":"2cc829a5.610f36","order":32,"width":1,"height":1,"passthru":false,"decouple":"false","topic":"homie/homey-topic/backdoor/onoff/set","style":"","onvalue":"true","onvalueType":"bool","onicon":"http://192.168.178.106:1880/images/bulb-on.png","oncolor":"yellow","offvalue":"false","offvalueType":"bool","officon":"http://192.168.178.106:1880/images/bulb-off.png","offcolor":"black","x":940,"y":1238,"wires":[["77a0e409.4af4bc"]]},{"id":"77a0e409.4af4bc","type":"mqtt out","z":"48518d4f.6375e4","name":"MQTT Transmitter","topic":"","qos":"","retain":"","broker":"d094d3b7.a558a8","x":1270,"y":1258,"wires":[]},{"id":"d094d3b7.a558a8","type":"mqtt-broker","name":"Homey MQTT","broker":"192.168.178.83","port":"1883","clientid":"","usetls":false,"compatmode":true,"keepalive":"60","cleansession":true,"birthTopic":"","birthQos":"0","birthPayload":"","closeTopic":"","closeQos":"0","closePayload":"","willTopic":"","willQos":"0","willPayload":""},{"id":"2cc829a5.610f36","type":"ui_group","name":"all","tab":"6766858b.dee74c","order":3,"disp":false,"width":20,"collapse":false},{"id":"6766858b.dee74c","type":"ui_tab","name":"Dash","icon":"home","order":1,"disabled":false,"hidden":false}]

@Khoi_Ho_Si did you restart the MQTT client & hub apps?

@HarriedeGroot Yes i did, several times.
Does the order matters? I also restarted the MQTT broker, not sure if that was needed.

Maybe worth mentioning: the Fibaro dimmers are working properly the issue only occurs with the Sonoff (with tasmota)

I have a problem that my sensors are not updated, when I look with the mqtt explorer at the broker, updates seems to be received but the same value is received. I restarted the client and hub many times already, all devices are selected from the hub app.
20210409-08:37:09 received ‘61’ on ‘homie/homey/airco-zolder/se-last-seen-seconds’
20210409-08:37:09 Trigger generic card for homie/homey/airco-zolder/se-last-seen-seconds
20210409-08:37:09 send message to listeners via realtime api
20210409-08:37:09 homie/homey/airco-zolder/se-last-seen-seconds: 61
20210409-08:37:15 SendMessageToTopic called
20210409-08:37:15 SendMessageToTopic: {“qos”:0,“retain”:“1”,“mqttTopic”:“homie/homey/pompvloerverwarming/measure-voltage”,“mqttMessage”:230.09}
20210409-08:37:15 publish_options: {“qos”:0,“retain”:true}
20210409-08:37:15 send 230.09 on topic homie/homey/pompvloerverwarming/measure-voltage
20210409-08:37:15 OnMessage called
20210409-08:37:15 received ‘230.09’ on ‘homie/homey/pompvloerverwarming/measure-voltage’
20210409-08:37:15 Trigger generic card for homie/homey/pompvloerverwarming/measure-voltage

edit:
I think I solved part of the issue my self;


screenshot of mqtt explorer, I was using topics from the deviceid section

anybody an idea how to use a mqtt value as a title in a gauge? I have the mqtt value - but how to bring this into a gauge as a title :slight_smile: