Homey Community Forum

Not all lights are turned on

zigbee
#1

I had 6 TRADFRI lights spread throughout the house that are working fine the last year. This weekend I replaced all the ceiling spots (10 in total) in the kitchen with the GU10 Tradfri. So I have now 16 Tradfri lights.

During the test everything seemed to work fine, they all did turn on in a sequence or turned off nicely. But this morning when I came downstairs two spots where still off. In the app, they were displayed as On. With one press they turned on again.

So I did some more testing today with running the flows to turn the lights on or off and randomly some won’t turn on or off. Sometimes they all work, but most of the time 1 or 2 are not responding.

I turned Homey off for 20 minutes to rebuild the Zigbee network, (they all have a direct route to Homey) but that didn’t help either.

As a last resort, I added a delay to the kitchen lights. First the normal lights, 3 sec later all the kitchen lights, but that didn’t help either.

Any thoughts on how to get this working?

#2

Split in severall flows?

#3

I have already split the kitchen lights and the rest in there own flow.

But I will do some tests with splitting up the 10 kitchen spots as well.

#4

Splitting the 10 kitchen spots into two flows didn’t help. Even with a delay between them.

What seem to work better is dimming the lights to 0 to turn them off and dimming them back on to 30% or so when you want to turn them on. Still not 100% score, but lets say from a 80% to 95%.

#5

Are always the same devices not switched on? Or randomly?
If it are the same RE-pair these again?
I had a Zigbee hum/temp/pressure device from Xiaomi not working properly. After repairing it did work again

#6

Completely random. Just 10 in ago 4 spots wouldn’t turn on. Running the same flow again solves the issue. So it’s really related to the amount of devices I am trying to turn on at the same time.

Splitting the flow didn’t help. I am now testing with different delays to see if that would work. Repairing the kitchen spots is a lot of work. Need to remove all the devices, pair one, remove it, pair the next, remove it. etc. (because they are all turned on with one light switch) And I don’t think it will help, they where all new and reset before I connected them.

#7

It could just be that they are too close to each other and interfere the sequential commands due to frequency overlap. This happened to me with my HomeWizard when i had put the plugs too close to each other in one extension box.
Since it’s a sequential chain you could try to switch in a distinct pattern that switches bulbs that are not close to each other.

#8

Smart idea :sunglasses: :ok_hand:t2:

#9

I had similar issues like you and i decided to add a Tradfri bridge. With that bridge and the Tradfri gateway app on Homey all problems are solved and bulbs act directly to all commands. Be aware that moving all bulbs to that gateway your routers in Zigbee are gone too, so i left a few directly attached to Homey to keep the mesh in ZIgbee alive.

#10

Try to add a delay between the actions. Light 1 with 0s, light 2 after 1s, light 3 after 2s etc…

#11

Even delays didn’t solve that, i tried that many times. It’s the ZIgbee which isn’t stable and with the Tradfri bridge you can solve that