Homey Community Forum

One Somfy blind refuses to work

I am switching from Homewizard to Homey and everything is fine, accept for 1 of the 12 Somfy blinds.

It moves when I press the program button on the remote, it moves when I press program in the Somfy app on Homey. It moves with the remote, it moves when controlled by Homewizard, but it refuses to move with Homey.

I tried reversing the signal, I tried moving the Homey, I tried changing the length of the signal, but all in vain.

Right now I am out of options, except for controlling the blind with Homey through Homewizard, which, of course, can not be the solution.

I have exactly the same. Is there a solución? I have changed my router. After that it happens. Therefor it works nice.

If you use a flow to control the blinds, did you try to send the signals with an interval of two or three seconds? Here that solved the issue, it is a known problem.

Another option is to let send the signal twice with delay between. In case it didnt pick it up

Yes, I already ran into that one too. But I already solved that. But that didn’t help for that 1 blind.

Does that 1 blind having a large distance to homey compare to the others.

Maybe the signal doesnt get there. Option to try … move homey just for testing closser to that blind. Just because its strange that only one blind doesnt work.

I already tried multiple commands and I also moved the Homey even closer to the blind. Because from the 12 blinds, the problem blind is the second closest to the Homey. The blinds in my bedroom are much further away, divide by two ceilings and some walls. The garden door (the problem blind) only has 1 wall. Weird? It sure is.
Also thought about interference with other signals, but when I hold the Somfy remote over the Homey (same line of sight) it works with the remote.
In the Athom archive (I’m new to Homey) I found a similar issue. Unfortunately there wasn’t a solution provided.

indeed weird. then iam out of option, yourself probbely also :thinking:

Last thing you could do i guess is contacting the devolper and ask they can have take a look at it

Do I understand it correctly that it does work with the Homey, but not when activating it through a flow?

They do work, al least iam having no problems with it.

No, the specific blind doesn’t work at all with Homey. Not through a flow and not when I use the app. The Somfy remote itself (hardware) works. The Homewizard works as well. Now I am sending a scene command to my Homewizard to open or close the blind. That works fine, but is not quite what I had in mind when I bought the Homey :slight_smile:

I even tried to make a new device in Homey with a combined group from blinds. After that I could give 1 command and all blinds were moving. Except… sure, the garden door.

1 Like

Yes, I’m afraid that will be the last option. Problem is: which developer?

If it is the app… why do all the other blinds work?
If it is the Homey… why do all the other blinds work?
If it is the RTS engine… why do the remote and Homewizard work?
If it is interference… well, then it should work at least sometimes (and fail on the remote, Homewizard too)

Good point.

The devolper is Athom.

Knipselsom

Your blind must be good, as you stated its working in homewizzerd.

Athom can see more than we can, if they ask you to send a log. They can read that out and perhaps see something, does the signal send correctly…. just thinking.

Now its not working, so its worth to try.

Is it included correctly? Did you try to remove it and then to add it again? That would be my last option …

1 Like

About three times I guess. And also on a combined channel. Thanks for thinking with me, it looks I really tried everything. Go ask Athom support I guess.

That’s right. I’ll try that. Keep you all posted.

I have been busy for more then a few hours now. but the screen is not working.
@sbstrop: which router you use. I use the Tplink archer c7 v4.

Linksys, but I don’t think the router has something to do with it. The signals are not Wifi, but 433 MHz. And yes, there could be some interference, but that would also be the case for the Homewizard or the Somfy remote. But, I could try tomorrow with the Wifi shut down. Keep you posted.

You cannot shut the wifi down because the signal goes from your tablet to the router, then to the server of Homey somewhere in the cloud, then to the router and then to the Homey and at least to the somfy. I think.

Correct, when I would use my tablet. But I can use any sensor to start a flow which will try to close the blind. And I have an Aeotec Wallmote. So that could work. But yes, it will take some time.