Homey Community Forum

Osram SmartPlug+ "Could not reach device"

Hello, everyone,

I have recently increased the number of my ZigBee Osram Smart+ Plug significantly. Now it comes since short more and more to the fact that I can not switch the sockets from now on at once.
“Could not reach device”.
The sockets (24 pieces) are all within 5 meters. So the range should not be.

Is there a maximum number of ZigBee devices that the homey can handle?
Is there a way to view an error log to find out what is going on with this “Could not reach device” error message?

Not all, but from time to time different sockets are affected.

If I delete the failed sockets and teach them again, they can be switched properly again.

I hope for your help!

Many greetings
Florian

There is a maximum number of devices that can be directly connected to Homey, which is about 20, so it could very well be that you’re reaching that limit.

You could try and let the Zigbee network settle for a while and try again. Hopefully, the plugs will form a mesh and you will be able to add a new device through one of the existing devices, rather than directly connected to Homey. When you add the new device, try adding it away from Homey (so it doesn’t try to connect through Homey but through another plug first).

Thanks for your constructive feedback.
Sounds like a good idea to teach the sockets “further away” from the homey. However, I can register all sockets successfully and then switch them - I’m surprised that when all sockets have been trained, they first work and then, for no apparent reason, can no longer be switched.

Is there any way to check this with the ~20 Zigbee devices - logfile etc.? Just to get some more info about the “Could not reach device”?

ZigBee itself should not have a problem with 20 devices. …

A Zigbee mesh, and Zigbee routing, are dynamic. It could be that initially devices were being routed through other devices, and for some reason the topology changed and it stopped working.

Homey is basically a black box with that respect: no logs, no real mesh overview, so it’s very difficult to debug these issues (I’m only assuming that you’re running into that limit, but it might be something else entirely).

Indeed, Zigbee itself doesn’t have that limit, it’s something that is imposed by the Zigbee-hardware that Homey uses.

That would be really annoying…
After all, 20 devices are not even that many devices. Is there anybody else who has problems with a bigger ZigBee installation and can tell you something about it?

Alternatively, is there someone who can reliably switch a larger number of sockets?
What protocol and hardware do you use for this requirement?

Some people have no issues with 50+ devices (meaning that they have a good mesh with plenty of routers, so sensor devices don’t need to connect to Homey), others run into the 20-device limit fairly quickly and can’t get it working without a full Zigbee reset.

Using externals hubs (like the Hue bridge or the IKEA gateway) can (somewhat) mitigate the issue. I think the Hue hub has a 50-device limit, don’t know about the IKEA gateway.

I had the same issue last year and there must be also a post that other had the same issue. I can not test it right now as the other homey is in the other appartment. It was for the time around January/ February Ok, may be it
got worse again with the new firmware update.