Homey Community

Owntracks - how to create flows?


#1

Ok so I’ve set up the cloudmqtt and created the homey-user and the family users. All smartphones got the owntracks app and all are connected.

I’ve created multiple geo-fence-zones and now we’re at the problematic part. I don’t get the flow to work as it should and I can’t really see what I’m doing wrong. The aim is to inform different family members when the kids go from school, bus arrives and when I leave work etc. but something is not working.

What am I doing wrong - any recommendations?


#2

maybe a bit offtopic, but honestly, i had Owntracks working once. but it drained my phone’s battery and the config was randomly gone… (search the old forum, i wasnt the only one)

im using IFTTT now and it works great, no draining battery’s, accurate, no disappearing config’s and much easy’er to setup.

on-topic: this topic helped me:


#3

I have read these post and installed the app. After installing the link the app opens and closes immediatly.
Is this normal? You don’t need to change setting anymore? i am using https

greets
Frans


#4

It works perfect owntracks but I use a private MQTT server


#5

Great, however that was not the question. Is it normale that the app closes after you open it?


#6

No that is not normal but as I told you in the previous post ! I use a private MQTT server so I don’t know how it reacts with a PUBLIC MQTT.


#7

Oké that’s helping me some more. I Will try the mqtt server than.

Thanks


#8

Hi Chris,

Maybe you can help me out here? I have changed form HTTP to MQTT and after a lot of ours somthing seems to work. I think the app on the phones work as they stated “connected” and when i share the waypoint i see reaction in the log of CloudMQTT. It also looks like homey is connected.

In the flows above i see the name of the household members. in my case i don’t see anything. My question is do i have to add users and geofences in the Homey app section?

Anyone else that also can help me as i seem to be stuck.

image

greetz Frans


#9

today i have tried what the app does and it works at least in the app. Accoorinding to the posts that i have read over and over again Homey should get Regions en users added automaticly from yhe owntrack app on the phone. This is not working for me so it looks i am missing somthing in Homey.

No Owntrack users here that can help me?

greetz Frans

Update just now i changed the inlog off CloudMQTT for trying. No succes. Changed it back to the usual login and suddenly i got al king off messages. Also saw 2 users in Homey. Even more confused now bit it seem to work, now i can go on with the flows.


#10

You have to create users and geofences in you owntrack client app.
When your phone is connected to Homey the owntrack app will pick up the users and the geofences.

Then you can select something like this


#11

Hoi Chris,

Thanks for your answer, unfortunatly is doesn’t work very good for me.
Its not reliable at all. Maybe its because we both (wife and i)have a huawei phone. They put the app to sleep even when i change settings in the phone. I tried everyting for days. I am trying now to get it working with IFTTT and this looks to go in the right direction.


#12

Not sure if it helps, but you should be able to prevent the Android system to let specific apps go to sleep. You should disable the ‘Battery Optimization’ for the specific app.

On my Dutch Android phone (running LineageOS, so it may be worded/phrased differently for you) it’s under:
Instellingen - Apps en meldingen - Geavanceerd - Speciale app-toegang - Batterijoptimalisatie

All apps that you don’t want to go to sleep (doze mode I think they call it in Android-land) should be ‘not optimized’. Stuff like Google Play Services also relies on this.
If you had already done this, then Android may require the app to keep a persistent message open. Android won’t kill apps that have unacknowledged messages. (some apps (mis)use this mechanism to always keep running as some weird workaround :slight_smile: )


#13

No i didn’t help. I also did this. Also have read on the site of owntrack that this is a specific Huawei problem.
There is a solution however very dificult again. IFTTT starts to work now and is way easier to setup so i am using this now.

Thanks for your answer