Homey Community Forum

Owntracks


#1

hallo, ik loop tegen het probleem aan dat homey de locatie niet meer goed bij houd… dat of helemaal geen locatie word gewijzigd of veel te laat pas. dat is irriterend met het thuis komen en dat dan niks het doet tenzij ik iedere keer voor ik na binnen ga in de app handmatig de aanwezigheid aanpas. dit is eigenlijk niet echt de bedoeling aangezien homey er voor is om de boel te automatiseren, erg frustrerend dat zoiets niet werkt na een update waar ze zo lang over gedaan hebben en dit dan nog nie eens goed werkt… maargoed ik heb nu owntracks geinstalleerd en dus zon server op cloudmqtt aangemaakt accounts aangemaakt en rechten gegeven voor lezen en schrijven. nu heb ik eigenlijk alles volgens mij goed ingesteld, in de app in homey bij owntracks geeft hij bij het account van mijn telefoon ook gewoon locatie weer en batterij gegevens. dus mij lijkt dat dit allemaal gewoon goed in is gesteld maar als ik een flow maak en test of echt weg ga en terug kom om dit echt te testen gebeurt er niks. als ik een flow maak van als ik vraag wat mijn locatie is en dat die dit dus moet zeggen, dan krijg ik het antwoord de locatie is niet bekend. beetje raar aangezien dat de app in homey owntracks gewoon aangeeft wat mijn locatie is.
help??


#2


#3

Ibby heeft iig geen locatie. Dennis wel maar heeft geen Home (of bevindt zich niet in Home)? Heb je wel een Home gemaakt in de owntracks app op je tel? Vervolgens even pushen naar de Owntracks Client app op Homey middels “push waypoints”.


#4

Heb je hier al gekeken?

@scanno kan je misschien verder helpen (ontwikkelaar app)


#5

Logging uit de app kan ook nog wel eens helpen.
Vaak is het een probleem met de instellingen van de app op de telefoon. Als je zeker wilt weten of alles goed werkt. kun je de app op de telefoon in “move monitoring” mode zetten. Dan wordt de GPS bijgeschakeld. Kijk dan eens wat er gebeurd.

De owntracks op je telefoon heeft verschillende modi.
De “move monitoring” is de meest snelle en nauwkeurige modus (GPS constant ingeschakeld)
De “significant chnages” monitoring mode is de modus die je eigenlijk wilt gebruiken (beste afweging tussen accu en nauwkeurigheid"

De laatste kun je nog tweaken, want deze controleert / verzend pas gegevens wanneer een bepaalde tijd is verstreken of een bepaalde afstand is afgelegd (zie preferences/advances/Locator displacement en Locator interval.


#6

Oké ja ik heb wel geoforce aangemaakt thuis in de android app waar ik me ook in bevind geeft die aaan krijg ook meldingen van die app dat ik er uit en er in ga. Maar ik kan nergens vinden hoe ik dan een thuis kan maken in de app Van homey


#7

Ik heb hem al ijn deze modes staan move monitoring. Ik krijg van de android app wel meldingen


#8

Als je in de settings pagina van de homey app kijkt, zie je die fence dan staan? Dit moet namelijk automatisch aangemaakt worden.

Als je een flow maakt, heb je dan de wildcards gebruikt voor user en fence?


#9

Ik heb nu in de flow gewoon user omdat ik dacht die zal beter werken dan als die wildcards maar ik zie bij instellingen geen fence staan


#10

Maar voor de duidelijkheid omdat de homey app wel ziet wat mijn coordinaten zijn en de rest van de info en dat de geoforces die ik maak in de android app er ook in komen te staan betekend dat de instellingen goed zouden moeten staan toch?


#11

in principe wel. Kijk even in de fence tab of ze zijn opgenomen.
Anders doe je een publish waypoints : Regions -> menu/publish waypoints


#12

Dit is nu net de eerste reactie op owntracks va. Homey


#13

Kijk dan even in de log van de homey app wat daar precies gebeurd


#14


#15

In huidige gegevens in de Owntracks Client in Homey geeft hij nu dus aan “Home”? Aan je coördinaten te zien en die van je thuis fence (ik zou de screenshots misschien verwijderen of in elk geval de coördinaten blurren) lijkt dat het geval namelijk. Als dat werkt hoef je enkel de “enter geofence” en “leave geofence” triggers te zitten in je flows.


#16

Oké wat je nou zegt snap ik echt niks van :stuck_out_tongue: maar dit is zoals het hele Tijd ingesteld staat ik krijg alleen geen reactie van homey ik heb de flows ook al ingesteld maar het doet niks


#17

Hoe ziet “huidige gegevens” er uit in de Owntracks Client Homey app?

En laat je flows eens zien want wat verwacht je dat Homey “reageert”?


#18

En mij lijkt dat deze flow wel iets moet laten weten en ik ben er van bewust dat libby nog niet werkt maar ik gebruik ook alleen me zelf tot het werkt ga ik meer instellen


#19

Probeer even met de “gebruik inregions” aan (zie homey owntracks app settings). Dan kun je iig even testen of de triggers werken.

Je kun wellicht om te testen de generieke trigger gebruiken (wekt voor zowel voor enter/leave) en gebruik voor gebruiker en fence de wildcard


#20

Dat kaartje doet nu niets omdat je ook niet in je region bent volgens Owntracks Client in Homey.

We moeten dus eerst zorgen dat Homey jou in je fence ziet (check ook dat je radius op 200 meter of zo staat);
In de Homey Owntracks Client, Druk even op “verwijder gegevens” onder “huidige gegevens”. Druk vervolgens op “publish waypoints” vanuit je telefoon owntracks app. Nu zou ie “fence” Home moeten zien bij je naam. Zodra dat het geval is gaat je flow ook werken.