Homey Community Forum

PaperTrails Log - Advanced Logging and Log management (v0.6.3)

Does the same here in Windows 10 (1903), Chrome 76 64-bit (tried both in normal mode and incognito mode to see if some addins may have been harassing).

In Edge it does work.

Usually I work in Vivaldi browser (Chrome engine) and that one also doesn’t work (can’t change tabs like described by @CorvanderNiet)

Hi @Dijker Found a glitch (maybe something I’m overlooking).

Today I configured my Synology NAS as a syslog server and configured it’s IP-address in Papertrails (v0.6.0)
Set the IP-address and checked the enable box
Chose UDP port 514

Enable syslog or all log additions => Application name: Paperrails
Severity: Informational
Facility: User

Now whenever I add something to papertrail a log is also written in syslog (which is expected) however, the application name is Papertrails [first word]
Or, to be more precise: the first word of the Papertrail log message gets added to the application name and the second word and further are in the message itself. I saw something about prefixing the first word with but that doesn't change anything (just the first word prefixed with is omitted completely). Also the category seems to be local0 while I did setup User in the settings.

Now when I use the send syslog line card, i can choose the type of message which seems to work (tested only a few) but the User is also not working; when choosing Audit I get “Console” in the syslog and also still the first word of the message gets added to the application name.

Maybe I’m overlooking something or maybe there’s a little issue with syslog logging (or the syslog implementation in Synology)…

Adding the papertrails cards to all flow with the community backup and restore tool isnt working for all flows in my case, some are added some are not.

any pointers or directions i can look at?

I only add it if the Flow does not have an Papertrails card already. and it must be a valid flow (not broken). pls try fixing or removing all broken flows first.

Tanks, ok, so i fixed all the broken flows and it did more flows, but not all.
so i went deeper, and fixed things like missing logic cards, wrong flow references and notifications to users that dont exist anymore.

but still not all flows are alterd. is there a way so see which flows are bottleneck?

Homey app shuts down in log view, latest iOS 13, iPhone 7

Looking at papertrail will cause an error after a while. See picture

0.60.0 is crashing in every platform, iphone, android etc, not only the app but also Homey app!

Not longer working in Homey update 3.1.1 rc1

here it is working fine still

On my part Papertrails shuts down Homey app when in syslog configuration view.

I have just installed Papertrails from the “homeybackup.web.app” but it crashes every time it runs. Homey says it has sent a report so hope it contains some useful information.

P.S. Backup looks good from first impressions :+1:

Hi, Thanks for trying and your msg.
Only Issue I get Crashreports if you open the Log viewer and then restart the Papertrails App… Homey doesn’t like that. (annoying, could not get it fixed and no big deal for me at that moment )
Workaround is Close the Log viewer and Start Papertrails App.
Then it should keep running
Until you restart Homey or the App and have the log viewer open.

I have it on my list and will look into a solution soon.

O, And Thanks for the compliment about Backup :wink:

I did indeed have the log viewer open as I had just pushed Papertrails to my Homey form the Backup web app and that automatically switched to the viewer.

By coincidence Homey just updated to rc-7 which made it reboot and Papertrails seems to be working now. Probably because I didn’t have the log viewer open when it rebooted.

Thanks for the prompt reply.

Every time I change the syslog settings to my syslog server ip and other syslog settings they are not saved. Always back to “default” settings and 127.0.0.1 as syslog server ip address.

Homey version is 3.20

1 Like

Hi @M_a_r_c_o
Is this new or has it worked before? What version is your Papertrails app?
I just tested latest versio on a clean Homey and it works for me, when do you lose te setting? (Restart app, Restart Homey, PtP ? just waiting for… )

Can you send a Log from the App after setting the information?
Then restart the app and send a 2nd log ?

Hi @Dijker, isn’t it longer possible to send the Log with Mail when it is trunced?

I still use this with the Email sender app.

1 Like

Hello @Dijker

Sorry for the delay

App version 0.6.3 currently but also before this version.
It has not worked for me (I think), I loose settings as soon as I exit the COnfiure App, no reboot of app of Homey is needed for it. I go to configure app, change IP address, go back twice, go into App configuration again and its again 127.0.0.1.

Tried what you asked, and will send you the codes.
But! I removed the app from the Homey and reinstalled the app and now it seems to work properly.

1 Like

Hello @Dijker, I do not understand the Prefix option you mentioned in one of the release notes. What does it mean/do and how do I use this?

  • Added Magic!
    • Automatic Adding & Removing Logging to All Flows with a Prefix.