Homey Community Forum

PaperTrails Log - Advanced Logging and Log management (v0.6.3)

I have just installed Papertrails from the “homeybackup.web.app” but it crashes every time it runs. Homey says it has sent a report so hope it contains some useful information.

P.S. Backup looks good from first impressions :+1:

Hi, Thanks for trying and your msg.
Only Issue I get Crashreports if you open the Log viewer and then restart the Papertrails App… Homey doesn’t like that. (annoying, could not get it fixed and no big deal for me at that moment )
Workaround is Close the Log viewer and Start Papertrails App.
Then it should keep running
Until you restart Homey or the App and have the log viewer open.

I have it on my list and will look into a solution soon.

O, And Thanks for the compliment about Backup :wink:

I did indeed have the log viewer open as I had just pushed Papertrails to my Homey form the Backup web app and that automatically switched to the viewer.

By coincidence Homey just updated to rc-7 which made it reboot and Papertrails seems to be working now. Probably because I didn’t have the log viewer open when it rebooted.

Thanks for the prompt reply.

Every time I change the syslog settings to my syslog server ip and other syslog settings they are not saved. Always back to “default” settings and 127.0.0.1 as syslog server ip address.

Homey version is 3.20

1 Like

Hi @M_a_r_c_o
Is this new or has it worked before? What version is your Papertrails app?
I just tested latest versio on a clean Homey and it works for me, when do you lose te setting? (Restart app, Restart Homey, PtP ? just waiting for… )

Can you send a Log from the App after setting the information?
Then restart the app and send a 2nd log ?

Hi @Dijker, isn’t it longer possible to send the Log with Mail when it is trunced?

I still use this with the Email sender app.

1 Like

Hello @Dijker

Sorry for the delay

App version 0.6.3 currently but also before this version.
It has not worked for me (I think), I loose settings as soon as I exit the COnfiure App, no reboot of app of Homey is needed for it. I go to configure app, change IP address, go back twice, go into App configuration again and its again 127.0.0.1.

Tried what you asked, and will send you the codes.
But! I removed the app from the Homey and reinstalled the app and now it seems to work properly.

1 Like