Homey Community Forum

Philips Air Purifiers & Humidifier app

hi,

Started this topic for the philips air purifier app. So I clean the readme and add a link to this topic.

With version v0.0.23 I will also support latest purifiers which work with the coap protocol firmware, since late 2019 philips moved away from http to coap.

Hello @Edwin_Biemond. I’am using versie 0.0.24 and it’s working great with my AC5659. Since yesterday i have a second device, a ac2889 that i also connected to the app.
But now i have a very strange situation that i can’t explain. Since i connected the second device, i am unable to control both device via flows. The fan_speed does not change anymore. But the strange part is that i CAN control both devices via homeyscript. I have recreated the flows, created a simple test flow that sets the fanspeed. But it does not work anymore. But via script there is no problem.
One note: Both devices are controlled via the coap protocol

oh, I also have 2 devices but let me verify this. I have 1 http and 1 coap protocol one. let me add the same one twice. Also I am using homey 5 rc versions but let me try to reproduce it.

So indeed there was a big action bug. I was thinking flow actions are on device level but it is on app level. so last registered device actions were leading plus wrong settings were picked up.

@tb1962
can you test this one https://homey.app/nl-nl/app/com.athom.philipsair/Philips-Air/test/
thanks

Hello @Edwin_Biemond. Thanks for your support. Unfortunately nothing seems changed. I have tested with a simple flow wich sets the ac5659 fanspeed to a specific value and the fanspeed of the ac2889 to another value (or the same, i did various tests) Most of the times, one of the devices reacts to the change of the fanspeed setting. Sometimes it is the ac5659 and another time it is the other device.
It does work via Homeyscript, so for me it is not a big deal. I am stil happy with te app. But maybe others with more than one device wil have problems getting it working
Please let me know if you want me to do more tests

Very weird. Can you try to remove the devices. Restart app.

Also maybe if you are technical you can checkout github . install node and homey. After that you can do homey app run to see all the output. To see what goes wrong.

Plus I will do another check

Hi Edwin
I recently, few days ago, bought a AC3829/10 and it works fine for monitoring the device.
But the actions (i.e. changing the flow speed) doesn’t works.
I have several times remove the device and/or your App (v0.0.25) That doesn’t solve the problem.
I have read that you fixed this problem in your latest version (0.25).
Unfortunly not for me. Do you have some advise ?

By the way
The problems is for my flows and not from the “monitoring page”
That works fine

He,

so does it work from the app? and all all actions failing.
sometimes a device does not support all the option values or it has to be combined with an other action.

it can be that they did something different for this device type or we got some protocol error.
maybe you can try it out locally to see the full stacktrace .
for that you have to install node , homey node npm and my code , after that you can do homey app run to see all the output.

Thanks for your quick response.
Unfortunately I’m not so technical for following your last advice.
It can change all the possibilities of my AC3829 Humifidier from “Monitoring Page” of your App.
Also I can monitoring everything. But only in the flow it is possible to trigger the device: IF PM2.5 is changed AND Value=10 THEN (the action) Fan Speed =1.
This action is not done. While in the “Monitoring Page” I can change the Fan Speed to 1, 2, 3 and Turbo
and all the other possibilities. So the problem must be in the the Flow App THEN part
I have also tried different action combinations as part of THEN part of the flow. But nothings happens.

thanks , let me try to do the same.

so it works for me but I did not use value as condition but this.

did you use the same one.

The AND condition is new for me. So instead of the Value condition I use your condition
And again nothing happens. The problem is, I think, not that the trigger mechanisme doesn’t works
Because the THEN part is always activated. Only the action " Fan Speed to 2" is not executed i.e. nothing happens on the device.
Can it be that the device (Humidifier) must be in a certain state Par example: General mode or Manual mode. Or something likewise.

I am testing by the way on the homey version 5 beta. maybe it fixes some things.
but in my case if it in general mode and I do the above it will switch to manual and set the speed.

from the app it will do the same and that works for you or not. So I think it is something with homey. let me think I can work on more (remote) logging.

From the App I can change the settings. So that works perfect.
It is only in the flow. The flow starts a several hundred times :grinning:
But no action follows.
I have a Homey Pro (bought on august 2020) with Homey version 4.2.0 and App version 6.1.0.633
I have also tested the flow under several state condition of the Humidifier (General mode, manual mode mode and so on).
But nothing helps.
Also I have reinstall the Philips Air App and the device several times.
And also I have disconnect the Humidifier from the Air Matters App and the Clean Home+
I have also a fixed IP-adress for the Humidifier.
The only thing I have not done is reinstalling the Humidifier from scratch.

ok, we can do some things

  • wait for homey 5 but this zigbee change is big.
  • I will try to implement some logging , lets see how others are doing this.

Plus maybe we can install node, install the homey npm see https://apps-sdk-v2.developer.athom.com/tutorial-Getting%20Started.html

download my github repo https://github.com/biemond/com.athom.philipsair
extract and do

  • homey login
  • homey app run from my directory.

you will see all the output

Hi
So I will wait until Homey version 5 is released, while I am not very technical to install the node advise
Thanks for your quick responses and efforts