Homey Community Forum

Philips motion sensor alarm fix

Hi

has anyone a homeyscript to set alarmstatus to false with curl or whatever. since I want to integrate the sensors to homey directly and not over the hue bridge.

hope someone can do that for the community, or a script already exists?

problem:
if the sensors are connected directly to homey, than the sensors getting offline in state motion detected hours/days ago.
quick fix restart homey every 2 hours. this is kind of a bullshit fix since over a year.
would like to set a counter, if the counter reaches 0 trigger script to set alarm status to false.

hope someone can help and post his script or his experience?

regards
adem

Homeyscript does not have enough permissions to change other app’s values, so you would have to find another workaround.

Try to raise the min interval to about 10s, like @mapulu proposed here. https://github.com/sebbebebbe/com.philips.hue.zigbee/issues/148

This was my idea since I changed it it works much better on Homey. May not work for all better but can’t do harm to try.

@mapulu You don’t feel like having a look if it’s possible to turn that annoying red LED off btw? Hehe. Like I suggested here. https://github.com/sebbebebbe/com.philips.hue.zigbee/issues/151 Obviously someone solved it for zigbee2mqtt by sending a response message to the sensor.

thx for the prompt replies
do I have to install a specific commit? and how to install this :confused:

regarding homeyscript and permissions, create a token on Philips hue bridge, curl it to ifttt or directly to sensor. even not a good workaround but would work I guess?!?

No, you can change that under the advanced settings for the device.

fixed my issues like here