Homey Community Forum

Philips TV Testing

I have a 2016-model (or maybe even 2015?) where I would like to try this app. Does it turn on/off with RF, IR or something third?

@Eduardo_Rodriguez first of all, thanks for the system response helps a lot.

Secondly, the app already tries to determine the port, so there’s no need to provide it in the “IP address” field. Also, from what I can see in the system response, it seems that your TV is using the Jointspace v6 API (you could test this by checking if this link works for you http://192.168.1.147:1925/6/system).

Try adding your device’s IP without the port, select API version “6”, TV type “other” and see if it works.

PS: A basic rule that the Philips TVs seems to adhere to is this; is it an Android TV then use port 1926, is it non-Android then use port 1925. This is why I added the TV type to the pairing process.

.

@Robbert the app uses the Jointspace API, this works via Wi-Fi or cable internet. As far as I know, every Philips TV since 2010 has had Jointspace support, so it should work for you TV as well.

Regarding waking your TV up
The app sends a { "powerstate": "On" } to your TV. This might fail when your tv has completely shut down and it no longer listens for new requests.

In these cases the app will try to wake your TV up by sending a Wake-on-LAN request to the MAC address of your TV. After 5 second the app will retry the poweron command, it tries this 3 times in a row. It’s important that your TV has Wake-on-LAN enabled, but the app checks this during the pairing process and will warn you if it’s not.

However I have experienced issues where the TV didn’t want to wake up even after the WOL request was sent, I’m still looking into the cause of this.

@lucasvdh Cool, sign me up! :smiley:

If not put the port get this error:

@Eduardo_Rodriguez thanks for the feedback.

It appears the app tries to start a pairing process when none is required. I might have some time today to fix this. If I’m not able to fix it today, it will have to wait a couple of weeks I’m afraid, going on vacation.

Back at it again.

Just published an update (v0.3.2) which adds two new flow actions (sending a key and opening an app if its an android tv) and resolved a bug in the power on behavior.

@Mickel_Luiten and @Eduardo_Rodriguez I’ll be looking into your pairing issue some time this week.

Hi Lucas,

Hope you enjoyed you holiday?
With the app no luck,

On homey after enter IP adress, APi version and type(android) the app endless says loading

With paring testscript :

node pairing.js
? What’s your TV’s IP? 192.168.2.140
? What’s your API version? (1 to 6) 6
? What port number should be used? Either 1925 or 1926 1926
Updating _client config
Sending system info call
Unexpected error
{“code”:“ECONNRESET”}

node pairing.js
? What’s your TV’s IP? 192.168.2.140
? What’s your API version? (1 to 6) 6
? What port number should be used? Either 1925 or 1926 1925
Updating _client config
Sending system info call
API version as returned by TV: 6
Starting pairing process
Could not reach api endpoint, connection was reset. Incorrect port number?

With postman i post http://192.168.2.140:1925/6/system and get following response.

{
    "notifyChange": "http",
    "menulanguage": "Dutch",
    "name": "tv-philips",
    "country": "Netherlands",
    "serialnumber_encrypted": "D+q4bijYOwT4hdDyS75aE73tMzZaSSzBQ9yiFMPqSTo=\n",
    "softwareversion_encrypted": "CzwJ+H33uwQTm2mfEteSJiSB+z0wRvl8WSwZu1itwlk=\n",
    "model_encrypted": "XUPZXApQvnWGsKtrK2EMVHfKchsmqySAkw268KA09Fk=\n",
    "deviceid_encrypted": "ZBu4F127jW6wQcc9Jg/CdmI29w12Oq152oSiDUX1/bU=\n",
    "nettvversion": "8.1.3",
    "epgsource": "one",
    "api_version": {
        "Major": 6,
        "Minor": 2,
        "Patch": 0
    },
    "featuring": {
        "jsonfeatures": {
            "editfavorites": [
                "TVChannels",
                "SatChannels"
            ],
            "recordings": [
                "List",
                "Schedule",
                "Manage"
            ],
            "ambilight": [
                "LoungeLight",
                "Hue",
                "Ambilight"
            ],
            "menuitems": [
                "Setup_Menu"
            ],
            "textentry": [
                "context_based",
                "initial_string_available",
                "editor_info_available"
            ],
            "applications": [
                "TV_Apps",
                "TV_Games",
                "TV_Settings"
            ],
            "pointer": [
                "not_available"
            ],
            "inputkey": [
                "key"
            ],
            "activities": [
                "intent"
            ],
            "channels": [
                "preset_string"
            ],
            "mappings": [
                "server_mapping"
            ]
        },
        "systemfeatures": {
            "tvtype": "consumer",
            "content": [
                "dmr",
                "dms_tad"
            ],
            "tvsearch": "intent",
            "pairing_type": "digest_auth_pairing",
            "secured_transport": "true"
        }
    }
}```

On  https://192.168.2.140:1926/6/system  or http://192.168.2.140:1926/6/system  no response.

Bit strange beacuse API version 6 should be on port 1926.

@Mickel_Luiten

That’s just weird…

That the API is on version 6 doesn’t necessarily mean that it uses port 1926 though. I’ve been in contact with someone else who has also been developing a Jointspace API client and has had contact with someone at Philips responsible for the API. What he says is that all Android TV’s should use port 1926 and all non-Android TV’s should use 1925. Also, apparently Android TV’s only support the /6/system endpoint on port 1925 to comply with older clients and should also work in 1926.

Your case appears to contradict this theory. I’ll try and get in touch with Philips to ask why your specific model (49pus7101/12) has this different behavior.

I think this will most likely be a new case in the pairing process which I’ll need to take into account. Hopefully Philips will have a concrete answer to which specific models this case applies, otherwise its going to be a lot of trail and error during the pairing process.

Just to recap (correct me if I’m wrong) what I’ll be communicating to Philips:

When trying to access the Jointspace API (v6.2.0) on an Android TV (49pus7101/12), connections are only accepted on port 1925 while it has been suggested that all Android TV’s should work with port 1926.
Are there more cases where Android Philips TV’s only accept connections on port 1925 and if so can these be identified by anything in the system response?

@lucasvdh, your recap is correct
To be sure below screenshot of the firmware version from TV, its the latest
see also https://www.philips.nl/c-p/49PUS7101_12/7000-series-ultraslanke-4k-tv-met-android-tvtm-met-driezijdig-ambilight-en-pixel-precise-ultra-hd/ondersteuning

Also its running android 8.0.0 with the latest security patch from 1 march 2019 ( build OPR5.170623.014 release-keys)

Hope you can get an answer from Philips, in the past the support on the API was bad.

Thanks in advance.

@Ben_Lens, @Tim_Messerschmidt, @Eduardo_Rodriguez and @Robbert does the pairing process work for you as of the latest version? (v0.3.4)

I’ve resolved a number of edge-cases in the pairing process. I’m also still waiting on a reply from Philips (TP Vision) about the Jointspace protocol, so I can’t be sure if I’ve resolved all issues.

I can enter a pin number now.
After entering it looks like i cant push the send button as nothing happens. Then get the message that pin is wrong.

Same here on an AndroidTV

1 Like

Same thing here. It’s already an improvement over the “loading” screen. Keep up the good work, you’ll get there!!! Thnx!

Yeah, same here as well. PIN is incorrect.

Restart the app and restart the ‘add device’ sequence. Then it works.

@lucasvdh
My feedback after some testing on version 0.3.4.
Great app… great work!

Issue 1:
WakeOnLan (WOL) is enabled and I am able to turn on the TV. This morning I said:“Ok google, turn on the tv”. Then it takes a bit and the tv switches on, however, the Google Assistant (GA) reports back that something went wrong.
Maybe the timeout is a bit too short. I will retest this without the GA to see how it works directly from Homey.

Issue 2:
During initial setup WOL was not yet activated in the TV. The app nicely warned me. After enabling this on the tv it still didn’t work so I had to remove the device and add it again. Then everything worked and the warning disappeared.

Issue 3:
After removing a device I was unable to add the tv again because the app states "pincode wrong’ during the process.
Restarting the app through the settings in homey fixed the issue.

Please let me know if there is anything that I can do to help you in development.

1 Like

Tried it several times as per your instructions.
Same issue ever time. So not a viable workaround for me at least.

Hi everyone,

Small update on status; I’m currently swamped at work, so new fixes will probably take some time. Might be two weeks before I’ve got some time again. So sorry for the wait but please be patient, haven’t forgotten about you :wink:

Known issues

  • Wake-on-LAN sometimes takes longer than 75 seconds (or 15 tries) to respond, or it works but doesn’t respond with an acknowledgement. Not sure if this is fixable but I’ll look into it.
  • There are still some issues with the pairing process on specific models. I know what the issue is, just not how to resolve it. I’ve been trying to contact TP Vision (developer of Jointspace protocol) for about a month now, but I’ve only received generic answers if any. Will post updates here.
  • The Homey app stops updating device values after a while. Not detecting on/off changes etc.
    If you experience this issue and there is an error log present under the app settings, please report it here.

Upcoming features

  • Switching/setting TV channels
  • Setting ambilight style to follow audio, video, etc.
  • Setting ambilight algorithm, this is mainly for when ambilight follows audio. Can be set to immersive, spectrum, party, knight rider, colors or brithness (depending on supported algo’s).
4 Likes

WOL issues are a nightmare … not sure if this is just my home network, my TV or if its something else. I’ve never had any issues waking up other devices via WOL.

Is there anyone (who has the app working with their tv) who is experiencing Wake-on-LAN issues after a night of inactivity? Waking my TV up via a WOL command only works 1/3 of the time for me.

Would appreciate any feedback.

For me it works all the time…except that it only does after 30 seconds.
My TV is connected with a cable.