Homey Community Forum

Philips TV Testing

Hi Lucas,

Great news, keep up the good work! Especially looking forward to the “power on behavior” improvement!

Dave

1 Like

I tried installing the app again, but I’m again stuck at a pincode incorrect when installing the device.
I thought it i’s a 2016 model

https://IPADDRESS:1926/6/system

{“notifyChange”:“http”,“menulanguage”:“Dutch”,“name”:“Tv”,“country”:“Netherlands”,“serialnumber_encrypted”:“BnqvPP7erV2bEZqZMxgM+Sab8yMyCpilPF1O8PhyNaU=\n”,“softwareversion_encrypted”:“aKWJhP8OOZBvzbOTjWAwJZf4gkPGawPnFBUK2jrwHxY=\n”,“model_encrypted”:“BBiKLsmyZ8TBkMd/8ICEJ/k8mG/GQYWCriFEQfTB8ZE=\n”,“deviceid_encrypted”:“UN9KoLBf/QxnwafbQKegmc9WT1CV9jkP/RdpThYi6ik=\n”,“nettvversion”:“8.1.3”,“epgsource”:“one”,“api_version”:{“Major”:6,“Minor”:2,“Patch”:0},“featuring”:{“jsonfeatures”:{“editfavorites”:[“TVChannels”,“SatChannels”],“recordings”:[“List”,“Schedule”,“Manage”],“ambilight”:[“LoungeLight”,“Hue”,“Ambilight”],“menuitems”:[“Setup_Menu”],“textentry”:[“context_based”,“initial_string_available”,“editor_info_available”],“applications”:[“TV_Apps”,“TV_Games”,“TV_Settings”],“pointer”:[“not_available”],“inputkey”:[“key”],“activities”:[“intent”],“channels”:[“preset_string”],“mappings”:[“server_mapping”]},“systemfeatures”:{“tvtype”:“consumer”,“content”:[“dmr”,“dms_tad”],“tvsearch”:“intent”,“pairing_type”:“digest_auth_pairing”,“secured_transport”:“true”}}}

tried restarting the app, reinstalling it and different JointSpace versions but then it says that it is probably a different api version.

Any idea?

A new version (v0.5.0) containing the features/improvements mentioned above has been released to test. This release also contains a minor pairing fix for models which do not require authentication and provided their pairing type as “none”.

Would be a great help I you guys can test this version before I release it.

https://homey.app/a/codes.lucasvdh.philips-jointspace/test/

1 Like

installing it now!

@lucasvdh was testing the ambilight + hue function, it turned on once and then couldn’t turn it off again. also by manually turning it off via the TV and turning it on via your app didn’t work anymore.

29b00b4f-3b65-4348-bfa9-136c6448b2b8

Hi Lucas,
I installed it this morning and it worked at first but after being away for a while and trying again, powering on is failing again.
I created a diagnostic report, do you need it?
Dave

Thanks @Otter and @DaveOne I received the diagnostic reports :+1:

I will probably not have time to look at this for some days so if the current test version breaks I’d suggest switching back to v0.4.1 on live.

1 Like

No problem, happy to test. Hopefully Philips is getting back to a source selective input instead of dynamic, i’ve complained about it already maybe that make things easier my harmony setup is a mess because of it.

I’m using a 55OLED935/12

I can’t pair. I have an 65OLED804/12 with the latest firmware. But it won’t pair. Not with the test version and not with version 0.4.1

Here is the json output

{
	"notifyChange": "http",
	"menulanguage": "Dutch",
	"name": "TV Woonkamer",
	"country": "Belgium",
	"serialnumber_encrypted": "raRoT1if7aB4bO5K4z/bfSyWid7eO0vlxUHNyUSSOlI=\n",
	"softwareversion_encrypted": "aet+S8/OFqtVtG9c/bwoT4quf+FNqOJpLXT+nEBXkqHUWe2UQocKLrN0dmEb5A38\n",
	"model_encrypted": "rJeSeoaS0GTwP6/J/o9rKmxaeeBlMz6tGeqGzug1R0w=\n",
	"deviceid_encrypted": "2JnRHYenGU2gGlxiiFbMuT02U1a79OwQ2FyVZ3t+UM4=\n",
	"nettvversion": "9.0.0",
	"epgsource": "broadcast",
	"api_version": {
		"Major": 6,
		"Minor": 4,
		"Patch": 0
	},
	"featuring": {
		"jsonfeatures": {
			"editfavorites": [
				"TVChannels",
				"SatChannels"
			],
			"recordings": [
				"List",
				"Schedule",
				"Manage"
			],
			"ambilight": [
				"LoungeLight",
				"Hue",
				"Ambilight",
				"HueStreaming"
			],
			"menuitems": [
				"Setup_Menu"
			],
			"textentry": [
				"not_available"
			],
			"applications": [
				"TV_Apps",
				"TV_Games",
				"TV_Settings"
			],
			"pointer": [
				"not_available"
			],
			"inputkey": [
				"key"
			],
			"activities": [
				"intent"
			],
			"channels": [
				"preset_string"
			],
			"mappings": [
				"server_mapping"
			]
		},
		"systemfeatures": {
			"tvtype": "consumer",
			"content": [
				"dmr",
				"pvr"
			],
			"tvsearch": "intent",
			"pairing_type": "digest_auth_pairing",
			"secured_transport": "true",
			"companion_screen": "true"
		}
	},
	"os_type": "MSAF_2019_P"
}

Gee Lucas, hope you will have a full recovery soon. Thank you for all your efforts. Just inplemented some flows triggering ambilight and ambihue. Looking promising!

2 Likes

@lucasvdh good to have you back. I’m curious if this will fix the pairing error I’ll try it out in a minute.

No, still parrings error, he sees the code on the TV, but if you retype it, nothing happens.

It’s working on my TV and I don’t have acces to any others models … so it’s a bit hard to test. I couldn’t find any errors in the diagnostic report you sent so I might need to add some extra logging before we can get to the bottom of this.

is there still a difference with cable or via wifi? I now have the TV on cable.

Happy to test anything. I will try fiddling around a bit to see if there are other things.

I must say it is not the most stable TV os I’ve used. Got some HDMI problems with handshakes and ARC my ambilight + hue loses some lights when configuring. The source selection is rubbish but hey… i’ve got ths ambilight :wink:

1 Like

@DaveOne I was hopeful that Evgeny’s solution by powering on the TV via Chromecast would work seeing how multiple people reported it to be a reliable way to wake up their Philips TV.

But after digging a bit deeper I found reports of people saying that even this solution didn’t work for them. This is also the case for me. A reason for this is yet to be found. The TV appears to just completely shut down all of it’s network interfaces (wired and wireless @HuisCHovens) even though(!) it should not be allowed to do this with the “Switch on with Chromecast” setting enabled.

For some people, reinstalling the integrated Chromecast app was the solution to their problems. For others it was activating the Alexa app. (source)

I have just reinstalled my Chromecast app and I’m waiting to see if it makes a difference. To any whom it may concern: I suggest you try both possible solutions mentioned above. You can find the Chromecast app under Internal apps in the Android settings.

You’ve got all the other energy saving settings and WoWlan disabled/enabled? And it still goes to poweroff?.

Yeah, it’s real weird. Everything is aimed at maximum power consumption/being always on and it still turns off. However, I’ll post here tomorrow what my findings are regarding the potential Chromecast fix.

FYI:

I use a different work-around to keep my tv on.
Installed Wakelock Revamp (installed the mobile version via apk) and enabled the processor option. This keeps the tv in standby but reachable via network and also ADB.

With this option you can also wake it up with Chromecast.

1 Like

Thanks for the suggestion, I’ll try this next.

Reinstalling the Chromecast app did not result in the TV staying on for me.

1 Like

i also tried that trick with chromecast but didn’t work for me either.

I can confirm that this solution works for me, thanks @martijnpoppen!

1 Like