Homey Community Forum

Please help, no more working Z-Wave devices after update

Hi All,

Today I upgraded to version 5. I have about everything working on Z-Wave devices and there are a lot of them already throughout the house, mainly Fibaro, Aeotec and Neo Coolcam.

As far as I can tell now they all stopped working after the update. Sometimes I get the “Timeout after 30000 ms”, sometimes a “Device not found”, but most of the attempts the interface just acts like everything is fine, but nothing happens with the light.

Lights that were on before the update can no longer be turned off and I lost all control of my house at the moment. Some door and motion sensors do still seem to work, but the lights are gone.

If I try to add a new Z-Wave device it is displaying “Waiting for Z-Wave” like forever. This is no improvement at all. I was looking for the Z-Wave page where you could see all your Z-Wave devices and hubs etc. Did they remove that as well? I can only find settings/z-wave it is displaying the region and has a reset option (last thing I would want to do) and remove a Z-Wave device, but it is not displaying any devices there.

Did I miss something we need to do in order to have it reconnect to all Z-Wave devices again? Or is this some kind of epic f-up?

These all should work perfectly fine with V5, so don’t panic just yet. If you just updated, especially if you did so manually, you might not have gotten all the updated apps yet. This is most important for zigbee, but it could also apply to z-wave. If some of the devices that route for others are not working just yet, it might explain all of your troubles.

So first of all I would check to see if all the corresponding apps of the devices you mention are up to date. Go to the app store to see if there’s a newer version, but also check if there is a “test” version (don’t take this to literally, most times it’s the well tested v5 version instead of the older V4 version.
You do this by putting /test behind the url of the app in the app store. If you stay in the same page, that is the latest, if you get a banner for the test version, install that version.

If that doesn’t work, there’s the usual suspects for weird behavior:
Perform a PTP (more than 10 minutes off power).
Try a different adapter of 2.1A or higher

If that doesn’t help: try this procedure (ignore that this is Zigbee related, it’s to make sure you got the full update for V5): HOWEVER: YOU CAN SKIP THE ZIGBEE RESET, since you don’t seem to have trouble there. A zigbee reset will require you to relink any zigbee devices).

Thanks for your amazingly quick response Edwin_D. I did see directly after Homey was updates that Netatmo, Fibaro and Aeotec were also updates (to resp. 5.1.0, 3.0.7 and 3.0.8). I will try to see if there is any newer version for them.

If all that fails,
i would check the developer pages → z-wave if you can see why z-wave is still busy, maybe something is keeping the z-wave chip too busy constantly.
under “System Information” you will see what command is currently being active/in process.

1 Like

Thanks! I was looking for that page :-). Something weird happened over time, it got a lot better again, only some still don’t work (status “unreachable”). Could it be that it was recreating the entire Z-Wave mesh and this took a long time? That could perhaps also explain why adding a new device before indicated “Waiting for Z-Wave” for an eternity?

I can now also add the new device, but it seems as if it (still?) did not find the correct route to some of the nodes. Is there any way you can tell it what route to take? Or could it restore the routes that were always working before the update from backup?

No, Homey has not much to say about routing of z-wave devices, and won’t notice anything going on with the creation of it (so it isn’t the reason for Homey’s z-wave not working), Z-wave also has no function to predetermine routes, routes are build according internal tables that mains powered devices have, you can reset this internal table with the “heal” option (when you press the 3 dots behind each device), but that is everything Homey can do about routing.