Homey Community Forum

Plötzlich alle Fibaro Roller Shutter 2 nicht erreichbar

Nachdem es letztens aus dem Nichts ein Problem mit einem Fibaro Dimmer 2 gab, sind wir heute aufgewacht und konnten keinen einzigen Roller Shutter 2 ansprechen. Weder via Flow, noch einzeln, noch über HomeyKit. Direkt am Schalter geht es überall noch und gestern Abend ging auch noch alles.

Jemand eine Idee?

  • Fibaro App ist auf 3.0.12
  • Homey ist auf 6.0.0-rc.5
  • Beide Updates sind jedoch mehrere Tage her.
  • Mehrstündiges Power-Off hat nichts gebraucht. Sicherungen habe ich auch alle gezogen gehabt.
  • Unter Developer stehen alle Shutter auf Route: “Unknown” und teilweise RxFlags: “Secure (x), Unreachable”.
  • Wenn ich die Hoch- und Runtertasten in der Taste: “Ein unbekannter Fehler ist aufgetreten [request_timeout]”.
  • Timeline ist zugespammt mit “Homey ist beim Erstellen eines Backups auf ein Problem gestoßen. Weitere Informationen dazu findest du im Backup Bereich der Homey-App.” Sonst nichts. Online sind nur noch rc5 Backups übrig.

Alle anderen Fibaro Geräte und Flows gehen noch (Plugs, Dimmer, Buttons) und auch andere Hersteller.

Hier das letzte Problem:

Alle Roller Shutter erneut anzulernen wäre übel. Und das ist jetzt das zweite Problem aus dem nichts. Das erste ist auch mit einer normalen Homey Version passiert - ohne 6er rc.

Außerdem kann ich kein Backup erneut einspielen. Ich habe nur die Option “Keep your data” oder “Reset to factory settings”. Wenn ich es richtig verstehe, sollte dieser Screen unter setup.athom.com auch die Backup-Option beinhalten?

Du hast nicht zufällig 7 RS2 (= 7 „Unknown“ Route aus dem letzten Thread)?

Meinst Du mit Power-Off die Module oder Homey?

Du hast nicht zufällig 7 RC2 (= 7 „Unknown“ Route aus dem letzten Thread)?

Ne, die hatte ich ja entfernt.
Aktuell stehen
9 Roller Shutter auf “unknown” und “Secure (⨯)”
3 auf “unknown” und “Secure (⨯), Unreachable”
5 auf “Prev. last working route” und “Secure (⨯), Unreachable”
4 auf “Prev. last working route” zusammen mit “Secure (⨯)”
1 auf “Last working route” mit “Secure (⨯)”
Keins davon reagiert. Auch wenn man die Tasten betätigt, werden keine Stromverbräuche oder so angezeigt.
Seit dem letzten Problem hat ja alles funktioniert. Ich hatte auch Flows erstellt, die alle gut durchgelaufen sind.

Meinst Du mit Power-Off die Module oder Homey?

Homey hatte ich für mehrere Stunden abgesteckt. Sicherungen, an denen die Shutter hängen, für mehrere Minuten.

Was mich auch wundert, dass ich kein Backup einspielen kann. Nur Factory Reset oder Daten behalten.

Ich meinte natürlich RS2 und nicht RC2, hab es in meinem Post geändert.

Ich bin mir nicht 100%ig sicher ob die Interpretation der Status in der Spalte “Route” richtig ist, aber nach meinem Verständnis bedeutet das folgendes:
Unknown = Gerät nicht erreichbar, sollte definitiv nicht funktionieren
Prev. last working route = Gerät hat eine längere Zeit keine Rückmeldung an Homey gesendet, sollte aber noch funktionieren
Last working route = alles ok

Die Info “Unreachable” in der Spalte “Flags” kann ich nicht eindeutig erklären, bedeutet aber definitiv nicht, dass die Geräte tatsächlich nicht erreichbar sind. Bei mir wird “Unreachable” meistens bei Geräten angezeigt, die einen rel. hohen Rx-Wert (an Homey gesendete Daten) haben. Dennoch funktionieren die Geräte einwandfrei. Und wenn ich auf “Heal” klicke verschwindet das “Unreachable” auch sofort, kommt aber nach einer gewissen Zeit wieder.

Der User “Caseda” kann bestimmt noch deutlich mehr dazu sagen, das ist mMn nach DER Z-Wave Experte hier im Forum, spricht aber nur niederländisch und englisch.

Was passiert denn wenn Du bei den genannten Geräten in Dev auf “Test” klickst?
Hast Du noch weitere Z-Wave Geräte? Wenn ja wieviele, getrennt nach Aktoren/Routern und batteriebetriebenen Geräten?

Bzgl. des Backups kann ich leider überhaupt nichts sagen, ich musste bisher auch kein Backup zurückspielen.

1 Like

Hatte ich noch vergessen zu sagen: Heal/Test hat auch nichts gebracht. Network request failed/Node X is unreachable. Andere Fibaro Geräte gibt es wie gesagt haufenweise. Die funktionieren alle noch. Nur nicht die Rollos.

@Caseda Could you please have a look with Google Translate?

Wenn ich das an dieser Übersicht richtig gesehen habe, sind es 11 Rollos + 1 Markise.
10 Rollos und die Markise haben einen Tx Error von 100 % (Tx = von Homey ans Gerät gesendete Daten, Fehler bedeutet keine Rückmeldung vom Gerät erhalten).
Allerdings wurde Homey grade frisch neu gestartet.

Hast Du die Fibaro App mal neu gestartet?
Was ist ID25 Rollo Kamin für ein Modul? Das scheint ja zu funktionieren.

Auf lange Sicht würde es definitiv Sinn machen alle Z-Wave Geräte die im Moment noch als “Secure (S0)” inkludiert sind, unsecure zu inkludieren. Dadurch wird der Z-Wave Datenverkehr reduziert und alles sollte flüssiger und stabiler laufen. Hat mit dem jetzigen Problem aber vermutlich nichts zutun.

Der Screenshot ist nur ein Auszug. Insgesamt sind es 86 Nodes.
Es sind mehr als 10 Rollos. Die Markise hat auch einen Roller Shutter dran bzw. ist es nur der Roller Shutter, da keine Markise verbaut. Es sind einfach wie gesagt alle Roller Shutter 2 nicht steuerbar. Alle anderen Fibaro Sachen gehen. Rollo Kamin ist auch ein RS2. Geht auch nicht.

Homey, HomeyKit, Fibaro App hatte ich als erstes erfolglos neugestartet.

Warum sollte man die Geräte als Unsecure inkludieren? Ich hatte sie ganz normal alle in Homey integriert. Wie kann ich das überhaupt beeinflussen?

Nachricht an Athom mit Verweis an diesen Threat und Log sind auf jeden Fall raus.

Warum hatte ich ja erklärt: (deutlich) geringerer Datenverkehr.
Homey ist leider kein GW welches Daten mMn nach gut verarbeiten kann. Das sieht man z.B. daran, dass oftmals bei gleichzeitig getriggerten Aktionen (z.B. gleichzeitig mehrere Lichter ein-/ausschalten) immer wieder Geräte entsprechend nicht geschaltet werden. Aus diesem Grund habe ich meine Flows mit mehreren Aktionen soweit wie nötig auseinandergezerrt (mit Delays).
Allerdings hatte mir zu Zeiten meines Fibaro HomeCenters 2 ein Mitarbeiter von der Fa. Intuitech (Deutscher Fibaro Distributor) auch bereits schon empfohlen, gleichzeitige Aktionen zu vermeiden.
Ob es sich dabei um ein generelles Z-Wave Problem bzw. um eine Z-Wave spezifische Eigenschaft handelt, kann ich nicht sagen. Von anderen Usern habe ich allerdings immer wieder mal gelesen, dass das mit ihren alten Gateways problemlos funktionierte.

Z-Wave Geräte, egal welcher Hersteller/Typ, kann man “unsecure” inkludieren, in dem man irgendein Fibaro Walli Gerät anstelle des eigentlich korrekten Gerätes zum inkludieren nimmt. Durch die im Gerät hinterlegten Infos wie zw_manufacturer_id, zw_product_type_id und zw_product_id werden die Geräte trotzdem richtig erkannt, aber halt “unsecure” inkludiert.

1 Like

Puh, also wirklich ein anderes Gerät vorgaukeln und dann auch noch alle Geräte neuanlernen. Schön ist es ja nicht und eigentlich komplett gebastelt. Danke trotzdem für die Infos.

Ich hoffe auf Hilfe von Athom. Die Sachen und Flows haben ja alle gut funktioniert. Auch Flows mit mehreren Rollos und Z-Wave Lampen. Insbesondere nach dem 5.0 Update bei Homey.
Nur, dass jetzt zum zweiten Mal Sachen einfach mal so nicht mehr gehen, ist sehr unbefriedigend.

Dass ich keine Möglichkeit habe ein Backup einzuspielen, ist auch mau.

Gebastelt und vorgegaukelt wird nichts, keine Sorge. Letztendlich wird das richtige Geräte mit allen zu Verfügung stehenden Funktionen inkludiert, nur halt “unsecure”.
Bei andere GW, z.B. dem Fibaro HC2, kann man das bei der Inklusion auswählen. Warum Athom diese Option nicht auch anbietet weiß ich nicht.

Ja, das mit dem Backup ist wirklich mist. Ich hoffe, dass ich nie darauf zurückgreifen muss.
Vielleicht liest ja noch jemand anderes den Thread und kann behilflich sein? @RonnyW und @Undertaker?

Info falls nicht bekannt: Um eine Exklusion/Inklusion der RS2 durchzuführen, müssen diese nicht ausgebaut werden. Durch 3faches Drücken einer der beiden Tasten funktioniert das auch.

Das einzige was ich dringend empfehlen würde, ist den Homey per Powerbank oder Verlängerungskabel in die direkte Nähe des Moduls zu platzieren.

Hi, ich kann vermutlich nicht viel beitragen außer…

  • durch Auswahl des Walli zwingst du Homey lediglich, den unsecure Modus zu verwenden (der Walli kann nur unsecure). Sonst includiert Homey immer secure, wenn die Geräte das können. Ich meine Thermostate (Eurotronic) mittlerweile auch umsecure und seit dem keine Probleme mehr mit seltenen nicht übertragenen Aufrufen. Das verringert die Übertragungs- und Verarbeitungszeiten, was bei vielen Geräten/Routern die Übertragungen stabiler machen kann.
  • Zum Backup kann ich nichts sagen. Ich zahle nur brav für Homey+ und hatte es noch nie benötigt :innocent:
1 Like

Danke für die flotte Antwort Ronny! Dann werde ich vielleicht im nächstes Schritt wirklich unsecure anlernen. Bringt es denn ein Sicherheitsrisiko mit sich?

Und Backup … tja … Bisher zahle ich auch einfach - mittlerweile im zweiten Jahr. Nur doof, wenn es nicht geht. Werde vielleicht dazu ein Thema im englischen Teil separat eröffnen.

Theoretisch ja. Wenn jemand vor deiner Haustür mit einem ZWave Sniffer mithört. Dann könnte er vielleicht dein Rollo runterfahren.
Ich kann das Risiko bei Thermostaten vertreten.
Wenn man mit einem ZWave-Taster die Haustür öffnet, dann vielleicht diesen besser secure einbinden :sweat_smile:

Ich kann auch nicht mehr dazu beigetragen, als schon gesagt wurde.
Ich persönlich habe alle Geräte unsecure angemeldet. Die Gefahr von einer Manipulation ist doch recht gering. Bei Zwave hatte ich das noch nie, dass einfach Geräte ausgestiegen sind. Zigbee ist da eine andere Geschichte.
Ich denke dir wird nichts anderes übrig bleiben, die Roller Shutter neu einzulernen. Da das Mysterium nur diese Geräte betrifft, kann der Fehler eigentlich nur an der Fibaro App oder an den Roller Shuttern selbst zu suchen sein.
Ich kann nur für dich hoffen, dass das ein einmaliger Fehler gewesen ist und du nicht nochmal alles einlernen musst.

Dto.

Ich bin, was die Homey FW und die Fibaro App-Version betrifft, auf identischem Stand. Ich habe auch 4 RS2 in Betrieb und habe keine Probleme.
Das ist halt mal wieder das merkwürdige mit Homey… :man_shrugging:t3:

@homey_user, welche FW hast Du auf den RS2 installiert? Meine sind alle auf 26.26.

Das lässt sich leider nicht auslesen. Feld Firmware-ID fehlt bei allen RS2.
Gekauft wurden die vor ca. 2 Jahreb bei Intuitech.
Updated kann ich die ohne Home Center ja eh nicht.

Sollte entweder unter den erweiterten Geräteeinstellungen bei „Firmware“ und „Unterfirmware“, oder in Dev. in der Rubrik Devices bei „zw_application_version“ und „zw_application_sub_version“ stehen.

Updaten könnte ich die, bzw. bei der Menge macht es eher Sinn wenn ich Dir das HC2 zuschicken würde. Dann bräuchtest Du die RS2 nicht alle ausbauen und die Rollos wären weiterhin funktionsfähig, zumindest über die Schalter.

Danke für das Angebot mit dem HC2. Braucht man denn die Updates unbedingt? Bringt es was in Kombination mit Homey?

Die Firmware lässt sich bei den besagten RS2 leider wirklich nicht auslesen. Die Felder sind in der App nicht vorhanden, unter developer leer.

Na ja, so ein Geräte FW Update kann Fehler/Probleme beseitigen, auch was die Kommunikation betrifft, oder auch Features hinzufügen.

Generell kann ich mir es aber nicht vorstellen, dass in diesem Fall eine unterschiedliche FW das Problem verursacht. Warum haben die RS2 ca. 2 Jahre funktioniert und jetzt nicht mehr. Die letzte Fibaro App Aktualisierung ist ja auch etwas her. Außerdem sind meine RS2 von ungefähr August/September 2018, also theoretisch älter, und ich kann mich an kein FW Update erinnern. Das Angebot besteht aber weiterhin.

EDIT
An Deiner Stelle würde ich einen RS2 versuchsweise mal neu inkludieren und überprüfen, ob dieser dann funktioniert oder nicht.
Es kann dann sogar sein, dass die FW dann in den erweiterten Geräteeinstellungen bzw. in Dev. erscheinen. Warum? Weil zum Zeitpunkt der ersten Inklusion die Fibaro App das Auslesen der FW-Daten vielleicht noch nicht unterstützt hat.
Wenn ich das richtig in Erinnerung habe, wird die Gerätebedienungsoberfläche etwas anders sein. Dir wird vermutlich die Ansicht mit den „Hoch / Stopp / Runter“ Tasten fehlen. Die manuelle Bedienung erfolgt dann nur noch über den „Schieber“. Damit funktioniert das „Hoch / Stopp / Runter“ aber prinzipiell genauso.