Homey Community Forum

Positioning of a Fibaro Walli Roller Shutter not working :(

Hi everybody,

I’ve installed one Fibaro Walli Roller Shutter one month ago, and some other ones more recently. The forst one works fine but not the other ones.

When opening and closing the shutter with Homey, everything’s working fine. But when trying to open them halfly using their position (like 50%), only the older one works fine. The other shutters receive the flow demand (they do a little noise) but they do not move, unless the % is 100 or 0.

I’ve had a look at their parameters, and the only difference I’ve seen is that :

Could somebody help me to solve this problem, please ?

Thanks a lot !

Weird, it seems like 2 different models.
Sometimes “Interviewing” the device can help.
https://tools.developer.homey.app/tools/zwave

What do you mean by interviewing ? I don’t see such an option (but it’s the first time I go to this web page)

I don’t run zwave, but in zigbee it looks like this


Isn’t such a button available on the zwave page? (Could be)

Z-Wave has no interview, instead you can press the 3dots on the right , there you get a menu for Test, Heal and some more, try Test a couple of times with some interval (wait for the response every time)

1 Like

2 Assumptions:

  • Parameter 151 “Operating Mode” is set differently (-> Advanced Settings).
  • The type (Other, Sunshade, Shutter, Curtain) is set differently (-> Edit devices)

But I guess the 1st one.

Z-Wave has no interview, instead you can press the 3dots on the right , there you get a menu for Test, Heal and some more, try Test a couple of times with some interval (wait for the response every time)

Test works fine. All my devices are reachables. I guess that’s not the problem …

2 Assumptions:
_ Parameter 151 “Operating Mode” is set differently (-> Advanced Settings).
_ The type (Other, Sunshade, Shutter, Curtain) is set differently (-> Edit devices)
But I guess the 1st one.

I’ve not found “Advanced Setting” nor Parameter 151 “Operating Mode”, but when I look at the devices parameters using the Developper’s web page, I see different windowcoverings_set Capabilities for each device :

  • for the one that works fine : windowcoverings_set = 1 (and there’s no windowcoverings_tilt_set field)
  • for these which do not works fine : windowcoverings_set = 0 or 1, and there’s another fild windowcoverings_tilt_set is null or = 0, depending on the devices

If you think Parameter 151 could be the solution, please could you tell me where I can go to Advanced Settings ?

Thanks a lot !

Homey Smartphone App → Devices → search for the Fibaro Walli Roller Shutter tile/icon → long tap on the tile/icon → tap on the gear :gear: wheel on the upper right site
This is the screen where you can choose between the types “Other, Sunshade, Shutter, Curtain”.
Tap on “Advanced Settings” → 1. register “Blind settings” → “Blind type”
There you can choose between different types of blinds acc. the manual:

1 Like

Positioning still does not work when adjusting the 151 parameters :frowning:

  • For the one that works fine : Roller blind with positioning and Curtains
  • For these that do not work : Roller blind with positioning (it was already this one, but I savec it once again to be sur it’s OK) and Curtains (it was Others).

I’ve also rebooted Homey, but nothing changed …

For information, there’s a small difference when using Homey for the devices that do not work fine :

I really don’t understand anything to thses Roller Shutters :pleading_face:

Two other possibilities:

  1. Two different firmware version of the Walli RS, you can check it in the advanced settings or in Developer (but I don’t believe that this would cause this problem)
  2. Athom updated the Homey firmware and/or Fibaro app between the first and second inclusion and they changed the capabilities of Roller Shutter

Both are assumptions by me and are not based on knowledge.

Firmwares are the same …
I’ve opened a ticket to the Homey suppor team. I’ll tell yoy when they answer me …

1 Like