Homey Community Forum

Presence detection

Hi everybody!

Since a month ago I have problems with the build in homey presence detection.
Homey does not register when me or my wife presence anymore.
It always worked perfectly since a month ago.
When I leave the house nothing happens, but when I open my homey app it immediatly sets me on ‘leave’…
It does not set me to home, I have to do it manually… it is very annoying because I use it for security as well.
I have a homey 2019 model, with iOS iPhone 12 and tried everything to fix it;
Restart Homey
Turn on and off the Location settings in Homey app and iPhone settings

Can anyone help me please?
Thank you in advance

See the image, when I open the app you see “is weggegaan” (left) a few seconds ago

image|231x500

Hi Dave!
Which firmware version is Homey on?
Presence with Homey v4.x was not of any use (way to slow)
Since v5 it works very well. It uses location and Wifi of the users’ phone, I use Androids btw.

  1. I’ve read iPhones tend to switch Wifi and location off to save batteries or for other reasons; Maybe you should take a look at the energy settings, and forbid the phone to switch things off.
  2. Set your home location manually on the map, not ‘Find Homey’s location automatically’ (more>settings>location)

Hi Peter,

Thank you for your reaction and input.

I’am on version 5.0.4
The Homey does not use the location automatically, so it is set to manually. What I saw was that the pin on the map was not correct, so I moved it to my house. But when I opened the Homey app again, it set me to leave :frowning:
My iPhone does not switch to saving mode, I also read some things about that, but unfortunatly it’s not it…

Hi Peter,

Quick update after a few minutes I opened the Homey app again, to see if it set me to leave again and it set me to home a few seconds before I opened the app!

So maybe it worked because the pin was not in the correct place! Fingers crossed that it will work now :crossed_fingers:

Thanks again!

1 Like

Nice to hear Dave. Hope it helps!