Homey Community Forum

Presence-flow

#1

Hi. Beacuse the presence built in the app doesnt work on my girlfriend phone. Ive made a ifttt flow.

It starts with my girlfriends phone connects to the router, then the flow mark her as home and the other way around if shes disconected.

It works kind of well but sometimes she disconects even if shes home. That results in start of some other flows. For exempel turn all the lights of If nobody is home.

Is there a way to ad a timer or something to stop that?

Like if she disconects but is conected again in a five minute period?

Like a delay on the disconect part and If shes conected again the flow for marking her away is stopped?

#2

you can use the countdown app.

when your gf disconnects start the timer (5min) and when the timer goes to zero you mark her as away. In the flow where she connects you add the card to stop the timer.

1 Like
#3

ive tried that but it doesnt work for me. the timer goes on anyway or when the flow tells the timer to stop beacuse shes online again, it just goes to zero right away and does the same thing as if the time runs out.

so if she goes offline the timer runs, when shes online again the timer goes to zero and mark her as away.

#4

. I do not have a connection to my homey now because i am moving to a new home, but maybe somebody else has a example for you.

#5

im now trying with this.

when:
ifttt start the flow

and:

then:
mark away after 5min

#6

and the other.

when:
ifttt start the flow.

and:

then:
mark as home.
disable the away flow
enable the away flow (delay 60sec)

#7

ah okay. the flows i used didnt work either

#8

aaaaahhh you are using the build i timer. That will not work. you have the app which is called countdown. This ill give you the ability to start, stop and restart a timer.

you will need 3 flows.

  1. If :
    IFFT says you GF is home
    then:
    mark home and stop “countdown” timer

  2. If :
    IFFT says you GF is away
    Then: Start thew countdown timer on 5min

  3. If :
    Counterdown timer reaches 0
    Then: mark gf away

in the topic below there are some examples:

#9

Ive used that to. Thats What i explined st First

Skickat från min iPhone

#10

Maybe u can post some screenshots of this ?

#11

#12

Uploaded them now. As soon as i connect to my wi-fi its like the timer gets to zero right away Instead of stopping

#13

Maybe @Jeroen_Bos can take a look at this flows?

#14

It works now. Ive changed the app

1 Like
#15

I Dont now What the problem was but the app i used didnt stop, it did run direct to zero wich made the flows go banarnas. Ive got a tip and ive changed the app to this. https://apps.athom.com/app/nl.bevlogenheid.countdown

Now it works great so far.

1 Like
#16

Thanks to https://community.athom.com/u/Rocodamelshe

2 Likes
#17

maybe you would like to consider to use wifi for the “home” and location for “away”. This so you skip the disconnections during dooze and don’t need the countdown,. As a bonus, if she switches wifi off to do whatever or has a poor signal she won’t be put to away mode.

I use wifi+location to get the whatever servers first for the “home” status and location for away.

1 Like
#18

Maybe i Will try that later on. For now it works just fine with the timer. But thanks

#19

hwo do you trigger wifi with iftt?

#20

An applet made for tp-link router

Skickat från min iPhone