Homey Community Forum

Problem in config Sonoff pow switch with home assistant app

Hello,

I installed home assistant 0.98.4 on raspberrypi 2. I configured the mqtt service in the raspberry pi and then I configured the configuration.yaml file.

It’s the config of the mqtt:

mqtt:

broker: 192.168.31.51

username: or94

password:

discovery: true

discovery_prefix: homeassistant

I configured shelly switch and yeelight in the same file and everthing works great. Yesterday I flashed tasmota for the sonoff pow R2 switch. I configured the mqtt service in the web interface:

I enabled the mqtt in the configure other option in the sonoff web inteface and I wrote friendly name.

Then I tried to config the sonoff in the configuration.yaml:

switch:

  • platform: mqtt

name: “Boiler”

state_topic: “stat/sonoff/power”

command_topic: “cmnd/sonoff/POWER”

qos: 1

payload_on: “ON”

payload_off: “OFF”

retain: true

I restarted the Home assistant server but nothing happened and I don’t have a switch. I saw in the console in the web interface of the sonoff switch and it connected to the wifi and to the mqtt server.

What I am doing wrong?

Thanks

Your question isn’t related to Homey at all. Perhaps you should post it on the Home Assistant community forum instead.

Closed for above reason.