Homey Community Forum

Problem with Countdown app

I noticed the same.

I figured out the alternative solution. In the app setting Export the setting and delete necessary raws in code. Click Delete all and import the adjusted code. The flows which are unchanged work fine after import. Cheers

I have a flow which closes blinds when it starts to rain or rain is expected. A countdown Raintimer (15 minutes) is started to prevent opening and closing too often by checking if it is still raining. If rain hasn’t stopped, the countdown Raintimer restarts. If raining has stopped AND logic daughterasleep = NO then countdown Raintimer stops and blinds will open.

At 20:15 the blind closes every day, the countdown Raintimer is stopped and logic ‘daughterasleep’ changes to yes. This way i want to prevent that the countdown Raintimer starts over night.

Somehow there are situations where the countdown timer starts during the night eventhough the only trigger to start this countdown is “IF Raintimer is empty”

Is it possible that a Countdown flow randomly triggers when IF is configured as “If hourglass Raintimer is empty”? (because when an hourglass is empty it is still empty one hour later and could trigger the flow one hour later?)

May be a faulty trigger, timers are not randomly triggered :wink:

Thanks, it was a faulty flow :man_facepalming:t2: which i managed to solve.

1 Like

Hi all,

having some trouble with a flow in the countdown app. i have a 3D printer witch i want to shut down when the print is ready. now i have made 3 flows:

what i am trying to accieve is that when de energie comes below a value the timer starts. But when is start a new print during the running time of the timer and the energie comes above a certain value the timer has to stop. When the timer is finished it need to shut down the printer and server.
Does this make any sense?

Forget these flows and get the mqtt plug-in on ur octoprint. With these messages u can do a lot more. Not guessing when printing is done but get a message when printer is done . Also the Telegram plug-in is nice to have. Get messages including a pic when printer is done .
Plz let the printer cool down before u shut it down.
And don’t forget to shut down the Pi with a http request before u pull the plug.

Ai ai that’s a lot to learn I see. Was already working on the telegram plugin now. Http request? Man is there still a lot to learn. Oke I will start from the top this weekend and work thru the option you gave me

Hi anybody such problem like me? I have motion triggered flows for lights with countown to turn off. I exeprience nonreliability in turning off my lights. Sometimes the do not turn off evethough time went to -1. Its almost like 50/50. :thinking: Running v5 stable, latest coundown app.

How many lights are you turning off from the flow, and what type (Zigbee, Z-Wave, WiFi, …) are they?

It is only one Hue bulb via hue bridge in each hall. I might be suspecting the processing limits of Homey, since I do not have PRO but big number of flows. I will also try to switch from contdown counter to “specific device inactive” cards. I also added mobile notification for flow sequence to know if both following flows go through. Manually testing all works fine.

This has most likely nothing to do with the countdown app but with the bulbs or with the flows u made.
Maybe show us the flows ur using with screenshots or shared flows so we don’t have to guess the flows are correct or not.

motion turn on light and trigger timer

Light adjustment acc. time

Timer zero turn off light

What I noticed is that it triggers the OFF flow but immediately the light turns on ( so not true that the countdown not working). I was afraid that the Turn on flow trigger could cause mess, so I also used flows sequence when i Start this flow instead of Turn on trigger is a trigger.

Maybe try this example and check if it works.
U can also delete the AND cards and check if it works but i ( personal opinion!) don’t like to start the timer on motion but i love to start the timer when motion turns off, like in the example given.

I did rebuild the flows so that the counters star when sensor goes off. Unfortunately the behavior remains. I notice when final light OFF command comes, I see it start dimming off but instantly the light turns on right away. I must have something wrong, but i checked my flows many times, i cant find how to log or debug this issue :thinking:

Past new screenies/shared flows. :wink:

Tricky stuff. It seems that the problem comes when I implement two sensors in the same room. When I disable one of the sensors, it seems working correctly. When I pass through both sensors than the light “ON trigger” repeats because sencond sensor also triggered it after the light turns OFF.
image

Motion turns on the light after sunset and stops the counter

Or second sensor

Dim according to daytime
I have 4 light statuses according to daytime

Start counter after sensor off

Turn off light

Then maybe use :

No matter how many sensors in a room, they will all join the flow.

Thanks, i did these:
step one
step two
etc.

EDIT: seems this is optimal. There are no double triggers, the counter stop reacts always on motion and turns on the light only when the light is off. ideal i think. Thanks for your hints

1 Like

Arghh. unfortunately the problem persists even with changed flows. It means few times a day when the lights are automatically being turned off (after timer 0) they instantly turn on. Its both halls occuring I suspect the Hue lights itself. annoying :thinking: