Homey Community Forum

Problem with lag speed/responsiveness between protocols, triggers and actions

I hope this question makes sense and that someone can shed some light on this.

TLDR: Is there any difference in speed in protocols? If so which is faster? What is the best practice to get smooth performance?

Before using Homey I was only using Philips Hue lights and I never once thought about any “lag” between pushing a button and a light turning on. After installing Homey and adding Hue lights to it through the Hue bridge I was able to get rid of the hideous Hue buttons (personal opinion) in exchange for some neat Aqara zigbee buttons. However there has become an issue of lag.
For example, pressing one button on an Aqara switch triggers three different lights, one Hue through the Hue bridge, and two nexa 433mhz sockets with lights. None of them are “instant”… The Hue light starts relatively fast (1,5seconds give or take), the 433mhz sockets take about 2,5 seconds. But i still think that 1,5 seconds from pushing a button and having the light turn on, is too much. When I have guests, they often press the button twice because they think they must have missed the first time or something, that’s how long 1,5 seconds is…
Is the problem, my Aqara buttons, my flow, the integration with Hue bridge or 433mhz or a combination? Can I do anything to make it work better/faster/smoother/harder (I realise it’s difficult to say without me explaining my entire setup, but if I’m alone with this issue, I can assume that the problem is self inflicted) I would be very happy if someone who knows something could tell me what to do…

Unfortunately in my opinion No. This is what it is. Therefore i use door sensors and motion sensors. Same lag, but when I get as far as my buttons, lights are on.

Thanks for the response. Do you think it has to do with Homey itself then? Are other systems faster? Like fibaro or smartthings?