Homey Community Forum

Problems adding Mysensor devices

Hi,

Really new to Homey (day 2) but starting to get the hang of things. With my previous controller I used MySensors to control arduino relays (a 8-channel board). I found out that MySensors is also supported through a third party app for Homey and I’ve tried to get it working but I think I’m missing something. If anyone out there has some insight I would be most greatful. This is the steps I’ve taken so far:

  1. Install the Mysensors app. No problem.
  2. Configure the app with the ip and port of my mysensors ethernet gateway. Checking the app log and I see that first there are log entries related to the app not being configured (like mqtt_host of null -> not using mqtt, I use the ethernet gateway), but after that it’s a mix of Gateway startup complete and pairing, initPair and GC Called. So, OK so far I guess.
  3. Go to Devices -> press + to add a new device -> select Mysensors and see that MySensors Driver has a red triangle on it and I can’t do anything with it.
  4. Restart Homey.
  5. Repeat step 3 but now the red triangle is gone and I can press the Mysensors Driver button.
  6. I get a popup saying “Mysensors.org This action will install Mysensors Driver” and a big green button “Install” which I click.
  7. New popup “Add your sensor” with a big blank white box which only contains the text “You may close this window.”
  8. Can’t move forward, only thing I can interact with is the back arrow next to the heading “Add your sensor” so I click that and go back apparently without being able to add the device…

I’ve tried rebooting the Homey and repeating steps 5-8. I’ve also tried uninstalling and reinstalling the Mysensors app. Then I get to do steps 1-8 again. :slight_smile: I’ve also tried rebooting my ethernet gateway.

Note; my old controller is still connected to the mysensors ethernet gateway as well. I don’t see how this should matter, but please tell me otherwise if it’s so.

Is it me; am I missing something, or is the app currently broken? Any help to be found for this issue?

Otherwise pretty impressed with the Homey so far!

Thanks in advance for any suggestions!
Tim