Homey Community Forum

Qubino Flush Dimmer powermeter funcion not working

Hello,

I installed a qubino ZMNHDD1 flush dimmer, and in the homey there is no report of power usage / energy.
I logged in to the developer.athom.com area and i see the qubino sending z-wave messages to homey in the logging.

[2019-02-27T15:20:23.393Z] Node[2]: Received application command for COMMAND_CLASS_METER, data: 0x02215400004483012d0000451a
[2019-02-27T15:20:23.395Z] Node[2]: [COMMAND_CLASS_METER] {“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[33]},“Properties1”:{“Scale bit 2”:false,“Meter Type”:“Electric meter”,“Rate Type”:“Import”,“Meter Type (Parsed)”:{“value”:“Electric meter”},“Rate Type (Parsed)”:{“value”:“Import”}},“Properties2 (Raw)”:{“type”:“Buffer”,“data”:[84]},“Properties2”:{“Size”:4,“Scale bits 10”:2,“Precision”:2},“Meter Value”:{“type”:“Buffer”,“data”:[0,0,68,131]},“Delta Time (Raw)”:{“type”:“Buffer”,“data”:[1,45]},“Delta Time”:301,“Previous Meter Value”:{“type”:“Buffer”,“data”:[0,0,69]},“Scale 2 (Raw)”:{“type”:“Buffer”,“data”:[26]},“Scale 2”:26,“Meter Value (Parsed)”:175.39}
[2019-02-27T15:20:24.498Z] Node[2]: Received application command for COMMAND_CLASS_METER, data: 0x02a1425c82012d5c9d
[2019-02-27T15:20:24.499Z] Node[2]: [COMMAND_CLASS_METER] {“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[161]},“Properties1”:{“Scale bit 2”:true,“Meter Type”:“Electric meter”,“Rate Type”:“Import”,“Meter Type (Parsed)”:{“value”:“Electric meter”},“Rate Type (Parsed)”:{“value”:“Import”}},“Properties2 (Raw)”:{“type”:“Buffer”,“data”:[66]},“Properties2”:{“Size”:2,“Scale bits 10”:0,“Precision”:2},“Meter Value”:{“type”:“Buffer”,“data”:[92,130]},“Delta Time (Raw)”:{“type”:“Buffer”,“data”:[1,45]},“Delta Time”:301,“Previous Meter Value”:{“type”:“Buffer”,“data”:[92]},“Scale 2 (Raw)”:{“type”:“Buffer”,“data”:[157]},“Scale 2”:157,“Meter Value (Parsed)”:236.82}
[2019-02-27T15:20:25.392Z] Node[2]: Received application command for COMMAND_CLASS_METER, data: 0x02a14a004f012d0050
[2019-02-27T15:20:25.393Z] Node[2]: [COMMAND_CLASS_METER] {“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[161]},“Properties1”:{“Scale bit 2”:true,“Meter Type”:“Electric meter”,“Rate Type”:“Import”,“Meter Type (Parsed)”:{“value”:“Electric meter”},“Rate Type (Parsed)”:{“value”:“Import”}},“Properties2 (Raw)”:{“type”:“Buffer”,“data”:[74]},“Properties2”:{“Size”:2,“Scale bits 10”:1,“Precision”:2},“Meter Value”:{“type”:“Buffer”,“data”:[0,79]},“Delta Time (Raw)”:{“type”:“Buffer”,“data”:[1,45]},“Delta Time”:301,“Previous Meter Value”:{“type”:“Buffer”,“data”:[0]},“Scale 2 (Raw)”:{“type”:“Buffer”,“data”:[80]},“Scale 2”:80,“Meter Value (Parsed)”:0.79}

Is this a known bug in the qubino app or am i dooing something wrong ?

With kind regards,
Martin

Niemand een antwoord ? en is er iemand die dit toevallig wel werkend heeft gekregen ?

And what you tried already, wich firmware running ect ect ect

Did you already asked the devolper what it could be.

What i did try is to get in to the developer portal to get these developer messages and read them. and i see the power values beeing send in the z-wave signal.

The app developer is athom itself.

First i connected the device with the current firmware of that time (Feb 2019) and now June (2019) the firmware has been updated several times. Im running experimental firmware.
I also tried to connect the dimmer within 20 cm of homey, as this gave me good results in the past connecting z-wave power plugs.

The app is from 11-2017 so i think there is a bug in this app or another incompatibillity, as im not a developper of this grade i was trying my luck over here.

Edit i logged in to my homey and i see the beta of qubino is installed: Version 2.0.10

Thanks in advance

So you did contacted them right?

My first option was to install the beta, but you already did.

So if you think of that, stil why didnt contact the devolper then. Sounds logic to be onest that you would already done that :slightly_smiling_face: