Homey Community Forum

Reliability of z-wave in flows

I’ve got really bad experience in terms of reliability of flows - mostly for more complex flows.

I’ve got flows which triggers on window sensor and if window is open - radiator valves closes. When window is closed - valves open back again. For rooms with just one valve, flows work perfectly, but in one room I’ve got 3 radiators and when I close window - randomly one valve opens and other two satays closed. (I have homey in that room and there is no more than 3 meters between valve and homey).

Second example is flow which set’s light color according to day time.
At selected time flow turns all lights on, sets color and dim than it turns it off. (flow has about 18 cards).
I expect that when light turns on - it will have correct color and dim. However reality is, that every light has different color (even during night there is a color set during morning - meaning 2 colors skipped).

What’s your experience in reliability?
Is there a way somehow to monitor z-wave?
Is there a way to workaround complex workflows?

Thanks.

I think it’s safe to say that any flow which has multiple action cards, where you change the state of multiple Z-Wave or Zigbee devices, has a high chance of failure, in that some of the devices will not be set to the new state.

This is an issue that has existed for quite some time now, and the only workaround so far is to add delays between each cards:

  • switch on light A with no delay
  • switch on light B with a 1 second delay
  • switch on light C with a 2 second delay (2 seconds since the start of the flow, not since the previous card)

I am experiencing the same with z-wave. I am using Fibaro Dimmer 2 devices. If I switch a single device, it generally works, but as soon as I try to do multiple actions like “Turn off all devices in a zone” then I cannot get it reliable. If I execute a flow to turn everything off, then the time it takes to execute ranges from 5 to 90 seconds and the number of devices that are actually switched off, range from 5 to 7. So worst case after 90 seconds, 2 lights are still on. Best case everything is off in 5 seconds. It greatly varies.

I have already tried:

  • Switching individual devices with delays between them, like robertklep suggested

  • Splitting up the zones so that there are less devices in a zone and then turning off each zone individually with a delay between them.

  • Using the group app to switch off devices in a group

So in the end it is much faster and more reliable to just turn off all the lights by hand. In my case it’s only lights, so if their status is incorrect it’s not such a big deal, but I would never connect any critical device like a door lock or smoke detector to Homey, because I cannot trust it.

Every device that is not connected via Zwave but via TCP/IP like my TV, receiver and Hue lights via the Hue bridge work flawlessly. So I think it’s mainly z-wave that fails and not the Flow engine of Homey.

https://developer.athom.com/tools/zwave >> Log
image

Hello,
thanks for advices. I set-up delay between commands, however it seems that 1 second delay is not enough - better results are with 2 sec delay (2…4…6… etc). However it’s still not 100% reliable.

However this seems to me little bit strange, I had z-wave nw with UZB stick/openhab and also with fibaro HC2 and never has such issues. Did somebody reported that to Athom? What was their reaction? Because it looks to me buggy behavior.

“Buy a Homey Pro”, I believe.

Robert,
I’ve got Pro and it’s exactly the same. Z-wave is the most unreliable network in Homey. And it’s not only with setting multiple devices at once. The same is with receiving the messages. E.g. I use “wasp in a box” algorithm for my toilet lights:

  • when someone opens the door (Aqara Zigbee via Xiaomi Gateway to Homey -> Homey gets this message instantly)
    -> turn on the light (qubino nano dimmer -> connected to Homey Zwave network -> lags 1-2sec to to the work)
    Then:
  • when someone closes the door (as above, Homey is informed instantly)
    -> delay for 7 seconds
    -> check if there was a movement within that period (so if within 7 seconds after the door closes there was a movement signal from Aeotec TriSensor - in Homey Zwave network) and keep the light if there was or turn off if there wasn’t any movement. I can see that sometimes (around 10% of cases) even when the movement was within the first 7 seconds the light closes and Homey receives movement alarm after few more seconds (even if there was a movement within first 5 seconds and totally no movement later). Checking signals on group 2 of the ZWave Network - the TriSensor sends the message instantly. It’s Homey who receives the message after few more lagging seconds…

it’s really annoying that it’s such unreliable.

Piotr

I didn’t say it solves the problem, I said I believe that that is what Athom will tell you when you run into these issues :wink:

1 Like

I’ve got PRO :confused: