Homey Community Forum

Ring Doorbell V2

Don’t know the problem for you but mine does a refresh like instantly. I turn off the lights outside and go back to the device and refresh them the lights are off… so at most half a minute. Which version of the app?

But you have Pro no? And I have V2 and I see lots of other people having the same issue as me with v2 and I see all pro users saying it works fine for them :slight_smile:
I have version 2.3.0

Same here with the V2, it just uses the refresh rate as setup in the Ring app itself (so not the Homey app). Looks like the Pro gets the refresh signal from Homey but the V2 doesn’t, don’t know if there is being said anything on the Ring API about this…

right, yes, that could be the problem. I’m using a PRO indeed. Well, sorry about that then :wink: hopefully, like @DidierVU mentioned there is a API reference somewhere. Good Luck

I have the V2 and can confirm I have the same problem as @Danne. Push notifications with an image aren’t useful now.

2 Likes

Here the same with a V2.
I had one picture for the first time with a person last week. Nothing more since then.

I acknowledge that v2 seems to have a snapshot issue. But it seems to be an API issue on the Ring side. I am unable to get those snapshots if the api returns a not found error. Maybe they changed the api or there is a bug in v2 firmware not updating the snapshot properly. But i do not think its the app. If someone knows a integration that is open source an working with snapshots right now than i am more than willing to look at how they use the API to look for differences.
But I can not fux this without a working example for the v2. For me the ring app not even updates the snap in the device list. only on the timeline they are working.

Hello,

im trying to use the Ring App for my Video Doorbell. However after installing it via CLI i am not able to authenticate. Im getting the Error “Error invalid_authentication 406 406 Not Acceptable nginx”
Any ideas what i might be doing wrong?

Greetings
Martin

Ok, my Ring-Account was disabled 24h because of too many Login attempts.

Now i am Not getting a Snapshot. I am using the Cards postet a few posts ago.

Maybe to much movement?

And which version did u download? And is 2FA on?

I am using the latest one out of the AppStore Right now. I am using 2FA.

Then, assuming ur using the v2 Ring device, there is some problems like stated a few posts up?

I can confirm that on my ring doorbell v2 I only get snapshots after pressing the doorbell multiple times short after each other. If I do not use the ring app for 4 days it also does not give new snapshots there until I open a live view or something like that. So its a doorbell or api issue. Sorry.

Ring has been working just fine for some time now, but I noticed since yesterday I’m getting a ‘invalid content type’ if I go to the device directly. I don’t get the images send to my device anymore. Anything else got this problem?

It works here both motion and alarm plus image. But really weird, the motion now is triggered almost instant whereas the alarm takes about 5s. Some days ago was the other way around…

Right, I guess my token expired. After removing and adding the stickup cam again it works. Wondering if there is a way to not reauthenticate only at adding?

Alarm I haven’t checked…, works almost instant for me.

Hi! Thanks for the good work! I have a question about this. I am trying to make the doorbell (ring v2) go into armed mode, based on a flow. I have tried setting the “enable motion detection” but that does not seem to work.
Any ideas?

App version 2.3.0, tried to authenticate - getting this unsupported_grant_type - error after submitting username and password. Before that, checked from the Ring app that two-step-authentication as their app calls 2fa is set to send text message.

Is this same 2fa error discussed earlier or another one?

… to continue, i can log in to Ring with IFTTT successfully with 2fa, so the problem is not in my credentials.