Homey Community Forum

ROBB smarrt Z-wave and Zigbee app (v1.5.2 | TEST: v2.1.3)

When will the Zigbee Wall controller 8 button be added to the app?

@Qufel I am currently debugging the driver for those devices; expected to be added to the App Store in ~2-3 weeks

1 Like

I’ve just uploaded the v1.1.0 update of the ROBB smarrt app to the app store (waiting for approval), with the following changes:

Credits for @Spikey for adding support for the LED Dimmer - White (Z-Wave)


Now available in the app store: https://apps.athom.com/app/nl.ROBBshop.ROBB-smarrt

The description in the app isn’t for the wall unit but for the dimmer. You have to press and hold the upper I and O and when the green light is on then press the upper O.

@Qufel which device and app version are your referring to?

I’ve just tried to add the ‘Wall controller 8 button (Zigbee)’ but it is somewhat confusing.
There are 2 ways to add the device:

  1. Connect the power on the dimmer, then it will go into inclusion mode.
    This means remove the battery and put it back in. Nothing happens after this.
  2. Press 5 times the reset button and the dimmer will reset itself.
    This isn’t the way the manual says to reset the dimmer. Both options don’t work, nothing happens.
    Also the line ‘The connected light turns on for 3 seconds when the inclusion is complete’ is a bit strange because it isn’t possible that a light is connected.

Both options don’t work, so @TedTolboom what will be the correct way?

The Wall controller 8 button (Zigbee) on version 1.1.1

@Martijn_Kamp see above

Any update when version 1.1.1 will be released?

@Martijn_Kamp version 1.1.1 is waiting for Athom’s app store approval, with following changelog:

1 Like

Can I ask whether support for the Robb Smarrt 5 and 4 button remotes is in the works? https://en.robbshop.nl/5-channel-remote-z-wave-plus-robb-smarrt

many thanks :slight_smile:

look at https://apps.athom.com/app/nl.ROBBshop.ROBB-smarrt
there you find Supported Devices

@smeula Welcome to the Athom community.

You mean this one (4 channel version)?

The 4 channel version (with 2 scene buttons) will be added with the next app update.

The 5 channel will be added in a next update; currently not in stock… also not for me :pensive:

Thank you @TedTolboom, yes I mean both the 4 channel version as well as the 5 channel version. Maybe the 2 are actually very similar or even the same, as the 4 channel also has the 2 scene buttons, so basically like the 5 channel?

They’re not exactly the same:
4-channel: 4 channels to directly (not flow based) control 4 Z-wave devices (or multiple devices), the buttons of these 4 channels double with scene triggers and dedicated 2 scene buttons that can be used to trigger scenes (not able to act as a 5th channel)
5-channel: 5 channels to directly (not flow based) control 4 Z-wave devices (or multiple devices), the buttons of these 5 channels double with scene triggers

I have the Wall Controler 8 button (zigbee). I added the device, but when I create a simple flow,
When - Any button is pushed
Then - Sent push message tag button tag scene to phone
I wont sent any thing. Same applies to When a scene is activated.

What am i doing wrong?

ps. also the battery won’t return how many percentage is left.

thanks :slight_smile:

@Jeroen_W is the device still within range of Homey? At what distance to Homey did you try this?

@TedTolboom thank you for updating the app.

I succeeded in including the 4 button controller into Homey, I get the 6 fast red led blinks on inclusion, it shows up under devices etc. However, I am not succeeding in getting it to control any of the z-wave devices (i’m trying to link it to Fibaro Roller Shutter 3).

I believe have I have up set the associations both in the controller and in the fibaro device, and woke up the controller before saving the settings. Nonetheless, nothing seems to happen when I press the button on the controller to move the blind. When I look at the log I also cannot see any commands sent.

Any help much appreciated, I’m still new at setting up associations.

Hi @tedtolboom

I’ve the same issue with a 4 button zwave controller. I see the controller marked as online. Save the advanced settings in the app. But i cannot see the sendData to COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION, params in the logging.
When i pressed the buttons i can see data being send to homey but non of the fibaro zwave devices are turning on.

Thx for your help.

Hi @smeula, @Keyracer,
Can you share which association group you tried to link to which end point of the shutter 3?
Specifically for the shutter 3, there are multiple endpoints that need to be controlled in the correct way.

Due to holidays, I will not be able to reproduce / provide hands on support in the next three weeks and will have some delay in providing a response.