Homey Community Forum

Samsung SmartTV App

#21

Ok, so selecting the “Approve” button does not work ?

0 Likes

#22

Can du access the “devices” page, and search for “samung”:
https://developer.athom.com/tools/devices

At check what’s under “settings”

0 Likes

#23
Samsung TV
Properties
Property Value
ID XXXXXXXXXXXXXXXXXXXXXXXXXXX
Class tv
Driver homey:app:com.samsung.smart — Samsung
Ready Yes
Available Yes
Custom icon No
Settings
Key Value
ipaddress “192.x.x.x”
mac_address “xxxxxxxxxxxxx”
Capabilities
Capability Type Value Edit value Last Updated
onoff boolean false truefalse 45 minutes ago
volume_mute boolean null truefalse 2 hours ago
volume_up boolean null truefalse
volume_down boolean null truefalse
channel_up boolean null truefalse
channel_down boolean null truefalse
0 Likes

#24

@Aart_Hardeman After upgrading to v. 1.0.3 you need to reinstall the Samsung device. Sorry about that.

0 Likes

#25

I have the same issue.

0 Likes

#26

Did you reinstall the device ?

0 Likes

#27

I tried this with HTTP://tv ip adres:55000/
Still no response
(I did not put < before ip adres)
Is there an option to detect the right port?)

0 Likes

#28

OK. The address would be something like http://192.168.1.15:55000/

0 Likes

#29

Always have the text to accept the homey on the tv. I have accept always in tv settings.

0 Likes

#30

@Jesse_dg You have reinstalled after upgraded to v. 1.0.3?

Can you also check settings if you search for “samsung” in https://developer.athom.com/tools/devices ?

0 Likes

#31

I tried that with my adres.
I did run a nmap on my rasperry
None of the Ports did work out
80
443
4443
6000
7676

I did check my tv modell
UE46F8000SLXXN

0 Likes

#32

I’m having the same problem. It keeps asking for permission. I re installed my TV using the app after updating to v1.0.3.

This is what I see in developertools:

0 Likes

#33

OK, thanks. I can see that the auth token is not stored in settings, as it should be.

0 Likes

#34

I updated the app.
Reinstalled my tv.
But it connects with the homey, but functions do not work.
Not even on or off, i also do not get any errors.
Developer mode on or off didn’t make any difference.
Heres the result of the link:

{
“id”: “uuid:f58a5776-d5a4-45db-9094-e04abfc4d876”,
“name”: “[TV] UE55JU7000”,
“version”: “2.0.25”,
“device”: {
“type”: “Samsung SmartTV”,
“duid”: “uuid:f58a5776-d5a4-45db-9094-e04abfc4d876”,
“model”: “15_HAWKM_UHD”,
“modelName”: “UE55JU7000”,
“description”: “Samsung DTV RCR”,
“networkType”: “wired”,
“ssid”: “”,
“ip”: “192.168.178.113”,
“firmwareVersion”: “Unknown”,
“name”: “[TV] UE55JU7000”,
“id”: “uuid:f58a5776-d5a4-45db-9094-e04abfc4d876”,
“udn”: “uuid:f58a5776-d5a4-45db-9094-e04abfc4d876”,
“resolution”: “1920x1080”,
“countryCode”: “NL”,
“msfVersion”: “2.0.25”,
“smartHubAgreement”: “true”,
“wifiMac”: “fc:8f:90:d6:4d:39”,
“developerMode”: “0”,
“developerIP”: “192.168.178.95”
},
“type”: “Samsung SmartTV”,
“uri”: “http://192.168.178.113:8001/api/v2/
}

I hope its useful to you.
If you need any more let me know!

0 Likes

#35

And this is what developer mode from the homey says.

TV] UE55JU7000
Properties
Property Value
ID 898f4669-7ee7-4c2d-83cf-afaf5ae28e6c
Class tv
Driver homey:app:com.samsung.smart — Samsung
Ready Yes
Available Yes
Custom icon No
Settings
Key Value
ipaddress “192.168.178.113”
tokenAuthSupport false
mac_address “fc:8f:90:d6:4d:39”
Capabilities
Capability Type Value Edit value Last Updated
onoff boolean true truefalse 7 minutes ago
volume_mute boolean true truefalse 12 minutes ago
volume_up boolean null truefalse
volume_down boolean null truefalse
channel_up boolean null truefalse
channel_down boolean null truefalse
0 Likes

#36

@balmli

Do you have any idea what all the keys do?
Thanks

0 Likes

#37

Well, just a few of them …

And not every key will work on the TV, in every situation.

Think you’ll have to test…

0 Likes

#38

For newer 2018+ models, if you had trouble with version 1.0.3:

Check out version 1.0.5 of the app, in app store now.

0 Likes

#39

Tv verwijderd en opnieuw toegevoegd en lijkt nu wel goed te werken! Top gedaan!

1 Like

#40

That’s good to hear :slight_smile: Fijn weekend

0 Likes