Homey Community Forum

Samsung SmartTV App

#41

@balmli I have a “very” old Samsung TV from 2011. It is an UE46D6500 and it seems not working with your app at the moment. It does not respond to Port 55000 and 8001.
But there is a working api for iobroker that supports TV´s older than 2014 and this works fine in my case.

So maybe you are interested to implement this, to support also TV´s before 2014.
For sure I would help testing :wink:

#42

That would-be be Very Nice :sunglasses:
I’m open for testing also.
I,m not sure about the age of my samsung But it is a smart tv
Somewhere at 2014
Type:UE46F8000SL

#43

Added v. 1.1.0 - Beta now in app store with a fix for the “Samsung (legacy)” - device.

This should work for TVs that can be controlled on port 55000.

2 Likes
#44

I was keep getting the “Invalid Socket error”. Removed and added the tv few times sorted this out.

Everything works perfect except power ON. Nothing when I press the button on the app to power ON.
It shows the status ON and if I try to power OFF it says “already OFF”

Power OFF works, thought. It turns the TV instantly OFF>

Anyway, thanks for a good app, at least I know when it is on/off which helps hips in creating nice flows.

#45

The TV must support wake-on-lan (or wifi) to be turned on by the app.

So that might be the explanation

#46

Thank you. It is a 2018 model Q7. I shall look and find out if supports it.

#47

I found the TV setting that allows WoL. Funny, it is not called WoL, they call that “Allow mobile devices to turn on the TV”
Enabled that and now I can turn it ON!

Thanks for a great app!

#48

And a small 5 Euro donation sent. :grinning:

#49

Wow, thanks :slight_smile:

#50

I have a Samsung from a few years ago as well (the remote looks like the ‘legacy’ image :slight_smile:).

I tried both connecting the legacy as the ‘modern’ TV. It finds it (both) and I can configure the IP address. But after configuring the IP address I get an exclamation mark and a message that the TV is not found, check IP address.

When I try “http://192.168.2.19:8001/api/v2” I get the message “Cannot GET /api/v2”.
When I try “http://192.168.2.19:55000/api/v2” I get a cannot find URL.

Is there anything I’m missing and/or need to do?

#51

Have you tried installing the “Samsung (legacy)” - device? That might work.

#52

Just for information:
I have a Samsung TV from 2011 - Model UE46D6500 and thanks to @balmli it works now with the “Samsung (legacy)” Device

donation is on the way!

#53

@balmli, yes, I have tried installing the legacy device. I tried both. It finds the TV, but then says the device is not availble. I double checked the IP address, which is good. The ‘secure connection’ option has nothing to do with it I guess (kept it ‘off’)? No port forwarding required in router? Anything else I can check?

#54

If you have to add the IP address yourself, the app does not actually find the TV. It just give you a possibility to enter the IP address, if the TV is not on the same network as the Homey.

Can you ping the TV and the Homey from your PC, when the TV is on ?

#55

@balmli

yes, when I do that, it returns me: { “version”: “1.1.18” }

1 When I add the TV, it finds it automatically.
2. After adding, it show the exclamation mark with ‘device not available’ message
3. I then go to set the IP. I just enter the IP without ports, in my case: ‘192.168.2.19’
4. It still shows the same error/message

#56

@Canedje Were you able to connect? I have the same model TV, but cannot connect for some reason.

#57

Yes. It worked for me. Accept the switch on function if tv is out.
So i can not switch on the tv

#58

Weird. Doesn’t work for me. I send you a PM.

#59

Added version 1.2.0, as an alpha-version now:

  • Faster communication with the TV by keeping the socket open for a while (Samsung)
  • Action to change channel (Samsung and Samsung legacy)
  • Action to send a list of keys (Samsung and Samsung legacy)

Send me a PM with your email-address if you want to participate in the alpha-testing.

1 Like
#60

this sounds useful :+1: