Homey Community Forum

Samsung SmartTV App

#61

I’m having a question… Why does it takes some time before homey can turn on the TV after it turned it off? I’m always getting a message; turning of is in progress or something like that…

#62

The app checks the state, if the TV is on/off, when it is switching the TV on/off… And it waits till it sees that the TV is actually on/off before you can turn if on/off again.

Maybe that is a bit strict…

I am considering using the “Power off” - key instead of the “Power” (toggle) to turn the TV off. Can you try the “Send key” - action with the “Power off” - key, and check if that works?

#63

I’v got a problem,

App don’t work on a UE40JU6000
It finds the tv, it connects…
But buttons and commands don’t work
I get network errors and time-outs…

I tried installing it in Legacy mode but then it don’t find the tv at all, and manualy setting the IP results in a error

what up?

My TV is new enough, it responds to [http://192.168.X.X:8001/api/v2/]
it gets me a nice Json reponse

{
“id”: “uuid:6ffc1a15-5f4e-4268-baf7-20c94cf71c6e”,
“name”: “[TV] Korova TV”,
“version”: “2.0.25”,
“device”: {
“type”: “Samsung SmartTV”,
etc
etc

What’s going wrong?
I’s like this app to work for me… very Much…
Anyone for Help

#64

Thank you for creating this app!
I get connected to my 2014 model smart tv, but non of functions are working
Actually, there is some feedback as the big power button gets lumined when I turn on the tv and dark when I torn it off (by normal remote controll)

{
“id”: “07bfa481-0082-1000-b3aa-54880eab7727”,
“name”: “[TV] Samsung”,
“version”: “2.0.24”,
“device”: {
“type”: “Samsung SmartTV”,
“duid”: “07bfa481-0082-1000-b3aa-54880eab7727”,
“model”: “14_NT14U”,
“modelName”: “UE55HU7500”,
“description”: “Samsung TV RCR”,
“networkType”: “wired”,
“ssid”: “”,
“ip”: “192.168.80.114”,
“firmwareVersion”: “Unknown”,
“name”: “[TV] Samsung”,
“id”: “07bfa481-0082-1000-b3aa-54880eab7727”,
“udn”: “07bfa481-0082-1000-b3aa-54880eab7727”,
“resolution”: “1920x1080”,
“countryCode”: “NO”,
“msfVersion”: “2.0.24”,
“smartHubAgreement”: “true”,
“developerMode”: “0”,
“developerIP”: “0.0.0.0”
},
“type”: “Samsung SmartTV”,
“uri”: “http://192.168.80.114:8001/api/v2/
}

#65

I’ll be back next week, and will try to answer then.

#66

Hi @Martijn1, @Menne_Talsma, @Tfur77

Looks like H, HU, J, JU models from 2014/2015 uses an encrypted websocket connection.

And that type of connection is not supported by the smart-tv app at the moment.

#67

Sounds like we’re fucked. Damn…

I had so hoped this would be the solution for the IR problems Homey is still suffering… .

AH well… someday Life will be perfect :stuck_out_tongue_winking_eye:
Thx 4 your time and effort @balmli.
Much appreciated!!!

#68

Just found out that my own KS model from 2016 also responds to the encrypted pairing requests that are necessary for the H, HU, J and JU models.

So it will be easier to fix, but it will require alpha-testing - participation from you guys. What do you say?

#69

Sorry to hear about the encrypted websockets.

Count me in for Alpha testing!
I am willing to help because you keep trying tot fix this problem! :+1:t2::+1:t2:

1 Like
#70

Count me in for alpha testing.

1 Like
#71

Yeah Sure Cool!! Count me in!!

Email Menne@mennetalsma.nl

1 Like
#72

Hi, this app has been sorely missing all this time! First of all, thank you so much for this effort!

Now, my UE40JU6510 from ‘15 (‘16?) is connected via Ethernet, responds to the query, is found, etc.

Can’t be controlled at all, neither by pressing app buttons, nor in flows.

No “Approve” message of any sort comes up.

I went through all the settings on the TV but just couldn’t find anything that could keep me from connecting to your app, other than Smart Security.

Is there any special setting on the TV itself that should be set?

Thanks and keep up the great work!!!

PS if you need another alpha-tester, count me in, I got two of the same year/series (different size) waiting yo be automated!

#73

Hi,

Well, I am together with a small team of alpha-testers, working on version 1.3.0 which will hopefully support H/HU/J/JU/JS - models.

The first version of the app for these models was uploaded to the app store this evening, and it is not complete yet. But not too far away…

Just send me a PM with your email address if you want to be an alpha - tester :slight_smile:

1 Like
#74

Just uploaded version 1.3.0 to app store as beta, and waiting for Athom to approve it.

#75

I can add the tv (an older 75" UE75H6475SUXXE) but no controls works?
I have tried both secure and non secure… what else can I try? :slight_smile:

#76

Hi . Have you tried the new v. 1.3.0 in app store … beta, just uploaded today ?

This version has a “Samsung (encrypted)” - device that has been developed for H/HU/J/JU/JS - models.

Try that, and please report if that works for you :slight_smile:

#77

Installed beta and removed old device… when trying to add using the new type (secure) no device is found?

1 Like
#78

Does your TV respond on http:// your-TV-ip-address :8001/ms/1.0/ ?

You tried “Samsung (encrypted)” ?

#79

Nice app. But it is not working with my brand new samsung tv

Het is the output from http://192.168.1.237:8001/api/v2/

{“device”:{“FrameTVSupport”:“false”,“GamePadSupport”:“true”,“ImeSyncedSupport”:“true”,“Language”:“nl_NL”,“OS”:“Tizen”,“PowerState”:“on”,“TokenAuthSupport”:“true”,“VoiceSupport”:“true”,“WallScreenRatio”:“0”,“WallService”:“false”,“countryCode”:“NL”,“description”:“Samsung DTV RCR”,“developerIP”:“0.0.0.0”,“developerMode”:“0”,“duid”:“uuid:0448451f-9931-41f3-b3cc-216163079b50”,“firmwareVersion”:“Unknown”,“id”:“uuid:0448451f-9931-41f3-b3cc-216163079b50”,“ip”:“192.168.1.237”,“model”:“19_MUSEM_QTV”,“modelName”:“QE55Q90RALXXN”,“name”:"[TV] Samsung Q90 Series (55)",“networkType”:“wired”,“resolution”:“3840x2160”,“smartHubAgreement”:“true”,“type”:“Samsung SmartTV”,“udn”:“uuid:0448451f-9931-41f3-b3cc-216163079b50”,“wifiMac”:“24:fc:e5:05:41:c6”},“id”:“uuid:0448451f-9931-41f3-b3cc-216163079b50”,“isSupport”:"{“DMP_DRM_PLAYREADY”:“false”,“DMP_DRM_WIDEVINE”:“false”,“DMP_available”:“true”,“EDEN_available”:“true”,“FrameTVSupport”:“false”,“ImeSyncedSupport”:“true”,“TokenAuthSupport”:“true”,“remote_available”:“true”,“remote_fourDirections”:“true”,“remote_touchPad”:“true”,“remote_voiceControl”:“true”}\n",“name”:"[TV] Samsung Q90 Series (55)",“remote”:“1.0”,“type”:“Samsung SmartTV”,“uri”:“http://192.168.1.237:8001/api/v2/",“version”:"2.0.25”}

#80

Have you checked if Secure connection is selected in adv. settings?