Homey Community Forum

Set dim levels based on time of the day - Fibaro

All,

Happy new user of Homey and expanding my smart home. I have a Fibaro dimmer (the Walli) and would like to adjust the dim level based on the time of the day. I have created a flow that when the light is turned on (using the switch) the dim level is set to a variable (which changes during the day). However when turning on the light it first moves to the initial dim level before adjusting to the level set for the time of the day. I read about the “force dimming level” flow card but that card does not seem to be part of my options. What are my options for solving this?

Thanks for your support!

Martijn

Possible to show your flow which activates the light?

Of course, is super simple

The issue is related to the flow working method. The dim level adjustment happens after the light switched on.

For the result you’d like to have you need a physical controller button (like Aqara remote rocker) in the “When” section, then switching the power and dimming the light level should be dome by a module for instance.

Hi Fac3, understood! But what is the solution then?

When I set the dim level to a certain level (e.g. during 20.00) when the light is turned-off this results in the light being turned on.

Hmm, perhaps try using scenes (with scene activation). I use the same method with a scene on my Fibaro Dimmer 2 and it works perfectly.

1 Like

I will need to look into these scenes. But I think the problem is that I have the integrated fibaro walli dimmer. Looking at your example, I do not have a card for s2 on to off.

My flow is triggered by physically turning on and therefore without a flow would also turn on the light (at the dim level from previous state). The dimming adjustments happens after. So what I would need is that the switch starts the flow but does not turn on but is turned on by a flow card (at the right dim level).

Anybody with similar experience and solutions how to tackle this? Or am I off? If there is no solution I understand that I should by pulse-switches and dimmers separately.

Thanks!

I don´t have a Walli Dimmer but according the manual Scene Activation is possible:

So this should be a way to start a flow without switching physical the light on.
However, these features may not be enabled via the advanced device settings because Athom may not have implemented this.
Alternatively, you can activate these functions via a raw configuration.

EDIT
If there is no such action card “Button Scene”, Athom have to add it. Unfortunately, this happens again and again.
I have such a action card with my Walli Switch, but I don’t have a card “Turned on”. This is an unsightly mistake on Athom’s site.