Homey Community Forum

Shelly App

I changed to HTTP requests, which proved to be 100% reliable. Just install the app on your Homey, follow the instructions (give Homey a static IP if you haven’t done that already).

Thanks for the update.
Shelly app already in use for a 2.5 that controls my ventilation system, but not yet build in the walls.

Will change a Fibaro that is causing trouble and check with HTTP requests!

The problem I had with the Shelly app, was that on/off are separate triggers. I detached both Shelly’s from the relais, since I have Hue bulbs in them. So I use the switch as a trigger for Homey. Now, when I flip the wall switch, Shelly will send the same HTTP request to Homey, so there is only 1 flow needed when the switch is flipped.
When using the Shelly (app) in Homey, I had to create every flow twice. One for when the switch was turned on, and one for off. Let me know if you need help setting it up, but it’s pretty straight forward when you read the HTTP request app instructions.

Just changed an Fibaro for Shelly and created the flow with a webhook-logic card and this works perfect, it works fast and for as long as i could test it now it works reliable… now i need to change all my flow’s :laughing:

I recently purchased a number of Shelly products and linked them to Homey. The app works well; thanks for that!
I come across a few things that I have some questions or comments about. I would like it (nice to have) if you can change more settings from the device settings via the Homey app such as LED LIGHT CONTROL, DEVICE REBOOT, FIRMWARE UPDATE etc.

With the Shelly 4Pro I run into a few problems. The device is seen as 1 device which I find difficult because it is more difficult to operate the different relays; is it possible to create a device per relay? I now control the lighting of the shed, the construction lamp and the garden lighting from the 4 Pro. I prefer to see each relay already loose device in Homey so that I can operate the device in the corresponding zone.

I also notice that the energy consumption of Relay 1 is only passed on to Homey and not of the other Relays.

  • Card for LED light control: for which device(s) is this an option, I dont see anything related for setting the LED light in the API documentation so it’s probably not possible
  • Card for reboot: sure, I’ll add it when I have some time
  • Card for firmware update: I dont see any option in the API documentation for this
  • What more options would you like to see, and please check if it’s actually posssible here: https://shelly-api-docs.shelly.cloud/

I choose to create one device for the Shelly4Pro because when creating four seperate devices for each channel Homey will also fire 4 polling requests to the Shelly4Pro to get the state for each channel. As already seen with the RGBW2 this causes performance issues (see this bug report: https://github.com/jghaanstra/cloud.shelly/issues/8). I still havent come up with an elegant solution for this and there has not been much demand for it as it seems not many people use the Shelly4Pro.

I can probably get the power for each channel and add them all to the Shelly4Pro device in Homey the same way as the relays are now under the same device. But I would need to know how the meters object looks like. Do you have any technical skills to call the /settings endpoint manually and post it here? If not I could create a test version where I do some educated guessing on how it probably looks but you would have to install a test version of the app to check.

Thank you for your answers. I understand that the Shelly 4 Pro is indeed not used much. I hereby send you the details of the settings:

{“device”:{“type”:“SHSW-44”,“mac”:"##HIDDEN##",“hostname”:“shelly4pro-CCA15A”,“num_outputs”:4, “num_meters”:4, “num_rollers”:0},“wifi_ap”:{“enabled”:false,“ssid”:“shelly4pro-CCA15A”,“key”:""},“wifi_sta”:{“enabled”:true,“ssid”:"##HIDDEN##",“ipv4_method”:“dhcp”,“ip”:null,“gw”:null,“mask”:null,“dns”:null},“wifi_sta1”:{“enabled”:false,“ssid”:null,“ipv4_method”:“dhcp”,“ip”:null,“gw”:null,“mask”:null,“dns”:null},“mqtt”: {“enable”:false,“server”:“192.168.33.3:1883”,“user”:"",“id”:“shelly4pro-CCA15A”,“reconnect_timeout_max”:60.000000,“reconnect_timeout_min”:2.000000,“clean_session”:true,“keep_alive”:60,“max_qos”:0,“retain”:false,“update_period”:30},“sntp”: {“server”:“time.google.com”},“login”:{“enabled”:true,“unprotected”:false,“username”:"##HIDDEN##",“password”:"##HIDDEN##"},“pin_code”:"",“name”:"",“fw”:“20191216-090307/v1.5.7@c30657ba”,“build_info”:{“build_id”:“20191216-090307/v1.5.7@c30657ba”,“build_timestamp”:“2019-12-16T09:03:07Z”,“build_version”:“1.0”},“cloud”:{“enabled”:false,“connected”:false},“timezone”:“Europe/Amsterdam”,“lat”:52.025002,“lng”:5.617240,“tzautodetect”:true,“time”:“22:35”,“hwinfo”:{“hw_revision”:“prod-2018-12”,“batch_id”:6},“lat”:52.025002,“lng”:5.617240,“relays”:[{“name”:null,“ison”:false,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:},{“name”:null,“ison”:true,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:},{“name”:null,“ison”:false,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:},{“name”:null,“ison”:false,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:}],“meters”:[{“power”:0.0,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 0.000],“total”:909},{“power”:70.2,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 70.022],“total”:30981},{“power”:0.0,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 0.000],“total”:806},{“power”:0.0,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 0.000],“total”:0}]}

Hey,
Is there any method how to add a Shelly 1 or 2.5 flashed with Tasmota with your App? Looks like I’m a little bit to stupid for that.:wink:

I think the Shelly app only works with the original firmware.

Robert is correct, only support for the original firmware. I’m wondering though what made you flash Tasmota in the first place. What is missing in the original firmware?

I just wanted the same easy firmware like in my Sonoffs. That’s all :wink: do you know any way to add them over MQTT?

Sure, you can add them as MQTT device using the MQTT Hub app.

Did somebody already receive a door/window sensor? I just got mine but I cant seem to pair it with my WiFi network. The pairing process is awefull and when I finally seem to be able to pair it ,it tells me something that the device did not accept my connection. Hope to build support for it but I need a working device.

The error in Dutch is “Er is een probleem opgetreden. De app heeft het verzoek om een apparaat te kiezen geannuleerd.”

Quite annoying.

[EDIT] Had to use a different device. My Android 10 device did not work.

Hi,
I’ve a problem to connect my two new shelly flood sensor to homey.
Could someone please explain how I can do this?
When I try to adapt the sonsor, the LED is blinking for ca. 1 minute, after the time the LED is going off.
According the APP instruction I have to wait until the will be solid red…
I’ve factory resetet the flood sensors, de- and reinstalled the shelly app and boot the homey.
I can’t find releated information in the community and in the www.
I think i made a mistake but i don’t know what… :slight_smile:
Thx in advance for your help.

It’s my mistake. When the LED is blinking it’s awake and you can pair your sensor by hitting the next button in the pairing wizard. I’ll fix the instructions.

:+1: :ok_hand:

Changelog

v1.15.0 - 2020-01-22

Added support for the Shelly Door Window Sensor.

Thanx to @Dino for his royal donation allowing me to buy the device.

2 Likes

Today I suddenly have problems with the Shelly app. The app lost connection with my shelly 1, and there was no way to get this right. I restarted the app even reinstalled the app. Still no way to make connection! The app has suddenly stopt and I can reinstall my shell :unamused:

Never seen it before that a device needs to be re-added after a crash. If you have to rebooted, could you please send me a crash log from the app settings.

Yes I will :+1: