Homey Community Forum

Shelly App

Thank you for your answers. I understand that the Shelly 4 Pro is indeed not used much. I hereby send you the details of the settings:

{“device”:{“type”:“SHSW-44”,“mac”:"##HIDDEN##",“hostname”:“shelly4pro-CCA15A”,“num_outputs”:4, “num_meters”:4, “num_rollers”:0},“wifi_ap”:{“enabled”:false,“ssid”:“shelly4pro-CCA15A”,“key”:""},“wifi_sta”:{“enabled”:true,“ssid”:"##HIDDEN##",“ipv4_method”:“dhcp”,“ip”:null,“gw”:null,“mask”:null,“dns”:null},“wifi_sta1”:{“enabled”:false,“ssid”:null,“ipv4_method”:“dhcp”,“ip”:null,“gw”:null,“mask”:null,“dns”:null},“mqtt”: {“enable”:false,“server”:“192.168.33.3:1883”,“user”:"",“id”:“shelly4pro-CCA15A”,“reconnect_timeout_max”:60.000000,“reconnect_timeout_min”:2.000000,“clean_session”:true,“keep_alive”:60,“max_qos”:0,“retain”:false,“update_period”:30},“sntp”: {“server”:“time.google.com”},“login”:{“enabled”:true,“unprotected”:false,“username”:"##HIDDEN##",“password”:"##HIDDEN##"},“pin_code”:"",“name”:"",“fw”:“20191216-090307/v1.5.7@c30657ba”,“build_info”:{“build_id”:“20191216-090307/v1.5.7@c30657ba”,“build_timestamp”:“2019-12-16T09:03:07Z”,“build_version”:“1.0”},“cloud”:{“enabled”:false,“connected”:false},“timezone”:“Europe/Amsterdam”,“lat”:52.025002,“lng”:5.617240,“tzautodetect”:true,“time”:“22:35”,“hwinfo”:{“hw_revision”:“prod-2018-12”,“batch_id”:6},“lat”:52.025002,“lng”:5.617240,“relays”:[{“name”:null,“ison”:false,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:},{“name”:null,“ison”:true,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:},{“name”:null,“ison”:false,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:},{“name”:null,“ison”:false,“has_timer”:false,“overpower”:false,“default_state”:“off”,“btn_type”:“toggle”,“auto_on”:0.00,“auto_off”:0.00,“max_power”:2300,“schedule”:false,“schedule_rules”:}],“meters”:[{“power”:0.0,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 0.000],“total”:909},{“power”:70.2,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 70.022],“total”:30981},{“power”:0.0,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 0.000],“total”:806},{“power”:0.0,“is_valid”:true,“timestamp”:1578263743,“counters”:[0.000, 0.000, 0.000],“total”:0}]}

Hey,
Is there any method how to add a Shelly 1 or 2.5 flashed with Tasmota with your App? Looks like I’m a little bit to stupid for that.:wink:

I think the Shelly app only works with the original firmware.

Robert is correct, only support for the original firmware. I’m wondering though what made you flash Tasmota in the first place. What is missing in the original firmware?

I just wanted the same easy firmware like in my Sonoffs. That’s all :wink: do you know any way to add them over MQTT?

Sure, you can add them as MQTT device using the MQTT Hub app.

Did somebody already receive a door/window sensor? I just got mine but I cant seem to pair it with my WiFi network. The pairing process is awefull and when I finally seem to be able to pair it ,it tells me something that the device did not accept my connection. Hope to build support for it but I need a working device.

The error in Dutch is “Er is een probleem opgetreden. De app heeft het verzoek om een apparaat te kiezen geannuleerd.”

Quite annoying.

[EDIT] Had to use a different device. My Android 10 device did not work.

Hi,
I’ve a problem to connect my two new shelly flood sensor to homey.
Could someone please explain how I can do this?
When I try to adapt the sonsor, the LED is blinking for ca. 1 minute, after the time the LED is going off.
According the APP instruction I have to wait until the will be solid red…
I’ve factory resetet the flood sensors, de- and reinstalled the shelly app and boot the homey.
I can’t find releated information in the community and in the www.
I think i made a mistake but i don’t know what… :slight_smile:
Thx in advance for your help.

It’s my mistake. When the LED is blinking it’s awake and you can pair your sensor by hitting the next button in the pairing wizard. I’ll fix the instructions.

:+1: :ok_hand:

Changelog

v1.15.0 - 2020-01-22

Added support for the Shelly Door Window Sensor.

Thanx to @Dino for his royal donation allowing me to buy the device.

2 Likes

Today I suddenly have problems with the Shelly app. The app lost connection with my shelly 1, and there was no way to get this right. I restarted the app even reinstalled the app. Still no way to make connection! The app has suddenly stopt and I can reinstall my shell :unamused:

Never seen it before that a device needs to be re-added after a crash. If you have to rebooted, could you please send me a crash log from the app settings.

Yes I will :+1: