Homey Community Forum

Shelly App


#41

v1.4.1- 2018-12-17

FIX: fix flow card issues for Shelly 4 Pro


#42

Hello. I have problem. After update Homey 2.0 RC7 not work my 4pcs shelly 1. RC4 no problem…
Last version 1.4.1
Device is unavailable.
Diagnostic report…
6fd80c36-5937-44dd-a274-c8848ffd0e90


#43

The crash report suggests your device is unreachable which would indicate network issues between Homey and your Shelly devices (it should have handled this exception better but it would indicate it’s not an issue with my app but with your network).

Can you reach the Shelly devices through the Shelly app? And have you tried restarting the Shelly app on Homey?


#44

Yes the original shelly app is working without problems. My wifi is okay. Wifi router 1x restarted. Application Shelly 1x restarted. 2 times I restarted Home. Still the same problem.


#45

Then I do not know. The crash report says that your Shelly is unreachable.

UnhandledPromiseRejectionWarning: FetchError: request to http://192.168.31.239/relay/0?turn=off failed, reason: connect EHOSTUNREACH 192.168.31.239:80 at ClientRequest.<anonymous> (/node_modules/node-fetch/lib/index.js:1345:11)

I’m not on firmware 2.x so I can’t confirm myself if this is a generic issue or an issue only for you.


#46

So the problem is with me. I had a power failure at home yesterday. I did not know about it. Shelly devices have changed their ip address. I did not have a solid ip. I set Restrict login. The next time the IP argument will not be changed. Excuse me for mistakes.


#47

Set a static IP for all domotic devices in your router.


#48

Somebody test if shelly plug S works?

@Phuturist

The shelly 2 receibe a firmware update, now after a calibration the shelly 2 can open/close in a percentage. In future updates of the app I think that it’s a good idea to add the percentage in the flow cards.


it’s the same as opening for time, but it’s more “professional” :slight_smile:


#49

Thanx, I’ll have a look at it some time soon.


#50

@Eduardo_Rodriguez do you know how to do a CLI install? I have uploaded a new release to Github which adds partial support for setting the blinds to a specific percentage. It’s partial as according to the API docs from Shelly it’s not possible to actually retrieve the current percentage the blinds are in. This means Homey can get out of sync if you manual control the blinds or use the Shelly app to control the blinds as well. I’ll ask Shelly if they plan to add this as well.

But for now I’d like to know if the release on Github works for at least setting the blinds to a specific percentage.


#51

@Phuturist

I update the app and the flow cards is the same as the previous version, “set state” and “change roller shutter” (in seconds).

I delete one of the roller shutter in devices, and now i can’t add it again.


#52

The new capabilities should become available after re-adding it. What does the console say when you try to re-add your device (use athom app run command).


#53

The console says nothing @Phuturist!


#54

Hmmm, what is the error during pairing?


#55

No error, I select the type of device, put IP and user/pass and no device is added.


#56

You are on firmware 2.x? On firmware 1.x it should at least give some info when testing the connection.


#57

I’m on 1.5.13. No info and no error. Return to version 1.4.2 of your app and add the device correctly.


#58

Ok, I’ll look at it tomorrow. Really don’t know what is wrong, I haven’t changed that much.


#59

I have checked the code. I cant explain this behaviour. I have uploaded a new version on Github (master) which adds extra logging and also implements synchronisation between the device and Homey. I have been in touch with the company behind Shelly and they gave me extra information that has not been added to the API documentation just yet.

Could you try this version with athom run app and let me know what the command line logging tells you but also what the browser console tells you (in chrome you can access this by F12 and tab console) when pairing the device.


#60

I install new version.

I can´t add the shelly 2. This is the log in “athom run app”:

2018-12-29 11:50:38 [log] [ManagerDrivers] [shelly2-rollershutter] [1] TypeError: Cannot read property ‘0’ of undefined
at util.sendCommand.then.result (/drivers/shelly2-rollershutter/device.js:57:39)
at
at process._tickCallback (internal/process/next_tick.js:189:7)
2018-12-29 11:50:38 [log] [ManagerDrivers] [shelly2-rollershutter] [0] TypeError: Cannot read property ‘0’ of undefined
at util.sendCommand.then.result (/drivers/shelly2-rollershutter/device.js:57:39)
at
at process._tickCallback (internal/process/next_tick.js:189:7)
{ type: ‘SHSW-21’,
mac: ‘827D3A5B270D’,
auth: false,
fw: ‘20181228-125308/v1.4.3@083c8385’,
num_outputs: 2,
num_meters: 1,
num_rollers: 1 }

If open homey in browser, in console nothing happens when add the device.

when you talk about the synchronization is it because homey knows what percentage are the blinds open now?