Homey Community Forum

Slowness and offline problems after 2.5

I had an issue with Zigbee after 2.5 as well. I did PTP for 20 min. After the restart, my Zigbee didn’t start. I restarted the Philips app after 5 min or so, and it started working again.

This sounds kinda interesting I have an similar experience after the last couple of days. Even today I got several messages on the Android app that Homey was offline. After 4 times retrying he would finally work but still having problems with stability and responsive on the Zigbee side.
Just initiated a PTP but after that I will remove the Hue app and sees how it goes then.

It may be a different issue, not related to version 2.5. I have a scheduled reboot every 3-4 days because my Homey gets unpredictable with offline messages after that.

Mine is restarting every day at 05:00 in the morning but still having unpredictable issues.

I have the same issues and send “every day” a support requests, but did not get any answer since weeks. I also restart homey at 5 in the morning, but have also connectivity issues during the day.

Does anyone has an idea how I can monitor the online status of homey with a flow and restart it dynamically when it looses internet, like a ping to DNS Server every minute?

I also think this issue is caused by some apps, as I have a second homey (2019) in another house with only two apps and he is stable.
only my old one (which was stable until 2.x) needs now attention every day.

Thanks for your ideas :bulb:

If you can read Dutch than this thread may give you some helpfull information:

1 Like

Should go for the Pro version if you intend to run Homey as power user! I never had problem with Zigbee, could be that I have the zigbee bridge 2 meter from the Homey Pro hub (philips hue bridge).

What I do miss in the Homey is a free memory app, could run it as a flow once every hour, if you dont have the Pro version. I got probably almost 200 units connected now, pretty complex flows etc, so even the Pro version is working its resources.

I would guess your problems are related to wifi and router. I did have the same problem so I installed a wifi repeater and connected the Homey to this one instead of the main router. I also miss an RJ-45 on the Homey!

IMG_2299router

1 Like

Same here. The app is really slow, almost impossible to work with flows. Ofte get “Homey is offline”. Started a couple of days ago. Never been this sluggish before.

Update:
I have deleted more apps, only 9 left, ~30 flows.
I did an PTP and everyting is up and running, if so, wery slow…
Tonight I restarted all the apps and it got a lot better, even though not optimal.
I still have a delay of 5-10 seconds of everything and the app loads really slow. I can’t load the More - Settings - General page in the app (IOS) and see the Memory status, gets “An unknown error occurred”.
Under the page (in app) More - Settings - General - About, I can read that the Load average is about 125%, that can’t be normal…?
Is there some one else who has similar problems, any ideas what to do next?
System%20-%20Memory%20Usage
You can see the PTP at 10:00 and restart of all apps about 20:00.

Have you tried a different power supply? The one that comes with Homey can become notoriously unstable after a while. Any USB power supply that can deliver 2A or more will suffice.

Yes, I have read about that in another topic so I changed to a better power-source a few days ago.
This morning everything is running smooth, no delay and every function is working. It seems that my restart of all apps somehow solved it.
I hope it will stay that way when I add some more apps that I need.
Thanks for all support in this forum, you guys rule! :slight_smile:

Sorry for going off topic, but those graphs for memory and load seems to come from Insights. I’ve searched the forums and tried looking in every corner of the app for hours and I can’t find how to do monitor that.

u sure? when i search on insights…… it gives me the answer in the first couple of results.

Yes, but where does it show how to monitor memory and load? I only get temperature/humidity when I open the page.

Go to the mobile app, press MORE and there it should be.:


Open the link, wait for the page to load and find “System”:

Or go to: https://insights.homey.app/ log in, choose your Homey and do the same as above, just look for “System”

There is no “System” section when I open Insights, regardless of whether I open it on the phone or on the PC. Just the “built in’” climate data and the temp/humidity sensors I’ve added myself.

Not 100% sure, but maybe you have to enable experiment user in the homey app.

more-----settings----experiments----power user

1 Like

Indeed, that should do the trick!

OK. I currently don’t see a need to be experimental and I understand a complete restart is needed to revert to non-experiment if I want to, but now I know how to enable this if I see something strange.
Thank you.

Enabling power user has nothing to do with beta firmware. That’s something completely different. Power user can be enabled and disabled on the fly.