Homey Community Forum

SMA Inverters App

As mentioned in the description you need Webconnect, Datamanager M or direct ethernet connection to use the modbus protocol. So no Bluetooth support.

Hi,
I’m stuk on:

Then click on your inverter in the left pane and after that on the settings tab. Click on the external communications menu item and click on edit. Now enable the option ‘Modbus TCP Server’ and if available and not already enabled the option ‘Webconnect’.

Where can i find this?

THX!

It’s right there in the text you quoted. You need to select the “Instellingen” tab. Or am I missing something … :thinking:

Sorry, screenshot was wrong.
In the “Instellingen” tab there is:

And the sunny explore seems to be connected as instalateur at 1111

I have the ethernet piggy back module installed in de SMA

THX!

Perhaps your inverter is in some sort of sleep mode because there is no sun atm, try again during daytime when you are sure your inverter is busy inverting.

I still cant connect, stuck on:

Then click on your inverter in the left pane and after that on the settings tab. Click on the external communications menu item and click on edit. Now enable the option ‘Modbus TCP Server’ and if available and not already enabled the option ‘Webconnect’.

I dont see this option: Click on the external communications menu item and click on edit

Can someone sent me the right screenshot where to click?

Thx!

Hi, I think it is because you are not logged in as installer, I had the same problem this week, got my homey last monday, treid to log in with 1111 first and could not find the Modbus TCP Server settings.

Logged in with 1111:

Then I remembered that I changed the installer code with an other password, logged in an there the setting appeared.!

Logged in with the right password:

you miss the green check mark at the inverter, that’s why I think you use the wrong installer code / password.

Great!
THX, i wil check the password again.
Let you know.

@rleunk Now it works! I also changed the password a long time ago…

In insight there is a steady flow if data comming in, in the app it says now communication for 2 hour
Is this a problem in the app?

THX!

@Phuturist You cab add the SB 3000TL-21 048
It works perfect now!

Can we share some flow examples?

THX!!!

1 Like

I can verify that STP8000 works great with the app.

1 Like

wow - I am so happy to see that SMA invertes will be supported :slight_smile:

Is there a support for the SMA Sunny Boy Storage 2.5, too?

Cheers,
Sven

See the description in the opening topic.

Below is a shortend list of supported inverters including the available connection types for each inverter. View the complete list of supported inverters in the second tab of this Google sheets document .

1 Like

Maybe I have asked the wrong question :wink: I know that my inverters use modbus :wink: because I read them out via iobroker.

But does the SMA inverters app is able to read them, too?

Maybe I quoted the wromg piece of text from the description … :wink:

Unfortunately the configuration for reading out the data of each of these converters seems to differ. I have only tested it with an older Sunny Boy 2500TL. Support for other inverters may need to be added seperately and might require some research. If you connect your inverter and you do not see correct values appear in the Homey device, please use the support topic to ask for support for your type of inverter.

1 Like

:slight_smile: thank you very much for your support :slight_smile:

v1.1.0 - 2019-04-17

  • NEW: support for Sunny Boy Storage
1 Like

it works like a charm :smile: :+1::clap:

The app works like a charm!
I now also get a message when there is a lot of excitement, but I get a lot too many messages.
How can I make this flow the best way to get only 1 notification if the power generated exceeds 1000 watts and preferably if this takes more than 10 minutes.

THX !!!

THX!!!

Use a true/false variable with a couple of flows.

if energy > 1000 set variable to true
if energy < 1000 set variable to false
if variable is set to true start countdown timer for 10 minutes
if variable is set to false and countdown timer is runnin than stop countdown timer
if countdown timer has counted down sent notification.