Homey Community Forum

Smart presence triggers too quick

Hi all!
I have a smart presence flow which goes like this:

So it trigger’s when someone’s phone looses its IP address in the house LAN network. But because I have different access points in my house (for a specific reason), the flow also triggers if the phone switches from access point, which of course isn’t needed. Usually switching access point takes less than a few seconds.

I hoped to solve it by setting a delay or something like that in the flow. Something like: IF xxx’s left the house AND xxx stays out of the house for 1 minute, THEN send out notification.

But I can’t see a way how to set this AND condition. Anyone got an idea? Or has an alternative solution?

The use of the countdown app could help. If the connection is lost then set a timer for 60 secs.
If the countdown timer is at zero and there is still no connection then the person has left.

There should be a delay of 900 seconds, that’s default. Its in the advanced settings of the device. You could increase it to a higher number.

Where exactly can I change this? I don’t see it when going to More > Apps > Smart Presence.

Ah got it. Under the device! (person)

But 900 seconds… That’s 15 minutes…
Auto changing access points only takes a few seconds at maximum. So not sure if increasing this number will help solving the problem?

so smart presence set your away when changing acces point. does it also set your home again?

i agree that 900 sec is way to long, dont use it anymore for my home/away detection but remember the max i used was around 60 seconds i believe. In combination with a timer like frank said.

Yes and that’s the weird thing. It should only set you away after that time, makes me wonder is it is something else what makes you go away.

Yes it sets me back home after reconnecting. Usually both (detecting I’m away and detecting I’m back) takes 1 minute at maximum.